summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Deutschmann <whissi@gentoo.org>2018-10-29 15:53:23 +0100
committerThomas Deutschmann <whissi@gentoo.org>2018-10-29 15:54:08 +0100
commit14d0571686b2750162afece2646eabfa1203fbe4 (patch)
tree2a846b3fb4f15c7822c16c0691923bdb194d7b5c /dev-db/mysql++/mysql++-3.2.4.ebuild
parentdev-libs/librdkafka: bump to v0.11.6 (diff)
downloadgentoo-14d0571686b2750162afece2646eabfa1203fbe4.tar.gz
gentoo-14d0571686b2750162afece2646eabfa1203fbe4.tar.bz2
gentoo-14d0571686b2750162afece2646eabfa1203fbe4.zip
dev-db/mysql++: bump to v3.2.4
Package-Manager: Portage-2.3.51, Repoman-2.3.11 Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
Diffstat (limited to 'dev-db/mysql++/mysql++-3.2.4.ebuild')
-rw-r--r--dev-db/mysql++/mysql++-3.2.4.ebuild61
1 files changed, 61 insertions, 0 deletions
diff --git a/dev-db/mysql++/mysql++-3.2.4.ebuild b/dev-db/mysql++/mysql++-3.2.4.ebuild
new file mode 100644
index 000000000000..24978aa9f91f
--- /dev/null
+++ b/dev-db/mysql++/mysql++-3.2.4.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit autotools libtool flag-o-matic
+
+DESCRIPTION="C++ API interface to the MySQL database"
+HOMEPAGE="https://tangentsoft.net/mysql++/"
+SRC_URI="https://www.tangentsoft.net/mysqlpp/releases/${P}.tar.gz"
+
+LICENSE="LGPL-2"
+SLOT="0/3"
+KEYWORDS="~alpha ~amd64 ~hppa ~mips ~ppc ~sparc ~x86 ~amd64-linux ~ppc-macos ~x64-macos ~x86-macos"
+IUSE="doc"
+
+RDEPEND="|| ( dev-db/mysql-connector-c dev-db/mariadb-connector-c )"
+DEPEND="${RDEPEND}"
+DOCS=( CREDITS.txt HACKERS.md doc/ssqls-pretty )
+PATCHES=(
+ "${FILESDIR}"/${PN}-3.2.1-gold.patch
+ "${FILESDIR}"/${PN}-3.2.4-as-needed.patch
+ "${FILESDIR}"/${PN}-3.2.4-only-unit-tests.patch
+)
+
+src_prepare() {
+ # Bug filed upstream about deprecated std::auto_ptr
+ append-cxxflags $(test-flags-CXX -Wno-deprecated-declarations)
+ # Bad symlink for libtool in the archive
+ rm "${S}/ltmain.sh" || die
+
+ default
+
+ # we don't use eautoreconf to avoid dev-util/bakefile
+ _elibtoolize --auto-ltdl --install --copy --force
+ elibtoolize
+
+ # Current MySQL libraries are always with threads and slowly being removed
+ sed -i -e "s/mysqlclient_r/mysqlclient/" "${S}/configure" || die
+ rm "${S}/doc/"README-*-RPM.txt || die
+}
+
+src_configure() {
+ local myconf=(
+ --enable-thread-check
+ --with-mysql="${EPREFIX%/}/usr"
+ --with-mysql-lib="${EPREFIX}$(mysql_config --variable=pkglibdir)"
+ --with-mysql-include="${EPREFIX}$(mysql_config --variable=pkgincludedir)"
+ )
+ econf "${myconf[@]}"
+}
+
+src_test() {
+ ONLY_UNIT_TESTS=1 "${S}"/dtest || die
+}
+
+src_install() {
+ default
+ # install the docs and HTML pages
+ use doc && dodoc -r doc/pdf/ doc/refman/ doc/userman/ doc/html/
+}