summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-db/mysql-connector-c++/files/mysql-connector-c++-1.1.0-fix-cmake.patch
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-db/mysql-connector-c++/files/mysql-connector-c++-1.1.0-fix-cmake.patch')
-rw-r--r--dev-db/mysql-connector-c++/files/mysql-connector-c++-1.1.0-fix-cmake.patch85
1 files changed, 85 insertions, 0 deletions
diff --git a/dev-db/mysql-connector-c++/files/mysql-connector-c++-1.1.0-fix-cmake.patch b/dev-db/mysql-connector-c++/files/mysql-connector-c++-1.1.0-fix-cmake.patch
new file mode 100644
index 000000000000..d32fa07f1e0b
--- /dev/null
+++ b/dev-db/mysql-connector-c++/files/mysql-connector-c++-1.1.0-fix-cmake.patch
@@ -0,0 +1,85 @@
+diff -urN mysql-connector-c++-1.1.0.old/CMakeLists.txt mysql-connector-c++-1.1.0/CMakeLists.txt
+--- mysql-connector-c++-1.1.0.old/CMakeLists.txt 2011-07-30 13:15:44.000000000 +0200
++++ mysql-connector-c++-1.1.0/CMakeLists.txt 2011-07-30 13:16:18.000000000 +0200
+@@ -232,7 +232,7 @@
+ "install_manifest.txt")
+ SET(PRJ_COMMON_IGNORE_FILES ${COMMON_IGNORE_FILES} "ANNOUNCEMENT_102_ALPHA" "ANNOUNCEMENT_103_ALPHA" "ANNOUNCEMENT_104_BETA" "ANNOUNCEMENT_105_GA" "ANNOUNCEMENT_110_GA" "ANNOUNCEMENT_DRAFT" )
+
+-SET(CPACK_SOURCE_IGNORE_FILES ${PRJ_COMMON_IGNORE_FILES} "./cppconn/config.h$" "./driver/nativeapi/binding_config.h$")
++SET(CPACK_SOURCE_IGNORE_FILES ${PRJ_COMMON_IGNORE_FILES} "${CMAKE_CURRENT_SOURCE_DIR}/cppconn/config.h$" "${CMAKE_CURRENT_SOURCE_DIR}/driver/nativeapi/binding_config.h$")
+ SET(CPACK_PACKAGE_IGNORE_FILES ${PRJ_COMMON_IGNORE_FILES} "something_there" )
+ SET(CPACK_SOURCE_GENERATOR "TGZ")
+
+diff -urN mysql-connector-c++-1.1.0.old/cppconn/CMakeLists.txt mysql-connector-c++-1.1.0/cppconn/CMakeLists.txt
+--- mysql-connector-c++-1.1.0.old/cppconn/CMakeLists.txt 2011-07-30 13:15:44.000000000 +0200
++++ mysql-connector-c++-1.1.0/cppconn/CMakeLists.txt 2011-07-30 14:10:34.000000000 +0200
+@@ -55,7 +55,7 @@
+
+ SET(MYSQLCPPCONN_INSTALL_HEADERS
+ build_config.h
+- config.h
++ ${CMAKE_CURRENT_BINARY_DIR}/config.h
+ connection.h
+ datatype.h
+ driver.h
+diff -urN mysql-connector-c++-1.1.0.old/driver/CMakeLists.txt mysql-connector-c++-1.1.0/driver/CMakeLists.txt
+--- mysql-connector-c++-1.1.0.old/driver/CMakeLists.txt 2011-07-30 13:15:44.000000000 +0200
++++ mysql-connector-c++-1.1.0/driver/CMakeLists.txt 2011-07-30 13:20:36.000000000 +0200
+@@ -26,6 +26,9 @@
+
+ INCLUDE_DIRECTORIES(${MYSQLCPPCONN_SOURCE_DIR})
+ INCLUDE_DIRECTORIES(${MYSQLCPPCONN_SOURCE_DIR}/cppconn)
++INCLUDE_DIRECTORIES(${MYSQLCPPCONN_BINARY_DIR})
++INCLUDE_DIRECTORIES(${MYSQLCPPCONN_BINARY_DIR}/cppconn)
++INCLUDE_DIRECTORIES(${MYSQLCPPCONN_BINARY_DIR}/driver/nativeapi)
+ INCLUDE_DIRECTORIES(${MYSQLCPPCONN_BOOST_INCLUDE_DIRS})
+ MESSAGE(STATUS "BOOST_INCLUDE_DIRS=${MYSQLCPPCONN_BOOST_INCLUDE_DIRS}")
+
+@@ -149,20 +152,22 @@
+ nativeapi/native_statement_wrapper.h
+ nativeapi/mysql_native_resultset_wrapper.h
+ nativeapi/native_resultset_wrapper.h
+- ../cppconn/warning.h
+- ../cppconn/statement.h
+- ../cppconn/sqlstring.h
+- ../cppconn/resultset_metadata.h
+- ../cppconn/resultset.h
+- ../cppconn/prepared_statement.h
+- ../cppconn/parameter_metadata.h
+- ../cppconn/metadata.h
+- ../cppconn/exception.h
+- ../cppconn/driver.h
+- ../cppconn/datatype.h
+- ../cppconn/connection.h
+- ../cppconn/config.h
+- ../cppconn/build_config.h
++ ${CMAKE_CURRENT_SOURCE_DIR}/cppconn/warning.h
++ ${CMAKE_CURRENT_SOURCE_DIR}/cppconn/statement.h
++ ${CMAKE_CURRENT_SOURCE_DIR}/cppconn/sqlstring.h
++ ${CMAKE_CURRENT_SOURCE_DIR}/cppconn/resultset_metadata.h
++ ${CMAKE_CURRENT_SOURCE_DIR}/cppconn/resultset.h
++ ${CMAKE_CURRENT_SOURCE_DIR}/cppconn/prepared_statement.h
++ ${CMAKE_CURRENT_SOURCE_DIR}/cppconn/parameter_metadata.h
++ ${CMAKE_CURRENT_SOURCE_DIR}/cppconn/metadata.h
++ ${CMAKE_CURRENT_SOURCE_DIR}/cppconn/exception.h
++ ${CMAKE_CURRENT_SOURCE_DIR}/cppconn/driver.h
++ ${CMAKE_CURRENT_SOURCE_DIR}/cppconn/datatype.h
++ ${CMAKE_CURRENT_SOURCE_DIR}/cppconn/connection.h
++ ${CMAKE_CURRENT_SOURCE_DIR}/cppconn/config.h
++ ${CMAKE_CURRENT_BINARY_DIR}/cppconn/config.h
++ ${CMAKE_CURRENT_SOURCE_DIR}/cppconn/build_config.h
++ ${CMAKE_CURRENT_BINARY_DIR}/cppconn/build_config.h
+
+ )
+
+@@ -271,8 +276,8 @@
+ )
+ ELSE(WIN32)
+ INSTALL(TARGETS mysqlcppconn mysqlcppconn-static
+- LIBRARY DESTINATION lib
+- ARCHIVE DESTINATION lib
++ LIBRARY DESTINATION lib${LIB_SUFFIX}
++ ARCHIVE DESTINATION lib${LIB_SUFFIX}
+ )
+ ENDIF(WIN32)
+