summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-db/mysql-connector-c/files
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-db/mysql-connector-c/files')
-rw-r--r--dev-db/mysql-connector-c/files/conn-c-includes.patch15
-rw-r--r--dev-db/mysql-connector-c/files/openssl-cmake-detection.patch12
2 files changed, 27 insertions, 0 deletions
diff --git a/dev-db/mysql-connector-c/files/conn-c-includes.patch b/dev-db/mysql-connector-c/files/conn-c-includes.patch
new file mode 100644
index 000000000000..fcde71f3f4ee
--- /dev/null
+++ b/dev-db/mysql-connector-c/files/conn-c-includes.patch
@@ -0,0 +1,15 @@
+diff -aurN a/include/CMakeLists.txt b/include/CMakeLists.txt
+--- a/include/CMakeLists.txt 2015-07-14 13:06:04.424091000 -0400
++++ b/include/CMakeLists.txt 2015-07-14 13:24:43.434091000 -0400
+@@ -55,6 +55,11 @@
+ byte_order_generic_x86.h
+ little_endian.h
+ big_endian.h
++ my_thread_local.h
++ thr_cond.h
++ thr_lock.h
++ thr_mutex.h
++ thr_rwlock.h
+ ${HEADERS_GEN_CONFIGURE}
+ )
+
diff --git a/dev-db/mysql-connector-c/files/openssl-cmake-detection.patch b/dev-db/mysql-connector-c/files/openssl-cmake-detection.patch
new file mode 100644
index 000000000000..3a5f53e7ba35
--- /dev/null
+++ b/dev-db/mysql-connector-c/files/openssl-cmake-detection.patch
@@ -0,0 +1,12 @@
+diff -aurN a/cmake/ssl.cmake b/cmake/ssl.cmake
+--- a/cmake/ssl.cmake 2014-11-21 00:39:51.000000000 -0500
++++ b/cmake/ssl.cmake 2015-01-27 08:45:36.771744344 -0500
+@@ -166,7 +166,7 @@
+ # Encoded as MNNFFPPS: major minor fix patch status
+ FILE(STRINGS "${OPENSSL_INCLUDE_DIR}/openssl/opensslv.h"
+ OPENSSL_VERSION_NUMBER
+- REGEX "^#define[\t ]+OPENSSL_VERSION_NUMBER[\t ]+0x[0-9].*"
++ REGEX "^#[\t ]*define[\t ]+OPENSSL_VERSION_NUMBER[\t ]+0x[0-9].*"
+ )
+ STRING(REGEX REPLACE
+ "^.*OPENSSL_VERSION_NUMBER[\t ]+0x([0-9]).*$" "\\1"