summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrian Evans <grknight@gentoo.org>2018-01-24 16:50:44 -0500
committerBrian Evans <grknight@gentoo.org>2018-01-24 16:55:36 -0500
commita51d8843bdf6d39c7964abac3b751f658ed4a078 (patch)
tree2bea89de1d12401edc52ec6deda98cc6cfc07d22 /dev-db/mysql-init-scripts
parentmail-client/neomutt: Fix berkdb slots (diff)
downloadgentoo-a51d8843bdf6d39c7964abac3b751f658ed4a078.tar.gz
gentoo-a51d8843bdf6d39c7964abac3b751f658ed4a078.tar.bz2
gentoo-a51d8843bdf6d39c7964abac3b751f658ed4a078.zip
dev-db/mysql-init-scripts: Add 'keyword -timeout'
It may take longer than 60 seconds to startup. Let the script handle any timeouts. Package-Manager: Portage-2.3.20, Repoman-2.3.6
Diffstat (limited to 'dev-db/mysql-init-scripts')
-rw-r--r--dev-db/mysql-init-scripts/files/init.d-2.25
-rw-r--r--dev-db/mysql-init-scripts/mysql-init-scripts-2.2-r3.ebuild64
2 files changed, 68 insertions, 1 deletions
diff --git a/dev-db/mysql-init-scripts/files/init.d-2.2 b/dev-db/mysql-init-scripts/files/init.d-2.2
index f6ad52496e4e..5603f9e60310 100644
--- a/dev-db/mysql-init-scripts/files/init.d-2.2
+++ b/dev-db/mysql-init-scripts/files/init.d-2.2
@@ -1,5 +1,5 @@
#!/sbin/openrc-run
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
extra_commands="checkconfig"
@@ -12,6 +12,9 @@ depend() {
use net.lo
# localmount needed for $basedir
need localmount
+ # This service has its own timeout and may need to wait for repairs
+ # or remote synchronization
+ keyword -timeout
}
get_config() {
diff --git a/dev-db/mysql-init-scripts/mysql-init-scripts-2.2-r3.ebuild b/dev-db/mysql-init-scripts/mysql-init-scripts-2.2-r3.ebuild
new file mode 100644
index 000000000000..f405a38a67f6
--- /dev/null
+++ b/dev-db/mysql-init-scripts/mysql-init-scripts-2.2-r3.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit systemd s6
+
+DESCRIPTION="Gentoo MySQL init scripts."
+HOMEPAGE="https://www.gentoo.org/"
+SRC_URI=""
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE=""
+
+DEPEND=""
+# This _will_ break with MySQL 5.0, 4.x, 3.x
+# It also NEEDS openrc for the save_options/get_options builtins.
+# The s6 support was added after openrc 0.16.2
+RDEPEND="
+ !<dev-db/mysql-5.1
+ !<sys-apps/openrc-0.16.2
+ "
+# Need to set S due to PMS saying we need it existing, but no SRC_URI
+S=${WORKDIR}
+
+src_install() {
+ newconfd "${FILESDIR}/conf.d-2.0" "mysql"
+
+ # s6 init scripts
+ if use amd64 || use x86 ; then
+ newconfd "${FILESDIR}/conf.d-2.0" "mysql-s6"
+ newinitd "${FILESDIR}/init.d-s6-2.2" "mysql-s6"
+ s6_install_service mysql "${FILESDIR}/run-s6"
+ s6_install_service mysql/log "${FILESDIR}/log-s6"
+ fi
+
+ newinitd "${FILESDIR}/init.d-2.2" "mysql"
+ newinitd "${FILESDIR}/init.d-supervise" "mysql-supervise"
+
+ # systemd unit installation
+ exeinto /usr/libexec
+ doexe "${FILESDIR}"/mysqld-wait-ready
+ systemd_newunit "${FILESDIR}/mysqld-v2.service" "mysqld.service"
+ systemd_newunit "${FILESDIR}/mysqld_at-v2.service" "mysqld@.service"
+ systemd_dotmpfilesd "${FILESDIR}/mysql.conf"
+
+ insinto /etc/logrotate.d
+ newins "${FILESDIR}/logrotate.mysql" "mysql"
+}
+
+pkg_postinst() {
+ if use amd64 || use x86 ; then
+ elog ""
+ elog "To use the mysql-s6 script, you need to install the optional sys-apps/s6 package."
+ elog "If you wish to use s6 logging support, comment out the log-error setting in your my.cnf"
+ fi
+
+ elog ""
+ elog "Starting with version 10.1.8, MariaDB includes an improved systemd unit named mariadb.service"
+ elog "You should prefer that unit over this package's mysqld.service."
+ einfo ""
+}