summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-db/mysql-udf-infusion
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-db/mysql-udf-infusion')
-rw-r--r--dev-db/mysql-udf-infusion/Manifest1
-rw-r--r--dev-db/mysql-udf-infusion/metadata.xml10
-rw-r--r--dev-db/mysql-udf-infusion/mysql-udf-infusion-20110109.ebuild68
3 files changed, 79 insertions, 0 deletions
diff --git a/dev-db/mysql-udf-infusion/Manifest b/dev-db/mysql-udf-infusion/Manifest
new file mode 100644
index 000000000000..4d1a582d468c
--- /dev/null
+++ b/dev-db/mysql-udf-infusion/Manifest
@@ -0,0 +1 @@
+DIST infusion-udf_infusion-8599a9c.tar.gz 5470 SHA256 46e924a7d22d61bbede7f22cb87c06b8c1c7cdc5357a9b2ad199f234f9a23441 SHA512 4a9cee8b45b0cd8e7e00210de79f8a42cc3154185c1b31e441f27d51300c113a46639ecce98d0c748aada0538e9bbfc55ef71f017c19c403a84c2e5d478c09fe WHIRLPOOL c55a070c2010afa248127848f0807c45b622f00f0e1389ae541463cde419e7b0de298873450e9fa790b024c22dd7efdb43f886c5939fb8aafb7b711a8aac73d7
diff --git a/dev-db/mysql-udf-infusion/metadata.xml b/dev-db/mysql-udf-infusion/metadata.xml
new file mode 100644
index 000000000000..0b109bb657ef
--- /dev/null
+++ b/dev-db/mysql-udf-infusion/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>maintainer-needed@gentoo.org</email>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">infusion/udf_infusion</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-db/mysql-udf-infusion/mysql-udf-infusion-20110109.ebuild b/dev-db/mysql-udf-infusion/mysql-udf-infusion-20110109.ebuild
new file mode 100644
index 000000000000..69d5b4552956
--- /dev/null
+++ b/dev-db/mysql-udf-infusion/mysql-udf-infusion-20110109.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit eutils toolchain-funcs
+
+MY_REV="8599a9c" # checkout revision
+MY_USR="infusion" # user name
+
+MY_PN="udf_infusion"
+MY_P="${MY_USR}-${MY_PN}-${MY_REV}"
+
+DESCRIPTION="New functions for MySQL implemented as UDF"
+HOMEPAGE="http://www.xarg.org/2010/11/mysql-my-new-playground/"
+SRC_URI="https://github.com/${MY_USR}/${MY_PN}/tarball/${MY_REV} -> ${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=">=virtual/mysql-5.1"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${MY_P}"
+
+# compile helper
+_compile() {
+ local CC="$(tc-getCC)"
+ echo "${CC} ${@}" && "${CC}" "${@}"
+}
+
+pkg_setup() {
+ MYSQL_PLUGINDIR="$(mysql_config --plugindir)"
+ MYSQL_INCLUDE="$(mysql_config --include)"
+}
+
+src_prepare() {
+ # fix soname
+ sed -i -e "s|${MY_PN}\.so|${PN//-/_}.so|g" *.sql
+
+ # add LF
+ echo >> create.sql
+ echo >> delete.sql
+}
+
+src_compile() {
+ _compile ${CFLAGS} -Wall -fPIC ${MYSQL_INCLUDE} \
+ -shared ${LDFLAGS} -o ${PN//-/_}.so ${MY_PN}.c
+}
+
+src_install() {
+ exeinto "${MYSQL_PLUGINDIR}"
+ doexe *.so
+ dodoc *.sql
+}
+
+pkg_postinst() {
+ elog
+ elog "Please have a look at the documentation, how to"
+ elog "enable/disable the UDF functions of ${PN}."
+ elog
+ elog "The documentation is located here:"
+ elog "/usr/share/doc/${PF}"
+ elog
+}