summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHasan ÇALIŞIR <hasan.calisir@psauxit.com>2019-07-28 23:20:47 +0300
committerJoonas Niilola <juippis@gentoo.org>2019-07-31 21:59:15 +0300
commitba9322f36ca48d07c585029b6b5d0c6b8cefb76c (patch)
tree1bb9b82fd5e4a9619c979c9615d48c5fa09d01a8 /dev-db/mysqltuner/mysqltuner-1.7.15.ebuild
parentdev-ruby/dotenv: add 2.7.5 (diff)
downloadgentoo-ba9322f36ca48d07c585029b6b5d0c6b8cefb76c.tar.gz
gentoo-ba9322f36ca48d07c585029b6b5d0c6b8cefb76c.tar.bz2
gentoo-ba9322f36ca48d07c585029b6b5d0c6b8cefb76c.zip
dev-db/mysqltuner: bump to 1.7.15
Version bump to 1.7.15. Also introduces new patch that fixes password detecting error. Package-Manager: Portage-2.3.66, Repoman-2.3.16 Signed-off-by: Hasan ÇALIŞIR <hasan.calisir@psauxit.com> Closes: https://github.com/gentoo/gentoo/pull/12565 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'dev-db/mysqltuner/mysqltuner-1.7.15.ebuild')
-rw-r--r--dev-db/mysqltuner/mysqltuner-1.7.15.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/dev-db/mysqltuner/mysqltuner-1.7.15.ebuild b/dev-db/mysqltuner/mysqltuner-1.7.15.ebuild
new file mode 100644
index 000000000000..4d6ffb075a99
--- /dev/null
+++ b/dev-db/mysqltuner/mysqltuner-1.7.15.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+MY_PN=MySQLTuner-perl
+
+DESCRIPTION="MySQLTuner is a high-performance MySQL tuning script"
+HOMEPAGE="https://github.com/major/MySQLTuner-perl"
+SRC_URI="https://github.com/major/${MY_PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-lang/perl
+ virtual/mysql
+ virtual/perl-Getopt-Long"
+
+DEPEND="${RDEPEND}"
+
+PATCHES=(
+ # Fix password detecting under MySQL 5.7 upstream #442 #427 #441
+ "${FILESDIR}/${P}-password.patch" )
+
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+DOCS=( USAGE.md CONTRIBUTING.md INTERNALS.md basic_passwords.txt vulnerabilities.csv )
+
+src_install() {
+ einstalldocs
+
+ newbin "${PN}.pl" "${PN}"
+
+ # Passwords and vulnerabilities are meant to be fed
+ # to the script uncompressed.
+ docompress -x "/usr/share/doc/${PF}/basic_passwords.txt" "/usr/share/doc/${PF}/vulnerabilities.csv"
+}