summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorViktar Patotski <xp.vit.blr@gmail.com>2021-02-22 13:17:13 +0100
committerThomas Deutschmann <whissi@gentoo.org>2021-02-25 04:31:30 +0100
commit48a8eb19e941bfc1155541b0ce6f2ae96c4813b7 (patch)
treefe8a44826bfda3a0f98f57db3bf6f5fc0cb14bec /dev-db/mysqltuner/mysqltuner-1.7.21.ebuild
parentapp-admin/radmind: Stabilize 1.15.3-r1 x86, #769896 (diff)
downloadgentoo-48a8eb19e941bfc1155541b0ce6f2ae96c4813b7.tar.gz
gentoo-48a8eb19e941bfc1155541b0ce6f2ae96c4813b7.tar.bz2
gentoo-48a8eb19e941bfc1155541b0ce6f2ae96c4813b7.zip
dev-db/mysqltuner: bump version to 1.7.21
This bumps dev-db/mysqltuner to latest version 1.7.21. Signed-off-by: Viktar Patotski <xp.vit.blr@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/19596 Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
Diffstat (limited to 'dev-db/mysqltuner/mysqltuner-1.7.21.ebuild')
-rw-r--r--dev-db/mysqltuner/mysqltuner-1.7.21.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/dev-db/mysqltuner/mysqltuner-1.7.21.ebuild b/dev-db/mysqltuner/mysqltuner-1.7.21.ebuild
new file mode 100644
index 000000000000..511d0291d647
--- /dev/null
+++ b/dev-db/mysqltuner/mysqltuner-1.7.21.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+MY_PN=MySQLTuner-perl
+
+DESCRIPTION="MySQLTuner is a high-performance MySQL tuning script"
+HOMEPAGE="https://github.com/major/MySQLTuner-perl"
+SRC_URI="https://github.com/major/${MY_PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="amd64 x86"
+
+RDEPEND="
+ dev-lang/perl
+ virtual/mysql
+ virtual/perl-Getopt-Long"
+
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+DOCS=( USAGE.md CONTRIBUTING.md INTERNALS.md basic_passwords.txt vulnerabilities.csv )
+
+src_install() {
+ einstalldocs
+
+ newbin "${PN}.pl" "${PN}"
+
+ # Passwords and vulnerabilities are meant to be fed
+ # to the script uncompressed.
+ docompress -x "/usr/share/doc/${PF}/basic_passwords.txt" "/usr/share/doc/${PF}/vulnerabilities.csv"
+}