summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-01-20 15:21:41 +0000
committerSam James <sam@gentoo.org>2022-01-20 15:21:41 +0000
commitffbe6ac5b5d4ccc29993e3d7ae68625afbf871df (patch)
tree27d7adab038a4bffaa4dac2d90c019f67c86af30 /dev-db/ocp
parentapp-text/opensp: use BDEPEND (diff)
downloadgentoo-ffbe6ac5b5d4ccc29993e3d7ae68625afbf871df.tar.gz
gentoo-ffbe6ac5b5d4ccc29993e3d7ae68625afbf871df.tar.bz2
gentoo-ffbe6ac5b5d4ccc29993e3d7ae68625afbf871df.zip
dev-db/ocp: move common inherit out
Bug: https://bugs.gentoo.org/831291 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-db/ocp')
-rw-r--r--dev-db/ocp/ocp-0.3.ebuild5
-rw-r--r--dev-db/ocp/ocp-9999.ebuild5
2 files changed, 6 insertions, 4 deletions
diff --git a/dev-db/ocp/ocp-0.3.ebuild b/dev-db/ocp/ocp-0.3.ebuild
index 47e7110d55b1..baeb53e6decb 100644
--- a/dev-db/ocp/ocp-0.3.ebuild
+++ b/dev-db/ocp/ocp-0.3.ebuild
@@ -6,14 +6,15 @@ EAPI=8
DESCRIPTION="Oracle copy tool"
HOMEPAGE="https://github.com/maxsatula/ocp"
+inherit toolchain-funcs
+
if [[ ${PV} == *9999 ]]; then
EGIT_REPO_URI="https://github.com/maxsatula/ocp.git"
EGIT_BRANCH="develop"
- inherit git-r3 autotools toolchain-funcs
+ inherit autotools git-r3
else
SRC_URI="https://github.com/maxsatula/ocp/releases/download/v${PV}/${P}.tar.gz"
KEYWORDS="~amd64 ~x86"
- inherit toolchain-funcs
fi
LICENSE="GPL-2"
diff --git a/dev-db/ocp/ocp-9999.ebuild b/dev-db/ocp/ocp-9999.ebuild
index 47e7110d55b1..baeb53e6decb 100644
--- a/dev-db/ocp/ocp-9999.ebuild
+++ b/dev-db/ocp/ocp-9999.ebuild
@@ -6,14 +6,15 @@ EAPI=8
DESCRIPTION="Oracle copy tool"
HOMEPAGE="https://github.com/maxsatula/ocp"
+inherit toolchain-funcs
+
if [[ ${PV} == *9999 ]]; then
EGIT_REPO_URI="https://github.com/maxsatula/ocp.git"
EGIT_BRANCH="develop"
- inherit git-r3 autotools toolchain-funcs
+ inherit autotools git-r3
else
SRC_URI="https://github.com/maxsatula/ocp/releases/download/v${PV}/${P}.tar.gz"
KEYWORDS="~amd64 ~x86"
- inherit toolchain-funcs
fi
LICENSE="GPL-2"