summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarco Genasci <fedeliallalinea@gmail.com>2022-01-07 13:42:14 +0100
committerSam James <sam@gentoo.org>2022-01-15 21:50:18 +0000
commitab1656a691cb263663340280456804d736cecbe9 (patch)
treee3d02900329d63f631bc5a7218c3b40a6ab7f669 /dev-db/opendbx/opendbx-1.5.0-r3.ebuild
parentsci-physics/root: changed old oracle-instantclient-basic dependency (diff)
downloadgentoo-ab1656a691cb263663340280456804d736cecbe9.tar.gz
gentoo-ab1656a691cb263663340280456804d736cecbe9.tar.bz2
gentoo-ab1656a691cb263663340280456804d736cecbe9.zip
dev-db/opendbx: changed old oracle-instantclient-basic dependency
Package-Manager: Portage-3.0.28, Repoman-3.0.3 Signed-off-by: Marco Genasci <fedeliallalinea@gmail.com> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-db/opendbx/opendbx-1.5.0-r3.ebuild')
-rw-r--r--dev-db/opendbx/opendbx-1.5.0-r3.ebuild81
1 files changed, 81 insertions, 0 deletions
diff --git a/dev-db/opendbx/opendbx-1.5.0-r3.ebuild b/dev-db/opendbx/opendbx-1.5.0-r3.ebuild
new file mode 100644
index 000000000000..b4e76604878b
--- /dev/null
+++ b/dev-db/opendbx/opendbx-1.5.0-r3.ebuild
@@ -0,0 +1,81 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+inherit flag-o-matic
+
+MY_PN="lib${PN}"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="OpenDBX - A database abstraction layer"
+HOMEPAGE="https://www.linuxnetworks.de/doc/index.php/OpenDBX"
+SRC_URI="https://www.linuxnetworks.de/opendbx/download/${MY_P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~x64-solaris"
+IUSE="firebird +mysql oracle postgres sqlite"
+RESTRICT="firebird? ( bindist )"
+
+RDEPEND="mysql? ( dev-db/mysql-connector-c:0= )
+ postgres? ( dev-db/postgresql:* )
+ sqlite? ( dev-db/sqlite:3 )
+ oracle? ( dev-db/oracle-instantclient[sdk] )
+ firebird? ( dev-db/firebird )"
+DEPEND="${RDEPEND} app-doc/doxygen app-text/docbook2X"
+
+S="${WORKDIR}"/${MY_P}
+
+REQUIRED_USE="|| ( firebird mysql oracle postgres sqlite )"
+
+PATCHES=( "${FILESDIR}/${PN}-doxy.patch" )
+
+pkg_setup() {
+ if use oracle && [[ ! -d ${ORACLE_HOME} ]]
+ then
+ die "Oracle support requested, but ORACLE_HOME not set to a valid directory!"
+ fi
+}
+
+src_configure() {
+ local backends=""
+
+ use firebird && backends="${backends} firebird"
+ use mysql && backends="${backends} mysql"
+ use oracle && backends="${backends} oracle"
+ use postgres && backends="${backends} pgsql"
+ use sqlite && backends="${backends} sqlite3"
+
+ use mysql && append-cppflags -I/usr/include/mysql
+ use firebird && append-cppflags -I/opt/firebird/include
+
+ if use oracle ; then
+ # Traditionally, OCI header files are provided in:
+ append-cppflags -I"${ORACLE_HOME}"/rdbms/public
+ # But newer versions merged them with additional SDKs:
+ append-cppflags -I"${ORACLE_HOME}"/sdk/include
+ # Depending on the client package ORACLE_HOME refers to,
+ # we need to find the libraries in varying locations:
+ # - gentoo instantclient has multilib (dev-db/oracle-instantclient)
+ append-ldflags -L"${ORACLE_HOME}"/$(get_libdir)
+ # - vanilla full client lacks multilib (LINUX*_client{,_home}.zip)
+ append-ldflags -L"${ORACLE_HOME}"/lib
+ # - vanilla instantclient lacks libdir (instantclient-*.zip)
+ append-ldflags -L"${ORACLE_HOME}"
+ fi
+
+ econf --with-backends="${backends}"
+}
+
+src_compile() {
+ # bug #322221
+ emake -j1
+}
+
+src_install() {
+ emake -j1 install DESTDIR="${D}"
+ dodoc AUTHORS ChangeLog README
+
+ rm -f "${D}"/usr/$(get_libdir)/opendbx/*.{a,la}
+}