summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Haubenwallner <haubi@gentoo.org>2018-07-09 16:51:59 +0200
committerMichael Haubenwallner <haubi@gentoo.org>2018-07-09 16:57:33 +0200
commit81f2b535a3defef03329a38d529b28d480a78d9a (patch)
tree05ef84d1b260b1c4b1ebabc880df75c9058018f9 /dev-db/oracle-instantclient-sqlplus/oracle-instantclient-sqlplus-11.2.0.3.ebuild
parentdev-db/oracle-instantclient-odbc: cleanup old (diff)
downloadgentoo-81f2b535a3defef03329a38d529b28d480a78d9a.tar.gz
gentoo-81f2b535a3defef03329a38d529b28d480a78d9a.tar.bz2
gentoo-81f2b535a3defef03329a38d529b28d480a78d9a.zip
dev-db/oracle-instantclient-sqlplus: cleanup old
Bug: https://bugs.gentoo.org/589146 Package-Manager: Portage-2.3.24, Repoman-2.3.6
Diffstat (limited to 'dev-db/oracle-instantclient-sqlplus/oracle-instantclient-sqlplus-11.2.0.3.ebuild')
-rw-r--r--dev-db/oracle-instantclient-sqlplus/oracle-instantclient-sqlplus-11.2.0.3.ebuild69
1 files changed, 0 insertions, 69 deletions
diff --git a/dev-db/oracle-instantclient-sqlplus/oracle-instantclient-sqlplus-11.2.0.3.ebuild b/dev-db/oracle-instantclient-sqlplus/oracle-instantclient-sqlplus-11.2.0.3.ebuild
deleted file mode 100644
index 6df81c9c2bec..000000000000
--- a/dev-db/oracle-instantclient-sqlplus/oracle-instantclient-sqlplus-11.2.0.3.ebuild
+++ /dev/null
@@ -1,69 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="4"
-
-inherit eutils multilib
-
-MY_PLAT_x86="Linux x86"
-MY_A_x86="${PN#oracle-}-linux-${PV}.0.zip"
-
-MY_PLAT_amd64="Linux x86-64"
-MY_A_amd64="${PN#oracle-}-linux.x64-${PV}.0.zip"
-
-DESCRIPTION="Oracle 11g Instant Client: SQL*Plus"
-HOMEPAGE="http://www.oracle.com/technetwork/database/features/instant-client/index.html"
-SRC_URI="
- x86? ( ${MY_A_x86} )
- amd64? ( ${MY_A_amd64} )
-"
-
-LICENSE="OTN"
-SLOT="0"
-KEYWORDS="amd64 x86"
-RESTRICT="fetch"
-IUSE=""
-
-DEPEND="app-arch/unzip"
-RDEPEND="~dev-db/oracle-instantclient-basic-${PV}"
-
-S="${WORKDIR}"/instantclient_11_2
-
-QA_PREBUILT="
- usr/lib*/oracle/${PV}/client/lib*/lib*
- usr/lib*/oracle/${PV}/client/bin/sqlplus
-"
-
-my_arch() {
- # platform name
- MY_PLAT=MY_PLAT_${ARCH}
- export MY_PLAT=${!MY_PLAT}
- # distfile
- MY_A=MY_A_${ARCH}
- export MY_A=${!MY_A}
-}
-
-pkg_nofetch() {
- my_arch
- eerror "Please go to"
- eerror " ${HOMEPAGE%/*}/index-097480.html"
- eerror " and download"
- eerror "Instant Client for ${MY_PLAT}"
- eerror " SQL*Plus: ${MY_A}"
- eerror "After downloading, put it in:"
- eerror " ${DISTDIR}/"
-}
-
-src_install() {
- # all binaries go here
- local oracle_home=/usr/$(get_libdir)/oracle/${PV}/client
- into "${oracle_home}"
-
- dolib.so libsqlplus$(get_libname) libsqlplusic$(get_libname)
- dobin sqlplus
-
- insinto "${oracle_home}"/sqlplus/admin
- doins glogin.sql
-
- dosym "${oracle_home}"/bin/sqlplus /usr/bin/sqlplus
-}