summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Deutschmann <whissi@gentoo.org>2020-07-25 20:45:18 +0200
committerThomas Deutschmann <whissi@gentoo.org>2020-07-25 20:45:32 +0200
commit1bfa4a43b6577c42a81168446899e8ccce908a50 (patch)
treee152cd7c998e149947cc0f0d25630f9910a4499b /dev-db/percona-server
parentdev-perl/DateTime-Format-Flexible: Fix DEPEND vs BDEPEND (diff)
downloadgentoo-1bfa4a43b6577c42a81168446899e8ccce908a50.tar.gz
gentoo-1bfa4a43b6577c42a81168446899e8ccce908a50.tar.bz2
gentoo-1bfa4a43b6577c42a81168446899e8ccce908a50.zip
dev-db/percona-server: update known test failures
Package-Manager: Portage-3.0.0, Repoman-2.3.23 Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
Diffstat (limited to 'dev-db/percona-server')
-rw-r--r--dev-db/percona-server/percona-server-8.0.20.11.ebuild13
1 files changed, 13 insertions, 0 deletions
diff --git a/dev-db/percona-server/percona-server-8.0.20.11.ebuild b/dev-db/percona-server/percona-server-8.0.20.11.ebuild
index 67c89a1518b9..0d4ac0f7b980 100644
--- a/dev-db/percona-server/percona-server-8.0.20.11.ebuild
+++ b/dev-db/percona-server/percona-server-8.0.20.11.ebuild
@@ -412,8 +412,12 @@ src_test() {
disabled_tests+=( "gis.spatial_utility_function_simplify;5452;Known rounding error with latest AMD processors (PS)" )
disabled_tests+=( "gis.spatial_op_testingfunc_mix;5452;Known rounding error with latest AMD processors (PS)" )
disabled_tests+=( "gis.spatial_analysis_functions_distance;5452;Known rounding error with latest AMD processors (PS)" )
+ disabled_tests+=( "group_replication.gr_ssl_options2;0;Sporadic failing test" )
disabled_tests+=( "innodb.percona_changed_page_bmp_flush;6807;False positive on Gentoo (PS)" )
disabled_tests+=( "innodb.percona_changed_page_bmp_log_resize;0;Sporadic failing test" )
+ disabled_tests+=( "innodb.percona_log_encrypt_failure;0;Requires proper keyring setup" )
+ disabled_tests+=( "innodb.percona_log_encrypt_change_mk;6039;False positive on Gentoo (PS)" )
+ disabled_tests+=( "innodb.percona_log_encrypt_change_rk;6805;False positive on Gentoo (PS)" )
disabled_tests+=( "innodb.upgrade_orphan;0;Sporadic failing test" )
disabled_tests+=( "main.myisam-blob;0;Sporadic failing test" )
disabled_tests+=( "main.mysqlpump_basic_lz4;6042;Extra tool output causes false positive" )
@@ -428,6 +432,15 @@ src_test() {
disabled_tests+=( "x.message_compressed_payload;0;False positive caused by protobuff-3.11+" )
disabled_tests+=( "x.message_protobuf_nested;6803;False positive caused by protobuff-3.11+" )
+ # Known test failures due to expired SSL certificates -- fixed in 8.0.22
+ disabled_tests+=( "auth_sec.admin_ssl_crl_crlpath;100055;Fixed in 8.0.22" )
+ disabled_tests+=( "auth_sec.admin_ssl_crl;100055;Fixed in 8.0.22" )
+ disabled_tests+=( "auth_sec.server_withssl_client_withssl;100055;Fixed in 8.0.22" )
+ disabled_tests+=( "main.ssl_crl_clients_valid;100055;Fixed in 8.0.22" )
+ disabled_tests+=( "main.ssl_crl;100055;Fixed in 8.0.22" )
+ disabled_tests+=( "main.ssl_crl_crlpath;100055;Fixed in 8.0.22" )
+ disabled_tests+=( "main.ssl_ca;100055;Fixed in 8.0.22" )
+
if ! hash zip 1>/dev/null 2>&1 ; then
# no need to force dep app-arch/zip for one test
disabled_tests+=( "innodb.partition_upgrade_create;0;Requires app-arch/zip" )