summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2019-12-30 20:12:17 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2019-12-31 19:42:20 +0100
commitbe0ab352405aa2d5d968a8c3905557b914df9626 (patch)
tree5b5da6a6ab8feb0c82b1f5c6b02e9fafdee83463 /dev-db/percona-xtrabackup
parentsys-kernel/gentoo-sources: Linux patch 5.4.7 (diff)
downloadgentoo-be0ab352405aa2d5d968a8c3905557b914df9626.tar.gz
gentoo-be0ab352405aa2d5d968a8c3905557b914df9626.tar.bz2
gentoo-be0ab352405aa2d5d968a8c3905557b914df9626.zip
*/*: Switch proxy-maint to cmake.eclass
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'dev-db/percona-xtrabackup')
-rw-r--r--dev-db/percona-xtrabackup/percona-xtrabackup-2.4.15.ebuild6
-rw-r--r--dev-db/percona-xtrabackup/percona-xtrabackup-8.0.7.ebuild4
2 files changed, 5 insertions, 5 deletions
diff --git a/dev-db/percona-xtrabackup/percona-xtrabackup-2.4.15.ebuild b/dev-db/percona-xtrabackup/percona-xtrabackup-2.4.15.ebuild
index 2ca76ece9d82..9e800bfb475a 100644
--- a/dev-db/percona-xtrabackup/percona-xtrabackup-2.4.15.ebuild
+++ b/dev-db/percona-xtrabackup/percona-xtrabackup-2.4.15.ebuild
@@ -5,7 +5,7 @@ EAPI="7"
CMAKE_MAKEFILE_GENERATOR="emake"
-inherit cmake-utils flag-o-matic
+inherit cmake flag-o-matic
DESCRIPTION="Hot backup utility for MySQL based servers"
HOMEPAGE="https://www.percona.com/software/mysql-database/percona-xtrabackup"
@@ -40,7 +40,7 @@ PATCHES=(
)
src_prepare() {
- cmake-utils_src_prepare
+ cmake_src_prepare
# remove bundled libedit, libevent, zlib
# just to be safe...
@@ -65,7 +65,7 @@ src_configure() {
)
local CMAKE_BUILD_TYPE="Release"
- cmake-utils_src_configure
+ cmake_src_configure
}
src_install() {
diff --git a/dev-db/percona-xtrabackup/percona-xtrabackup-8.0.7.ebuild b/dev-db/percona-xtrabackup/percona-xtrabackup-8.0.7.ebuild
index af0018e27b3c..3776aa32ffd3 100644
--- a/dev-db/percona-xtrabackup/percona-xtrabackup-8.0.7.ebuild
+++ b/dev-db/percona-xtrabackup/percona-xtrabackup-8.0.7.ebuild
@@ -5,7 +5,7 @@ EAPI="7"
CMAKE_MAKEFILE_GENERATOR="emake"
-inherit cmake-utils flag-o-matic
+inherit cmake flag-o-matic
BOOST_VER="1_69_0"
MY_PV="$(ver_rs 2 '-')"
@@ -50,7 +50,7 @@ src_configure() {
-DWITH_SYSTEM_LIBS=ON
)
local CMAKE_BUILD_TYPE="Release"
- cmake-utils_src_configure
+ cmake_src_configure
}
src_install() {