summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAaron W. Swenson <titanofold@gentoo.org>2017-10-07 16:42:52 -0400
committerAaron W. Swenson <titanofold@gentoo.org>2017-10-07 16:42:52 -0400
commit688f3c389edcf5009d8f5ba5b256a76b75c09ee0 (patch)
tree491124951d4b6bfb45d3102a82d8eb9cbf7d11c4 /dev-db/pgadmin3/pgadmin3-1.22.2.ebuild
parentdev-db/postgresql: Improved systemd support (diff)
downloadgentoo-688f3c389edcf5009d8f5ba5b256a76b75c09ee0.tar.gz
gentoo-688f3c389edcf5009d8f5ba5b256a76b75c09ee0.tar.bz2
gentoo-688f3c389edcf5009d8f5ba5b256a76b75c09ee0.zip
dev-db/pgadmin3: Bump to 1.22.2, fix startup crash
Bump to version 1.22.2. Also fix crash on start up when using GCC 6. Thanks torto09. Gentoo-Bug: https://bugs.gentoo.org/629422 Package-Manager: Portage-2.3.8, Repoman-2.3.3
Diffstat (limited to 'dev-db/pgadmin3/pgadmin3-1.22.2.ebuild')
-rw-r--r--dev-db/pgadmin3/pgadmin3-1.22.2.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/dev-db/pgadmin3/pgadmin3-1.22.2.ebuild b/dev-db/pgadmin3/pgadmin3-1.22.2.ebuild
new file mode 100644
index 000000000000..efce58f103c6
--- /dev/null
+++ b/dev-db/pgadmin3/pgadmin3-1.22.2.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+inherit eutils multilib versionator wxwidgets
+
+DESCRIPTION="wxWidgets GUI for PostgreSQL"
+HOMEPAGE="http://www.pgadmin.org/"
+SRC_URI="mirror://postgresql/pgadmin/pgadmin3/v${PV}/src/${P}.tar.gz"
+
+LICENSE="POSTGRESQL"
+KEYWORDS="~amd64 ~ppc ~x86 ~x86-fbsd"
+SLOT="0"
+IUSE="debug +databasedesigner"
+
+DEPEND="
+ x11-libs/wxGTK:3.0=[X]
+ >=dev-db/postgresql-8.4.0:=
+ >=dev-libs/libxml2-2.6.18
+ >=dev-libs/libxslt-1.1"
+RDEPEND="${DEPEND}"
+
+PATCHES=( "${FILESDIR}"/pgadmin3-{desktop,gcc6-null-pointer}.patch )
+
+src_configure() {
+ WX_GTK_VER="3.0"
+
+ setup-wxwidgets
+
+ econf --with-wx-version=${WX_GTK_VER} \
+ $(use_enable debug) \
+ $(use_enable databasedesigner)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+
+ newicon "${S}/pgadmin/include/images/pgAdmin3.png" ${PN}.png
+
+ domenu "${S}/pkg/pgadmin3.desktop"
+
+ # Fixing world-writable files
+ fperms -R go-w /usr/share
+}