summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrian Evans <grknight@gentoo.org>2019-01-23 14:48:32 -0500
committerBrian Evans <grknight@gentoo.org>2019-01-23 14:48:32 -0500
commit6d1da50b8257d38b280f9719ab9dbc2069884ce5 (patch)
tree56a370ac3e8e5b0894856b3bd283ccd8cfa91df2 /dev-db/pgadmin3/pgadmin3-1.22.2.ebuild
parentdev-libs/libisoburn: stable 1.5.0 for sparc, bug #676052 (diff)
downloadgentoo-6d1da50b8257d38b280f9719ab9dbc2069884ce5.tar.gz
gentoo-6d1da50b8257d38b280f9719ab9dbc2069884ce5.tar.bz2
gentoo-6d1da50b8257d38b280f9719ab9dbc2069884ce5.zip
Revert "dev-db/pgadmin3: Remove last rites package"
This reverts commit c27c8dfa1bc0dd1371ce9cd0a1383a44965b0dc9. Signed-off-by: Brian Evans <grknight@gentoo.org>
Diffstat (limited to 'dev-db/pgadmin3/pgadmin3-1.22.2.ebuild')
-rw-r--r--dev-db/pgadmin3/pgadmin3-1.22.2.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/dev-db/pgadmin3/pgadmin3-1.22.2.ebuild b/dev-db/pgadmin3/pgadmin3-1.22.2.ebuild
new file mode 100644
index 000000000000..5498f4be6fd3
--- /dev/null
+++ b/dev-db/pgadmin3/pgadmin3-1.22.2.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+inherit eutils multilib versionator wxwidgets
+
+DESCRIPTION="wxWidgets GUI for PostgreSQL"
+HOMEPAGE="https://www.pgadmin.org/"
+SRC_URI="mirror://postgresql/pgadmin/pgadmin3/v${PV}/src/${P}.tar.gz"
+
+LICENSE="POSTGRESQL"
+KEYWORDS="amd64 ppc x86 ~x86-fbsd"
+SLOT="0"
+IUSE="debug +databasedesigner"
+
+DEPEND="
+ x11-libs/wxGTK:3.0=[X]
+ >=dev-db/postgresql-8.4.0:=
+ >=dev-libs/libxml2-2.6.18
+ >=dev-libs/libxslt-1.1"
+RDEPEND="${DEPEND}"
+
+PATCHES=( "${FILESDIR}"/pgadmin3-{desktop-r1,gcc6-null-pointer}.patch )
+
+src_configure() {
+ WX_GTK_VER="3.0"
+
+ setup-wxwidgets
+
+ econf --with-wx-version=${WX_GTK_VER} \
+ $(use_enable debug) \
+ $(use_enable databasedesigner)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+
+ newicon "${S}/pgadmin/include/images/pgAdmin3.png" ${PN}.png
+
+ domenu "${S}/pkg/pgadmin3.desktop"
+
+ # Fixing world-writable files
+ fperms -R go-w /usr/share
+}