summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAaron W. Swenson <titanofold@gentoo.org>2022-03-15 12:58:30 -0400
committerAaron W. Swenson <titanofold@gentoo.org>2022-03-15 12:58:30 -0400
commite5b884a6f1caf966832a6519218107c23838b4d8 (patch)
tree74f82c845d50c39551ad80e6c168c74f6009460c /dev-db/pgagent/pgagent-4.2.1.ebuild
parentacct-user/pgagent: Initial 0 release for GLEP-81 update (diff)
downloadgentoo-e5b884a6f1caf966832a6519218107c23838b4d8.tar.gz
gentoo-e5b884a6f1caf966832a6519218107c23838b4d8.tar.bz2
gentoo-e5b884a6f1caf966832a6519218107c23838b4d8.zip
dev-db/pgagent: Bump to 4.2.1
Additionally migrates from cmake-utils and user to cmake and acct-user. Bug: https://bugs.gentoo.org/781284 Signed-off-by: Aaron W. Swenson <titanofold@gentoo.org>
Diffstat (limited to 'dev-db/pgagent/pgagent-4.2.1.ebuild')
-rw-r--r--dev-db/pgagent/pgagent-4.2.1.ebuild48
1 files changed, 48 insertions, 0 deletions
diff --git a/dev-db/pgagent/pgagent-4.2.1.ebuild b/dev-db/pgagent/pgagent-4.2.1.ebuild
new file mode 100644
index 000000000000..e6e675fbee11
--- /dev/null
+++ b/dev-db/pgagent/pgagent-4.2.1.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+CMAKE_IN_SOURCE_BUILD=1
+
+inherit cmake
+
+MY_PN=${PN/a/A}
+
+KEYWORDS="amd64 x86"
+
+DESCRIPTION="${MY_PN} is a job scheduler for PostgreSQL"
+HOMEPAGE="https://www.pgadmin.org/download/pgagent-source-code/"
+SRC_URI="https://ftp.postgresql.org/pub/pgadmin/${PN}/${MY_PN}-${PV}-Source.tar.gz"
+
+LICENSE="POSTGRESQL GPL-2"
+SLOT="0"
+
+RDEPEND="
+ acct-user/pgagent
+ dev-db/postgresql:*
+ dev-libs/boost
+"
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}/${MY_PN}-${PV}-Source"
+
+src_prepare() {
+ cmake_src_prepare
+
+ sed -e "s:share):share/${P}):" \
+ -i CMakeLists.txt || die "failed to patch CMakeLists.txt"
+}
+
+src_configure() {
+ local mycmakeargs=( "-DSTATIC_BUILD:BOOLEAN=FALSE" )
+ cmake_src_configure
+}
+
+src_install() {
+ cmake_src_install
+
+ newinitd "${FILESDIR}/pgagent.initd-r1" "${PN}"
+ newconfd "${FILESDIR}/pgagent.confd" "${PN}"
+
+ rm "${ED}"/usr/{LICENSE,README} || die "failed to remove useless docs"
+}