summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-db/pgagent
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-db/pgagent')
-rw-r--r--dev-db/pgagent/Manifest2
-rw-r--r--dev-db/pgagent/files/pgagent.confd22
-rw-r--r--dev-db/pgagent/files/pgagent.initd25
-rw-r--r--dev-db/pgagent/metadata.xml5
-rw-r--r--dev-db/pgagent/pgagent-3.3.0.ebuild52
-rw-r--r--dev-db/pgagent/pgagent-3.4.0.ebuild52
6 files changed, 158 insertions, 0 deletions
diff --git a/dev-db/pgagent/Manifest b/dev-db/pgagent/Manifest
new file mode 100644
index 000000000000..8b9ee02172f3
--- /dev/null
+++ b/dev-db/pgagent/Manifest
@@ -0,0 +1,2 @@
+DIST pgAgent-3.3.0-Source.tar.gz 43722 SHA256 110f2fd811a05ea8a420a79fcbb25b971e60f10f8abb8ab2bede8419c58b7321 SHA512 928d72d578beacc7725cfd3e206d81a732baf6d654a681dd1d603b68e54c0d20e54fad793759924fdad7efc5c6b2047d372e6cd8ae7539c76c06db3a8963657a WHIRLPOOL ce44d26ef314ff0076ab376377c1f2b4e826366da346f4aac77e0e877a49fbbf9f6018869b8dc6db24b7ef519bb4d6499d6436da3a4a5053e1cd787028003856
+DIST pgAgent-3.4.0-Source.tar.gz 45081 SHA256 0da0ac8f453cf34ab6f708eee036bed0fd0e5fa311de283b92d2ff06600bbb3d SHA512 3b068fc6f5e51ff20604f8cec3e067d04b5b1537229da15ee442000f5fe834697a4eae86be0e9a58b8ee5da24cc985c8c9804d71cb2a50e93ec4cf9a424a4ff0 WHIRLPOOL df619ddbfd5c01cf9e17b22becf74742ea7caa783504fd5942d63992bc80913b36f1c85d7ce2d3dd31634b524617a943ed07a3eba675caddc7cd7f3fc79d8c1c
diff --git a/dev-db/pgagent/files/pgagent.confd b/dev-db/pgagent/files/pgagent.confd
new file mode 100644
index 000000000000..0b2c7d788dd2
--- /dev/null
+++ b/dev-db/pgagent/files/pgagent.confd
@@ -0,0 +1,22 @@
+# Pool time interval
+PGA_POLL="10"
+
+# Retry period
+PGA_RETRY="30"
+
+# Log file
+PGA_LOG="/var/log/pgagent.log"
+
+# Logging verbosity
+# ERROR=0, WARNING=1, DEBUG=2
+PGA_LEVEL="1"
+
+# Server parameters
+# Host address
+PG_HOST="localhost"
+
+# DB name
+PG_DBNAME="postgres"
+
+# Username
+PG_USER="postgres" \ No newline at end of file
diff --git a/dev-db/pgagent/files/pgagent.initd b/dev-db/pgagent/files/pgagent.initd
new file mode 100644
index 000000000000..d168e9a27d2c
--- /dev/null
+++ b/dev-db/pgagent/files/pgagent.initd
@@ -0,0 +1,25 @@
+#!/sbin/runscript
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+PGAGENTOPT="-t ${PGA_POLL} -r ${PGA_RETRY} -s ${PGA_LOG} -l ${PGA_LEVEL}"
+
+PGOPT="hostaddr=${PG_HOST} dbname=${PG_DBNAME} user=${PG_USER}"
+
+depend() {
+ use net
+ need postgresql
+}
+
+start() {
+ ebegin "Starting pgagent"
+ start-stop-daemon --start --exec /usr/bin/pgagent -- ${PGAGENTOPT} ${PGOPT}
+ eend $?
+}
+
+stop() {
+ ebegin "Stopping pgagent"
+ start-stop-daemon --stop --name pgagent
+ eend $?
+}
diff --git a/dev-db/pgagent/metadata.xml b/dev-db/pgagent/metadata.xml
new file mode 100644
index 000000000000..adf45800ffea
--- /dev/null
+++ b/dev-db/pgagent/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>postgresql</herd>
+</pkgmetadata>
diff --git a/dev-db/pgagent/pgagent-3.3.0.ebuild b/dev-db/pgagent/pgagent-3.3.0.ebuild
new file mode 100644
index 000000000000..ac96c34bfdd0
--- /dev/null
+++ b/dev-db/pgagent/pgagent-3.3.0.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="4"
+
+inherit cmake-utils eutils wxwidgets
+
+MY_PN=${PN/a/A}
+
+KEYWORDS="amd64 x86"
+
+DESCRIPTION="${MY_PN} is a job scheduler for PostgreSQL"
+HOMEPAGE="http://www.pgadmin.org/download/pgagent.php"
+SRC_URI="mirror://postgresql/pgadmin3/release/${PN}/${MY_PN}-${PV}-Source.tar.gz"
+LICENSE="POSTGRESQL GPL-2"
+SLOT="0"
+IUSE=""
+
+RDEPEND=">=dev-db/postgresql-8.3.0
+ x11-libs/wxGTK:2.8
+"
+DEPEND="${RDEPEND}
+ >=dev-util/cmake-2.6
+"
+
+S="${WORKDIR}/${MY_PN}-${PV}-Source"
+
+src_prepare() {
+ sed -e "s:share):share/${P}):" \
+ -i CMakeLists.txt || die "Couldn't patch CMakeLists.txt"
+}
+
+src_configure() {
+ WX_GTK_VER="2.8"
+ if has_version "x11-libs/wxGTK[X]"; then
+ need-wxwidgets unicode
+ else
+ need-wxwidgets base-unicode
+ fi
+ mycmakeargs="-DSTATIC_BUILD:BOOLEAN=FALSE"
+ cmake-utils_src_configure
+}
+
+src_install() {
+ cmake-utils_src_install
+
+ newinitd "${FILESDIR}/pgagent.initd" ${PN}
+ newconfd "${FILESDIR}/pgagent.confd" ${PN}
+
+ rm "${ED}"/usr/{LICENSE,README} || die "Failed to remove useless docs"
+}
diff --git a/dev-db/pgagent/pgagent-3.4.0.ebuild b/dev-db/pgagent/pgagent-3.4.0.ebuild
new file mode 100644
index 000000000000..1ba18eac7923
--- /dev/null
+++ b/dev-db/pgagent/pgagent-3.4.0.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+CMAKE_IN_SOURCE_BUILD=1
+inherit cmake-utils eutils wxwidgets
+
+MY_PN=${PN/a/A}
+
+KEYWORDS="amd64 x86"
+
+DESCRIPTION="${MY_PN} is a job scheduler for PostgreSQL"
+HOMEPAGE="http://www.pgadmin.org/download/pgagent.php"
+SRC_URI="mirror://postgresql/pgadmin3/release/${PN}/${MY_PN}-${PV}-Source.tar.gz"
+LICENSE="POSTGRESQL GPL-2"
+SLOT="0"
+IUSE=""
+
+RDEPEND=">=dev-db/postgresql-9.0.0
+ x11-libs/wxGTK:2.8
+"
+DEPEND="${RDEPEND}
+ >=dev-util/cmake-2.6
+"
+
+S="${WORKDIR}/${MY_PN}-${PV}-Source"
+
+src_prepare() {
+ sed -e "s:share):share/${P}):" \
+ -i CMakeLists.txt || die "Couldn't patch CMakeLists.txt"
+}
+
+src_configure() {
+ WX_GTK_VER="2.8"
+ if has_version "x11-libs/wxGTK[X]"; then
+ need-wxwidgets unicode
+ else
+ need-wxwidgets base-unicode
+ fi
+ mycmakeargs="-DSTATIC_BUILD:BOOLEAN=FALSE"
+ cmake-utils_src_configure
+}
+
+src_install() {
+ cmake-utils_src_install
+
+ newinitd "${FILESDIR}/pgagent.initd" ${PN}
+ newconfd "${FILESDIR}/pgagent.confd" ${PN}
+
+ rm "${ED}"/usr/{LICENSE,README} || die "Failed to remove useless docs"
+}