summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAaron W. Swenson <titanofold@gentoo.org>2018-08-03 09:26:51 -0400
committerAaron W. Swenson <titanofold@gentoo.org>2018-08-03 09:26:51 -0400
commit079ff486c23fdb326e5d58df1433b854ca900e94 (patch)
tree88822d2600ba82cabcc0918c4696dc908fd7d8e2 /dev-db/pgpool2/pgpool2-9999.ebuild
parentmedia-sound/apulse: version bump (diff)
downloadgentoo-079ff486c23fdb326e5d58df1433b854ca900e94.tar.gz
gentoo-079ff486c23fdb326e5d58df1433b854ca900e94.tar.bz2
gentoo-079ff486c23fdb326e5d58df1433b854ca900e94.zip
dev-db/pgpool2: Bump to 3.7.5
Add a couple patches to fix a few options in configure.ac. --without-pam no longer acts as if --with-pam was given. Now uses pkg-config to get any special settings for libmemcached rather than using fixed sub-directories (${user_provided_path}/{include,lib,…}). Lastly, introduced AX_PTHREAD to link in the appropriate threading library to fix bug 616302. If libmemcached was built with USE=sasl which builds against cyrus-sasl. cyrus-sasl builds against a threading library which necessitates including the same threading in pgpool2 despite pgpool2 not being a threaded program. pgpool2 is now able to build against LibreSSL as well as OpenSSL. The ebuild now reflects this fact Bug: https://bugs.gentoo.org/616302 Bug: https://bugs.gentoo.org/646888 Package-Manager: Portage-2.3.40, Repoman-2.3.9
Diffstat (limited to 'dev-db/pgpool2/pgpool2-9999.ebuild')
-rw-r--r--dev-db/pgpool2/pgpool2-9999.ebuild42
1 files changed, 26 insertions, 16 deletions
diff --git a/dev-db/pgpool2/pgpool2-9999.ebuild b/dev-db/pgpool2/pgpool2-9999.ebuild
index b0b43a07e37c..b565c24cfbee 100644
--- a/dev-db/pgpool2/pgpool2-9999.ebuild
+++ b/dev-db/pgpool2/pgpool2-9999.ebuild
@@ -5,9 +5,9 @@ EAPI=6
EGIT_REPO_URI="https://git.postgresql.org/git/pgpool2.git"
-POSTGRES_COMPAT=( 9.{3..6} 10 )
+POSTGRES_COMPAT=( 9.{3..6} {10..11} )
-inherit git-r3 postgres-multi
+inherit autotools git-r3 postgres-multi
DESCRIPTION="Connection pool server for PostgreSQL"
HOMEPAGE="http://www.pgpool.net/"
@@ -17,18 +17,27 @@ SLOT="0"
KEYWORDS=""
-IUSE="doc memcached pam ssl static-libs"
+IUSE="doc libressl memcached pam ssl static-libs"
RDEPEND="
${POSTGRES_DEP}
net-libs/libnsl:0=
memcached? ( dev-libs/libmemcached )
pam? ( sys-auth/pambase )
- ssl? ( dev-libs/openssl:* )
+ ssl? (
+ !libressl? ( dev-libs/openssl:* )
+ libressl? ( dev-libs/libressl:= )
+ )
"
DEPEND="${RDEPEND}
- sys-devel/bison
!!dev-db/pgpool
+ sys-devel/bison
+ virtual/pkgconfig
+ doc? (
+ app-text/openjade
+ dev-libs/libxml2
+ dev-libs/libxslt
+ )
"
pkg_setup() {
@@ -38,25 +47,27 @@ pkg_setup() {
}
src_prepare() {
- eapply "${FILESDIR}/pgpool_run_paths-9999.patch"
+ eapply \
+ "${FILESDIR}/pgpool-configure-memcached.patch" \
+ "${FILESDIR}/pgpool-configure-pam.patch" \
+ "${FILESDIR}/pgpool-configure-pthread.patch" \
+ "${FILESDIR}/pgpool_run_paths-9999.patch"
+
+ eautoreconf
postgres-multi_src_prepare
}
src_configure() {
- local myconf
- use memcached && \
- myconf="--with-memcached=\"${EROOT%/}/usr/include/libmemcached\""
- use pam && myconf+=' --with-pam'
-
postgres-multi_foreach econf \
--disable-rpath \
--sysconfdir="${EROOT%/}/etc/${PN}" \
--with-pgsql-includedir='/usr/include/postgresql-@PG_SLOT@' \
--with-pgsql-libdir="/usr/$(get_libdir)/postgresql-@PG_SLOT@/$(get_libdir)" \
- $(use_with ssl openssl) \
$(use_enable static-libs static) \
- ${myconf}
+ $(use_with memcached) \
+ $(use_with pam) \
+ $(use_with ssl openssl)
}
src_compile() {
@@ -65,6 +76,7 @@ src_compile() {
# of that directory built, too.
postgres-multi_foreach emake
postgres-multi_foreach emake -C src/sql
+ use doc && postgres-multi_forbest emake DESTDIR="${D}" -C doc
}
src_install() {
@@ -79,9 +91,7 @@ src_install() {
# Documentation!
dodoc NEWS TODO
- if use doc ; then
- postgres-multi_forbest emake DESTDIR="${D}" -C doc install
- fi
+ use doc && postgres-multi_forbest emake DESTDIR="${D}" -C doc install
# Examples and extras
# mv some files that get installed to /usr/share/pgpool-II so that