summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAaron W. Swenson <titanofold@gentoo.org>2019-06-21 06:05:40 -0400
committerAaron W. Swenson <titanofold@gentoo.org>2019-06-21 06:07:55 -0400
commit95d44e303a459e9de6025f87156b58ecc6a0bc5d (patch)
tree86d6fed99418e4c97f8de10674b8c4c90156301c /dev-db/pgrouting/pgrouting-2.6.2.ebuild
parentapp-portage/portage-utils: version bump 0.80 RC (diff)
downloadgentoo-95d44e303a459e9de6025f87156b58ecc6a0bc5d.tar.gz
gentoo-95d44e303a459e9de6025f87156b58ecc6a0bc5d.tar.bz2
gentoo-95d44e303a459e9de6025f87156b58ecc6a0bc5d.zip
dev-db/pgrouting: Bump to 2.6.2
Fixes doc installation. Bug: https://bugs.gentoo.org/625778 Package-Manager: Portage-2.3.62, Repoman-2.3.11 Signed-off-by: Aaron W. Swenson <titanofold@gentoo.org>
Diffstat (limited to 'dev-db/pgrouting/pgrouting-2.6.2.ebuild')
-rw-r--r--dev-db/pgrouting/pgrouting-2.6.2.ebuild64
1 files changed, 64 insertions, 0 deletions
diff --git a/dev-db/pgrouting/pgrouting-2.6.2.ebuild b/dev-db/pgrouting/pgrouting-2.6.2.ebuild
new file mode 100644
index 000000000000..7690a22ce133
--- /dev/null
+++ b/dev-db/pgrouting/pgrouting-2.6.2.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+POSTGRES_COMPAT=( 9.{4..6} 10 11 )
+POSTGRES_USEDEP="server"
+
+inherit postgres cmake-utils
+
+DESCRIPTION="pgRouting extends PostGIS and PostgreSQL with geospatial routing functionality."
+HOMEPAGE="http://pgrouting.org/"
+LICENSE="GPL-2 MIT Boost-1.0"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+SRC_URI="https://github.com/pgRouting/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+IUSE="doc pdf html"
+
+REQUIRED_USE="html? ( doc ) pdf? ( doc )"
+
+RDEPEND="${POSTGRES_DEP}
+ >=dev-db/postgis-2.0
+ dev-libs/boost
+ sci-mathematics/cgal
+"
+
+DEPEND="
+ doc? ( >=dev-python/sphinx-1.2 )
+ pdf? ( >=dev-python/sphinx-1.2[latex] )
+"
+
+# Needs a running psql instance, doesn't work out of the box
+RESTRICT="test"
+
+pkg_setup() {
+ postgres_pkg_setup
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_HTML=$(usex html)
+ -DBUILD_LATEX=$(usex pdf)
+ -DBUILD_MAN=ON
+ -DWITH_DOC=$(usex doc)
+ )
+
+ cmake-utils_src_configure
+}
+
+src_compile() {
+ local make_opts
+ use doc && make_opts="all doc"
+ cmake-utils_src_make ${make_opts}
+}
+
+src_install() {
+ cmake-utils_src_install
+
+ doman "${BUILD_DIR}"/doc/man/en/pgrouting.7
+
+ use html && dodoc -r "${BUILD_DIR}"/doc/html
+ use pdf && dodoc "${BUILD_DIR}"/doc/latex/en/*.pdf
+}