summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAaron W. Swenson <titanofold@gentoo.org>2020-11-25 21:30:09 -0500
committerAaron W. Swenson <titanofold@gentoo.org>2020-11-25 21:30:09 -0500
commit33c03035bddb5bc325bc5fb8aa65260886f3e0ea (patch)
treed2bd67360f03f8c0717c56612d6c938ab3fc9f1c /dev-db/pgrouting/pgrouting-3.1.1.ebuild
parentnet-vpn/openvpn-2.5.0-r1: Add patch to fix libressl (bug #651228) (diff)
downloadgentoo-33c03035bddb5bc325bc5fb8aa65260886f3e0ea.tar.gz
gentoo-33c03035bddb5bc325bc5fb8aa65260886f3e0ea.tar.bz2
gentoo-33c03035bddb5bc325bc5fb8aa65260886f3e0ea.zip
dev-db/pgrouting: Bump to 3.1.1
Now supports side-by-side installations for PostgreSQL slots. Dropped support for building documentation because upstream has a novel approach. Signed-off-by: Aaron W. Swenson <titanofold@gentoo.org>
Diffstat (limited to 'dev-db/pgrouting/pgrouting-3.1.1.ebuild')
-rw-r--r--dev-db/pgrouting/pgrouting-3.1.1.ebuild56
1 files changed, 56 insertions, 0 deletions
diff --git a/dev-db/pgrouting/pgrouting-3.1.1.ebuild b/dev-db/pgrouting/pgrouting-3.1.1.ebuild
new file mode 100644
index 000000000000..2414673c0556
--- /dev/null
+++ b/dev-db/pgrouting/pgrouting-3.1.1.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+CMAKE_BUILD_TYPE="Release"
+#CMAKE_MAKEFILE_GENERATOR=emake
+
+POSTGRES_COMPAT=( 9.{5..6} {10..13} )
+POSTGRES_USEDEP="server"
+
+inherit cmake postgres-multi
+
+DESCRIPTION="pgRouting extends PostGIS and PostgreSQL with geospatial routing functionality."
+HOMEPAGE="http://pgrouting.org/"
+LICENSE="GPL-2 MIT Boost-1.0"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+SRC_URI="https://github.com/pgRouting/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+IUSE=""
+
+RDEPEND="${POSTGRES_DEP}
+ >=dev-db/postgis-2.0
+ dev-libs/boost
+ sci-mathematics/cgal
+"
+DEPEND="${RDEPEND}"
+
+# Needs a running psql instance, doesn't work out of the box
+RESTRICT="test"
+
+src_prepare() {
+ cmake_src_prepare
+ postgres-multi_src_prepare
+}
+
+my_src_configure() {
+ local mycmakeargs=(
+ -DPOSTGRESQL_BIN="$($PG_CONFIG --bindir)"
+ )
+
+ cmake_src_configure
+}
+
+src_configure() {
+ postgres-multi_foreach my_src_configure
+}
+
+src_compile() {
+ postgres-multi_foreach cmake_build
+}
+
+src_install() {
+ postgres-multi_foreach cmake_src_install
+}