summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAaron W. Swenson <titanofold@gentoo.org>2020-12-08 23:21:53 -0500
committerAaron W. Swenson <titanofold@gentoo.org>2020-12-08 23:21:53 -0500
commit6cf8a7aef3e7530063c7352c2085957473571aee (patch)
tree8f425834a68625cf6061965c53837256d0ab5361 /dev-db/pgtap/pgtap-1.1.0.ebuild
parentsys-cluster/cinder: 16.2.1 bump (diff)
downloadgentoo-6cf8a7aef3e7530063c7352c2085957473571aee.tar.gz
gentoo-6cf8a7aef3e7530063c7352c2085957473571aee.tar.bz2
gentoo-6cf8a7aef3e7530063c7352c2085957473571aee.zip
dev-db/pgtap: Bump to 1.1.0
Signed-off-by: Aaron W. Swenson <titanofold@gentoo.org>
Diffstat (limited to 'dev-db/pgtap/pgtap-1.1.0.ebuild')
-rw-r--r--dev-db/pgtap/pgtap-1.1.0.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-db/pgtap/pgtap-1.1.0.ebuild b/dev-db/pgtap/pgtap-1.1.0.ebuild
new file mode 100644
index 000000000000..ca1636c707c5
--- /dev/null
+++ b/dev-db/pgtap/pgtap-1.1.0.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+POSTGRES_COMPAT=( 9.{5..6} {10..13} )
+
+inherit postgres-multi
+
+DESCRIPTION="Unit testing for PostgreSQL"
+HOMEPAGE="https://pgtap.org/"
+SRC_URI="https://api.pgxn.org/dist/${PN}/${PV}/${P}.zip"
+
+LICENSE="POSTGRESQL"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+DEPEND="${POSTGRES_DEP}
+ app-arch/unzip
+ dev-perl/TAP-Parser-SourceHandler-pgTAP
+"
+RDEPEND="${DEPEND}"
+
+# Tests requires a running database that match up with the current
+# testing slot. Won't run from ${ED}, want's to install too early.
+RESTRICT="test"
+
+src_configure() {
+ :
+}