summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAaron W. Swenson <titanofold@gentoo.org>2022-03-22 10:28:53 -0400
committerAaron W. Swenson <titanofold@gentoo.org>2022-03-22 10:28:53 -0400
commit5d0b5920fb265d4f66ca6222e17412604c8bb2fd (patch)
treea893f8c848513441c44a297554241013822a1e47 /dev-db/pgtap
parentdev-lang/spidermonkey: drop 91.7.0 (diff)
downloadgentoo-5d0b5920fb265d4f66ca6222e17412604c8bb2fd.tar.gz
gentoo-5d0b5920fb265d4f66ca6222e17412604c8bb2fd.tar.bz2
gentoo-5d0b5920fb265d4f66ca6222e17412604c8bb2fd.zip
dev-db/pgtap: Correct src_install
src_install called default when it should have been postgres-multi_src_install. Close: https://bugs.gentoo.org/835753 Signed-off-by: Aaron W. Swenson <titanofold@gentoo.org>
Diffstat (limited to 'dev-db/pgtap')
-rw-r--r--dev-db/pgtap/pgtap-1.2.0-r2.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/dev-db/pgtap/pgtap-1.2.0-r2.ebuild b/dev-db/pgtap/pgtap-1.2.0-r2.ebuild
new file mode 100644
index 000000000000..c622db920eb2
--- /dev/null
+++ b/dev-db/pgtap/pgtap-1.2.0-r2.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+POSTGRES_COMPAT=( 9.6 {10..14} )
+
+inherit postgres-multi
+
+DESCRIPTION="Unit testing for PostgreSQL"
+HOMEPAGE="https://pgtap.org/"
+SRC_URI="https://api.pgxn.org/dist/${PN}/${PV}/${P}.zip"
+
+LICENSE="POSTGRESQL"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+DEPEND="${POSTGRES_DEP}
+ app-arch/unzip
+ dev-perl/TAP-Parser-SourceHandler-pgTAP
+"
+RDEPEND="${DEPEND}"
+
+# Tests requires a running database that match up with the current
+# testing slot. Won't run from ${ED}, want's to install too early.
+RESTRICT="test"
+
+src_configure() {
+ :
+}
+
+src_install() {
+ postgres-multi_src_install
+
+ rm -r ${ED}/usr/share/doc/postgresql* || die "Failed to remove improper doc locations"
+ dodoc doc/pgtap.mmd
+}