summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2020-07-21 18:26:44 +0200
committerAlfredo Tupone <tupone@gentoo.org>2020-07-21 18:26:44 +0200
commit27dd194da8ab27e2365bea91f1a908602bb8c797 (patch)
tree71c5cb783241a0e1ab3b430735c3d67bb6811e0f /dev-db/phppgadmin
parentdev-util/ragel: Drop 6.7-r1, 6.8 and 6.9 (diff)
downloadgentoo-27dd194da8ab27e2365bea91f1a908602bb8c797.tar.gz
gentoo-27dd194da8ab27e2365bea91f1a908602bb8c797.tar.bz2
gentoo-27dd194da8ab27e2365bea91f1a908602bb8c797.zip
dev-db/phppgadmin: version bump to 7.12.1
Package-Manager: Portage-2.3.99, Repoman-2.3.23 Signed-off-by: Alfredo Tupone <tupone@gentoo.org>
Diffstat (limited to 'dev-db/phppgadmin')
-rw-r--r--dev-db/phppgadmin/Manifest1
-rw-r--r--dev-db/phppgadmin/phppgadmin-7.12.1.ebuild38
2 files changed, 39 insertions, 0 deletions
diff --git a/dev-db/phppgadmin/Manifest b/dev-db/phppgadmin/Manifest
index 9ef1200084b2..3c7c0c8634c2 100644
--- a/dev-db/phppgadmin/Manifest
+++ b/dev-db/phppgadmin/Manifest
@@ -1 +1,2 @@
DIST phpPgAdmin-5.6.0.tar.bz2 880640 BLAKE2B a49fb97c26c35323b567f06002cc6da9f3efacb4be99633e6ad4d6a53015e557ef3c98a4bf9c4dedf525b86354816e744f6159bad7db6f52fe2c03223f0be9a1 SHA512 afe4c99322bb24bf1895afb20dd87dcad1fc7d887b9271d9dd6b56779a7b5c8aa7293cdc7fa560a62a830adbf5453914a4783a1265915b24594779c0beeaecda
+DIST phpPgAdmin-7.12.1.tar.bz2 579723 BLAKE2B 58d4992424fb6c9bf8565843c6d76ceecb68212cc311d15d43303fd6b63fe2a611ce146761b8f6b8f992798060d065a0b0e528aed5df217a3078cef9e56c49da SHA512 d64b4796c5acad990ef81b12ebd377474d04c1a65adc41a91a2d278bb975812389bb6eae23490de3f5ce09502d36adea3cacfdec0e868c6a0e0bcb639b8a94db
diff --git a/dev-db/phppgadmin/phppgadmin-7.12.1.ebuild b/dev-db/phppgadmin/phppgadmin-7.12.1.ebuild
new file mode 100644
index 000000000000..e0ec4521ab80
--- /dev/null
+++ b/dev-db/phppgadmin/phppgadmin-7.12.1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit webapp
+
+MY_P="phpPgAdmin-${PV}"
+
+DESCRIPTION="Web-based administration for Postgres database in php"
+HOMEPAGE="http://phppgadmin.sourceforge.net/"
+SRC_URI="https://github.com/${PN}/${PN}/releases/download/REL_$(ver_rs 1- -)/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2"
+KEYWORDS="~amd64"
+IUSE=""
+
+RDEPEND="dev-lang/php[postgres,session]"
+
+S="${WORKDIR}/${MY_P}"
+
+src_install() {
+ webapp_src_preinst
+
+ local doc
+ local docs="CREDITS DEVELOPERS FAQ HISTORY INSTALL TODO TRANSLATORS"
+ dodoc ${docs}
+ mv conf/config.inc.php-dist conf/config.inc.php
+
+ cp -r * "${D}"${MY_HTDOCSDIR}
+ for doc in ${docs} INSTALL LICENSE; do
+ rm -f "${D}"${MY_HTDOCSDIR}/${doc}
+ done
+
+ webapp_configfile ${MY_HTDOCSDIR}/conf/config.inc.php
+ webapp_postinst_txt en "${FILESDIR}"/postinstall-en.txt
+ webapp_src_install
+}