summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-04-19 16:29:46 +0100
committerSam James <sam@gentoo.org>2022-05-14 00:46:57 +0000
commitee9ac56b728a77a8a6b62b983c13c85342ef0f38 (patch)
tree186df44082b81206fb8301c6be2fbfa8affed571 /dev-db/plr
parentnet-libs/serf: [QA] inline ESYSROOT (diff)
downloadgentoo-ee9ac56b728a77a8a6b62b983c13c85342ef0f38.tar.gz
gentoo-ee9ac56b728a77a8a6b62b983c13c85342ef0f38.tar.bz2
gentoo-ee9ac56b728a77a8a6b62b983c13c85342ef0f38.zip
dev-db/plr: add 8.4.5, inline ESYSROOT
(ESYSROOT is SYSROOT/EPREFIX in >= EAPI 7) Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-db/plr')
-rw-r--r--dev-db/plr/Manifest1
-rw-r--r--dev-db/plr/plr-8.4.5.ebuild70
2 files changed, 71 insertions, 0 deletions
diff --git a/dev-db/plr/Manifest b/dev-db/plr/Manifest
index 92687bf21aa4..9098fc212b61 100644
--- a/dev-db/plr/Manifest
+++ b/dev-db/plr/Manifest
@@ -1,2 +1,3 @@
DIST plr-8.3.0.17.tar.gz 74017 BLAKE2B 314b4cfa2c3ca8ed31e80a72233a6dc8cdb9f3811dad6e9f3eb5147c17cdf5a039436598b0fc2b30c6702b02dd3cb2da33543764aee3199c6864aae22be875ce SHA512 d7080c62349d1dcdd17008a7be3643b54678e0f66bf721068df73057394496d025c4fe01e52945c3acf9cc21eb90241512667772ef3fe519a3c9081efe92dd40
DIST plr-8.4.1.tar.gz 265142 BLAKE2B 859913ba14d3e6876eb5a3d7593346b98ab2e1b6c70d9fd9cc7e1810fe11ecb3c552305485735cf975cc41ce2de6cbd7bcf407c9e373fc4024230be797c9899a SHA512 0db407355271009bad95c21f81e544839322f0fa0a63d2abd8edbf9eab8f61e208a3e4f7083729cc8247411885197ff3569c88264db0a29b34523dc83bbed7ec
+DIST plr-8.4.5.tar.gz 273711 BLAKE2B 666941f1cbc7e74dee532b928102afda4684b344f3c69a6ac4e3449c057e8f4dbb74b765f4222bb06e61940fa1e4ba888cc60bac193ca43989b557da9d02ceaa SHA512 bb04a8956d1cdc7acb20c89ea3b17be6ee385dac52381ab0f8af7446480fa9b8d163ff6697a05b439a75f57841b203e65bea78db8a7c3d55c1118bebbf4ac81a
diff --git a/dev-db/plr/plr-8.4.5.ebuild b/dev-db/plr/plr-8.4.5.ebuild
new file mode 100644
index 000000000000..a75eb62a0b0f
--- /dev/null
+++ b/dev-db/plr/plr-8.4.5.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+POSTGRES_COMPAT=( 9.6 {10..14} )
+POSTGRES_USEDEP="server"
+
+inherit postgres-multi
+
+DESCRIPTION="R language extension for postgresql database"
+HOMEPAGE="http://www.joeconway.com/plr/"
+SRC_URI="https://github.com/postgres-plr/plr/archive/REL${PV//./_}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="dev-lang/R
+ ${POSTGRES_DEP}"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+REQUIRED_USE="${POSTGRES_REQ_USE}"
+
+S="${WORKDIR}"/contrib/${PN}
+
+src_unpack() {
+ unpack ${A}
+
+ # the build system wants 'contrib' to be part of the path
+ mkdir -p "${WORKDIR}/contrib" || die
+ mv "${WORKDIR}/${PN}-REL${PV//./_}" "${S}" || die
+}
+
+src_prepare() {
+ local BUILD_DIR="${S}"
+ postgres-multi_src_prepare
+}
+
+src_compile() {
+ pg_src_compile() {
+ cd "${BUILD_DIR}"
+ PG_CONFIG="${ESYSROOT}/usr/$(get_libdir)/postgresql-${MULTIBUILD_ID}/bin/pg_config" \
+ USE_PGXS=1 \
+ emake -j1
+ }
+ postgres-multi_foreach pg_src_compile
+}
+
+src_install() {
+ pg_src_install() {
+ cd "${BUILD_DIR}"
+ PG_CONFIG="${ESYSROOT}/usr/$(get_libdir)/postgresql-${MULTIBUILD_ID}/bin/pg_config" \
+ USE_PGXS=1 \
+ emake -j1 DESTDIR="${D}" install
+ }
+ postgres-multi_foreach pg_src_install
+}
+
+pkg_postinst() {
+ elog "The plr extension needs to be explicitly added (or 'created') on each database"
+ elog "you wish to use it with. As of postgresql-9.1 the easiest way to do this is"
+ elog "with the proprietary SQL statement:"
+ elog
+ elog "\tCREATE EXTENSION plr;"
+ elog
+ elog "For more info on how to add PL/R to your postgresql database(s), please visit"
+ elog "http://www.joeconway.com/doc/plr-install.html"
+}