summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2020-02-08 17:21:07 +0100
committerDavid Seifert <soap@gentoo.org>2020-02-08 17:21:07 +0100
commitb0890289f729e199c8c3a0050a84a4d1ca5b956f (patch)
tree75b529f4f0736d3ac0e63a3e8f3461abe03308ff /dev-db/postgresql/postgresql-11.5.ebuild
parentdev-db/mysql-connector-c++: [QA] Fix UnnecessarySlashStrip (diff)
downloadgentoo-b0890289f729e199c8c3a0050a84a4d1ca5b956f.tar.gz
gentoo-b0890289f729e199c8c3a0050a84a4d1ca5b956f.tar.bz2
gentoo-b0890289f729e199c8c3a0050a84a4d1ca5b956f.zip
dev-db/postgresql: [QA] Fix UnnecessarySlashStrip
Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'dev-db/postgresql/postgresql-11.5.ebuild')
-rw-r--r--dev-db/postgresql/postgresql-11.5.ebuild28
1 files changed, 14 insertions, 14 deletions
diff --git a/dev-db/postgresql/postgresql-11.5.ebuild b/dev-db/postgresql/postgresql-11.5.ebuild
index 665416e9dcbc..67c77e9b5084 100644
--- a/dev-db/postgresql/postgresql-11.5.ebuild
+++ b/dev-db/postgresql/postgresql-11.5.ebuild
@@ -133,7 +133,7 @@ src_configure() {
export LDFLAGS_SL="${LDFLAGS}"
export LDFLAGS_EX="${LDFLAGS}"
- local PO="${EPREFIX%/}"
+ local PO="${EPREFIX}"
local i uuid_config=""
if use uuid; then
@@ -283,7 +283,7 @@ pkg_postinst() {
postgresql-config update
elog "If you need a global psqlrc-file, you can place it in:"
- elog " ${EROOT%/}/etc/postgresql-${SLOT}/"
+ elog " ${EROOT}/etc/postgresql-${SLOT}/"
if use server ; then
elog
@@ -294,11 +294,11 @@ pkg_postinst() {
elog "http://www.postgresql.org/docs/${SLOT}/static/index.html"
elog
elog "The default location of the Unix-domain socket is:"
- elog " ${EROOT%/}/run/postgresql/"
+ elog " ${EROOT}/run/postgresql/"
elog
elog "Before initializing the database, you may want to edit PG_INITDB_OPTS"
elog "so that it contains your preferred locale in:"
- elog " ${EROOT%/}/etc/conf.d/postgresql-${SLOT}"
+ elog " ${EROOT}/etc/conf.d/postgresql-${SLOT}"
elog
elog "Then, execute the following command to setup the initial database"
elog "environment:"
@@ -332,15 +332,15 @@ pkg_postrm() {
pkg_config() {
use server || die "USE flag 'server' not enabled. Nothing to configure."
- [[ -f "${EROOT%/}/etc/conf.d/postgresql-${SLOT}" ]] \
- && source "${EROOT%/}/etc/conf.d/postgresql-${SLOT}"
- [[ -z "${PGDATA}" ]] && PGDATA="${EROOT%/}/etc/postgresql-${SLOT}/"
+ [[ -f "${EROOT}/etc/conf.d/postgresql-${SLOT}" ]] \
+ && source "${EROOT}/etc/conf.d/postgresql-${SLOT}"
+ [[ -z "${PGDATA}" ]] && PGDATA="${EROOT}/etc/postgresql-${SLOT}/"
[[ -z "${DATA_DIR}" ]] \
- && DATA_DIR="${EROOT%/}/var/lib/postgresql/${SLOT}/data"
+ && DATA_DIR="${EROOT}/var/lib/postgresql/${SLOT}/data"
# environment.bz2 may not contain the same locale as the current system
# locale. Unset and source from the current system locale.
- if [ -f "${EROOT%/}/etc/env.d/02locale" ]; then
+ if [ -f "${EROOT}/etc/env.d/02locale" ]; then
unset LANG
unset LC_CTYPE
unset LC_NUMERIC
@@ -349,7 +349,7 @@ pkg_config() {
unset LC_MONETARY
unset LC_MESSAGES
unset LC_ALL
- source "${EROOT%/}/etc/env.d/02locale"
+ source "${EROOT}/etc/env.d/02locale"
[ -n "${LANG}" ] && export LANG
[ -n "${LC_CTYPE}" ] && export LC_CTYPE
[ -n "${LC_NUMERIC}" ] && export LC_NUMERIC
@@ -361,7 +361,7 @@ pkg_config() {
fi
einfo "You can modify the paths and options passed to initdb by editing:"
- einfo " ${EROOT%/}/etc/conf.d/postgresql-${SLOT}"
+ einfo " ${EROOT}/etc/conf.d/postgresql-${SLOT}"
einfo
einfo "Information on options that can be passed to initdb are found at:"
einfo " http://www.postgresql.org/docs/${SLOT}/static/creating-cluster.html"
@@ -401,9 +401,9 @@ pkg_config() {
einfo "Initializing the database ..."
if [[ ${EUID} == 0 ]] ; then
- su postgres -c "${EROOT%/}/usr/$(get_libdir)/postgresql-${SLOT}/bin/initdb -D \"${DATA_DIR}\" ${PG_INITDB_OPTS}"
+ su postgres -c "${EROOT}/usr/$(get_libdir)/postgresql-${SLOT}/bin/initdb -D \"${DATA_DIR}\" ${PG_INITDB_OPTS}"
else
- "${EROOT%/}"/usr/$(get_libdir)/postgresql-${SLOT}/bin/initdb -U postgres -D "${DATA_DIR}" ${PG_INITDB_OPTS}
+ "${EROOT}"/usr/$(get_libdir)/postgresql-${SLOT}/bin/initdb -U postgres -D "${DATA_DIR}" ${PG_INITDB_OPTS}
fi
if [[ "${DATA_DIR%/}" != "${PGDATA%/}" ]] ; then
@@ -446,7 +446,7 @@ pkg_config() {
einfo "You should use the 'postgresql-${SLOT}.service' unit to run PostgreSQL"
einfo "instead of 'pg_ctl'."
else
- einfo "You should use the '${EROOT%/}/etc/init.d/postgresql-${SLOT}' script to run PostgreSQL"
+ einfo "You should use the '${EROOT}/etc/init.d/postgresql-${SLOT}' script to run PostgreSQL"
einfo "instead of 'pg_ctl'."
fi
}