summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAaron W. Swenson <titanofold@gentoo.org>2018-01-11 05:34:14 -0500
committerAaron W. Swenson <titanofold@gentoo.org>2018-01-11 05:34:14 -0500
commitf48f559e65e4b1867073b9782b6120f26a658a2b (patch)
tree1f0d768400b392d54a7b3e985263327745fe1c00 /dev-db/psqlodbc/psqlodbc-10.01.0000.ebuild
parentx11-terms/xterm: Removed old. (diff)
downloadgentoo-f48f559e65e4b1867073b9782b6120f26a658a2b.tar.gz
gentoo-f48f559e65e4b1867073b9782b6120f26a658a2b.tar.bz2
gentoo-f48f559e65e4b1867073b9782b6120f26a658a2b.zip
dev-db/psqlodbc: Bump to 10.01.0000
Package-Manager: Portage-2.3.13, Repoman-2.3.3
Diffstat (limited to 'dev-db/psqlodbc/psqlodbc-10.01.0000.ebuild')
-rw-r--r--dev-db/psqlodbc/psqlodbc-10.01.0000.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-db/psqlodbc/psqlodbc-10.01.0000.ebuild b/dev-db/psqlodbc/psqlodbc-10.01.0000.ebuild
new file mode 100644
index 000000000000..a7d8360210f1
--- /dev/null
+++ b/dev-db/psqlodbc/psqlodbc-10.01.0000.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+DESCRIPTION="Official ODBC driver for PostgreSQL"
+HOMEPAGE="http://www.postgresql.org/"
+SRC_URI="mirror://postgresql/odbc/versions/src/${P}.tar.gz"
+SLOT="0"
+LICENSE="LGPL-2"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc iodbc ssl threads"
+
+DEPEND="dev-db/postgresql:*[ssl?]
+ !iodbc? ( dev-db/unixODBC )
+ iodbc? ( dev-db/libiodbc )
+"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ econf \
+ $(use_with iodbc) \
+ $(use_with !iodbc unixodbc) \
+ $(use_enable threads pthreads)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+
+ dodoc readme.txt
+ use doc && dodoc docs/*{html,jpg,txt}
+}