summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAaron W. Swenson <titanofold@gentoo.org>2017-04-18 11:19:42 -0400
committerAaron W. Swenson <titanofold@gentoo.org>2017-04-18 11:20:12 -0400
commit41bb5290789187f89136604f541d9f2959dcda47 (patch)
tree1f322069745c2ee5323e2c5b93a7a6047c9828d1 /dev-db/psqlodbc
parentnet-misc/apt-proxy: Remove last-rited pkg (diff)
downloadgentoo-41bb5290789187f89136604f541d9f2959dcda47.tar.gz
gentoo-41bb5290789187f89136604f541d9f2959dcda47.tar.bz2
gentoo-41bb5290789187f89136604f541d9f2959dcda47.zip
dev-db/psqlodbc: Version bump
Cleaned up the ebuild as well as there isn’t any dependency on a particular version of PostgreSQL. This should prevent any future issue of blocking old slots of dev-db/postgresql. Package-Manager: portage-2.3.0
Diffstat (limited to 'dev-db/psqlodbc')
-rw-r--r--dev-db/psqlodbc/Manifest1
-rw-r--r--dev-db/psqlodbc/psqlodbc-09.06.0200.ebuild33
2 files changed, 34 insertions, 0 deletions
diff --git a/dev-db/psqlodbc/Manifest b/dev-db/psqlodbc/Manifest
index d8ae24216600..0dfd41e103e5 100644
--- a/dev-db/psqlodbc/Manifest
+++ b/dev-db/psqlodbc/Manifest
@@ -1,2 +1,3 @@
DIST psqlodbc-09.02.0100.tar.gz 738231 SHA256 6701525030a8c927059f972ebd65e83a41f7f177228cd8e894654893d86cb93c SHA512 5d2eae82596b3a120b00c140441c47af065a201236fef9aa086372f2207bab2f2bffee7d0db177a64c370118eaa4348509dcb3e99a40f564d26d4e938c57cc68 WHIRLPOOL e300672c7608e28af52befbb62a16c8584a709b75fc12edeadf37b2d26a8cdd64a390af026ec752408818d053d51202c829b6ad62d82a543dbce21ce6624d3c0
DIST psqlodbc-09.03.0210.tar.gz 784548 SHA256 42f2a57ec65c8a2edb0736f57b03c510986f33a9178d3d695616734dcc5e96d9 SHA512 da6b8da28c8ddd0912c57b7c1b8a2b494446b07ef7c6db8b56006b0c26705f64d413bdfed64b99e8baf6db70f1b578e818ad9ead357d16a8765deff7121c0a44 WHIRLPOOL 03f191421d95ab7b7da3c7806fc0081d66588bf5d860097fd9a239219d59ebdbe56790bf62786fb145f6378b60fdeb37ac74196f41de7e6ae7ac5551ba6f47c2
+DIST psqlodbc-09.06.0200.tar.gz 887807 SHA256 aaa44027f98478635b4ab512a4f90c1aaf56a710276a482b3b0ef6740e20e415 SHA512 d8e3b6c13e657b4a3435ace94e6e1265a5a1a7bcd3a1f81348ca4edcb532b66036e3595ecd7224d3104f6a3f2e02704f73c1b62d94e9879528933edef7764552 WHIRLPOOL 398386f79928e65d29a493fa7d293e9adf2e6352c95c21d9e474675f0a5562128f7f514c834f444659222ebabc84402e5b9abc7a4832728468eb6e4b79c0e609
diff --git a/dev-db/psqlodbc/psqlodbc-09.06.0200.ebuild b/dev-db/psqlodbc/psqlodbc-09.06.0200.ebuild
new file mode 100644
index 000000000000..1b84488b8768
--- /dev/null
+++ b/dev-db/psqlodbc/psqlodbc-09.06.0200.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+DESCRIPTION="Official ODBC driver for PostgreSQL"
+HOMEPAGE="http://www.postgresql.org/"
+SRC_URI="mirror://postgresql/odbc/versions/src/${P}.tar.gz"
+SLOT="0"
+LICENSE="LGPL-2"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc iodbc ssl threads unicode"
+
+DEPEND="dev-db/postgresql:*[ssl?]
+ !iodbc? ( dev-db/unixODBC )
+ iodbc? ( dev-db/libiodbc )
+"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ econf \
+ $(use_with iodbc) \
+ $(use_with !iodbc unixodbc) \
+ $(use_enable threads pthreads) \
+ $(use_enable unicode)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+
+ dodoc readme.txt
+ use doc && dodoc docs/*{html,jpg,txt}
+}