summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAkinori Hattori <hattya@gentoo.org>2017-03-30 23:26:43 +0900
committerAkinori Hattori <hattya@gentoo.org>2017-03-30 23:26:43 +0900
commitb64dfb87139e61279882f7a0c1d498bcdaf88919 (patch)
tree58b9ba7e820cbaba2b8778e5ebf2c13949b7761c /dev-db/qdbm/qdbm-1.8.78-r1.ebuild
parentdev-db/qdbm: update to EAPI 6 (diff)
downloadgentoo-b64dfb87139e61279882f7a0c1d498bcdaf88919.tar.gz
gentoo-b64dfb87139e61279882f7a0c1d498bcdaf88919.tar.bz2
gentoo-b64dfb87139e61279882f7a0c1d498bcdaf88919.zip
dev-db/qdbm: fix build
Gentoo-Bug: 584998 Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'dev-db/qdbm/qdbm-1.8.78-r1.ebuild')
-rw-r--r--dev-db/qdbm/qdbm-1.8.78-r1.ebuild14
1 files changed, 13 insertions, 1 deletions
diff --git a/dev-db/qdbm/qdbm-1.8.78-r1.ebuild b/dev-db/qdbm/qdbm-1.8.78-r1.ebuild
index 6f6bd6fc00d2..cbde7564d40f 100644
--- a/dev-db/qdbm/qdbm-1.8.78-r1.ebuild
+++ b/dev-db/qdbm/qdbm-1.8.78-r1.ebuild
@@ -3,7 +3,7 @@
EAPI="6"
-inherit java-pkg-opt-2 perl-functions
+inherit autotools java-pkg-opt-2 perl-functions
DESCRIPTION="Quick Database Manager"
HOMEPAGE="http://fallabs.com/qdbm/"
@@ -24,12 +24,15 @@ DEPEND="${RDEPEND}
java? ( >=virtual/jdk-1.4:* )"
PATCHES=(
+ "${FILESDIR}"/${PN}-configure.patch
"${FILESDIR}"/${PN}-perl.patch
"${FILESDIR}"/${PN}-ruby19.patch
"${FILESDIR}"/${PN}-runpath.patch
)
HTML_DOCS=( doc/. )
+AT_NOELIBTOOLIZE="yes"
+
qdbm_foreach_api() {
local u
for u in cxx java perl ruby; do
@@ -42,6 +45,10 @@ qdbm_foreach_api() {
fi
cd "${u}"
case "${EBUILD_PHASE}" in
+ prepare)
+ mv configure.{in,ac}
+ eautoreconf
+ ;;
configure)
case "${u}" in
cgi|java|plus)
@@ -75,8 +82,13 @@ src_prepare() {
-e "/^CXXFLAGS/s|$| ${CXXFLAGS}|" \
-e "/^JAVACFLAGS/s|$| ${JAVACFLAGS}|" \
-e 's/make\( \|$\)/$(MAKE)\1/g' \
+ -e '/^debug/,/^$/s/LDFLAGS="[^"]*" //' \
Makefile.in {cgi,java,perl,plus,ruby}/Makefile.in
find -name "*~" -delete
+
+ mv configure.{in,ac}
+ eautoreconf
+ qdbm_foreach_api
}
src_configure() {