summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2016-11-18 15:17:48 -0800
committerRobin H. Johnson <robbat2@gentoo.org>2016-11-18 15:25:27 -0800
commit30175f8d0e50d35a0924bf8ae6c0d4b4e7e4c559 (patch)
tree54c709548961ccc9562ad4f7fa5822999c56a1f0 /dev-db/redis/files/redis-3.2.5-shared.patch
parentprofiles/package.mask: mask dev-db/redis-3.2.5-r1 for slotted lua. (diff)
downloadgentoo-30175f8d0e50d35a0924bf8ae6c0d4b4e7e4c559.tar.gz
gentoo-30175f8d0e50d35a0924bf8ae6c0d4b4e7e4c559.tar.bz2
gentoo-30175f8d0e50d35a0924bf8ae6c0d4b4e7e4c559.zip
dev-db/redis: bump for bug #589044.
Package-Manager: portage-2.3.2
Diffstat (limited to 'dev-db/redis/files/redis-3.2.5-shared.patch')
-rw-r--r--dev-db/redis/files/redis-3.2.5-shared.patch30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-db/redis/files/redis-3.2.5-shared.patch b/dev-db/redis/files/redis-3.2.5-shared.patch
new file mode 100644
index 000000000000..7ebff12b5196
--- /dev/null
+++ b/dev-db/redis/files/redis-3.2.5-shared.patch
@@ -0,0 +1,30 @@
+diff --git a/src/Makefile b/src/Makefile
+index fdbe36a..df224ae 100644
+--- a/src/Makefile
++++ b/src/Makefile
+@@ -26,12 +26,7 @@ PREFIX?=/usr/local
+ INSTALL_BIN=$(PREFIX)/bin
+ INSTALL=install
+
+-# Default allocator
+-ifeq ($(uname_S),Linux)
+- MALLOC=jemalloc
+-else
+- MALLOC=libc
+-endif
++MALLOC?=jemalloc
+
+ # Backwards compatibility for selecting an allocator
+ ifeq ($(USE_TCMALLOC),yes)
+@@ -103,9 +98,8 @@ ifeq ($(MALLOC),tcmalloc_minimal)
+ endif
+
+ ifeq ($(MALLOC),jemalloc)
+- DEPENDENCY_TARGETS+= jemalloc
+- FINAL_CFLAGS+= -DUSE_JEMALLOC -I../deps/jemalloc/include
+- FINAL_LIBS+= ../deps/jemalloc/lib/libjemalloc.a
++ FINAL_CFLAGS+= -DUSE_JEMALLOC -DJEMALLOC_NO_DEMANGLE
++ FINAL_LIBS+= -ljemalloc -ldl
+ endif
+
+ REDIS_CC=$(QUIET_CC)$(CC) $(FINAL_CFLAGS)