summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomas Mozes <hydrapolic@gmail.com>2018-10-18 14:12:27 +0200
committerThomas Deutschmann <whissi@gentoo.org>2018-10-26 15:17:44 +0200
commit23040f93869d3b935312c475084c834d3be62558 (patch)
tree22b27f48047820aa6b1f0d26b620a8fefca5051f /dev-db/redis/files
parentapp-admin/syslog-ng: bump to 3.18.1 (diff)
downloadgentoo-23040f93869d3b935312c475084c834d3be62558.tar.gz
gentoo-23040f93869d3b935312c475084c834d3be62558.tar.bz2
gentoo-23040f93869d3b935312c475084c834d3be62558.zip
dev-db/redis: bump to 5.0.0
Closes: https://bugs.gentoo.org/668950 Signed-off-by: Tomáš Mózes <hydrapolic@gmail.com> Package-Manager: Portage-2.3.51, Repoman-2.3.11 Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
Diffstat (limited to 'dev-db/redis/files')
-rw-r--r--dev-db/redis/files/redis-5.0-sharedlua.patch4
-rw-r--r--dev-db/redis/files/redis-sentinel-5.0-config.patch21
2 files changed, 17 insertions, 8 deletions
diff --git a/dev-db/redis/files/redis-5.0-sharedlua.patch b/dev-db/redis/files/redis-5.0-sharedlua.patch
index 76971cf4571e..3e14f41733b0 100644
--- a/dev-db/redis/files/redis-5.0-sharedlua.patch
+++ b/dev-db/redis/files/redis-5.0-sharedlua.patch
@@ -12,7 +12,7 @@ index c26c0d7..fa50c41 100644
#ifndef CJSON_MODNAME
#define CJSON_MODNAME "cjson"
diff --git a/src/Makefile b/src/Makefile
-index f5525bd..cecd8d0 100644
+index 773d3b2..2d120d4 100644
--- a/src/Makefile
+++ b/src/Makefile
@@ -16,7 +16,7 @@ release_hdr := $(shell sh -c './mkreleasehdr.sh')
@@ -44,7 +44,7 @@ index f5525bd..cecd8d0 100644
@@ -145,6 +146,7 @@ endif
REDIS_SERVER_NAME=redis-server
REDIS_SENTINEL_NAME=redis-sentinel
- REDIS_SERVER_OBJ=adlist.o quicklist.o ae.o anet.o dict.o server.o sds.o zmalloc.o lzf_c.o lzf_d.o pqsort.o zipmap.o sha1.o ziplist.o release.o networking.o util.o object.o db.o replication.o rdb.o t_string.o t_list.o t_set.o t_zset.o t_hash.o config.o aof.o pubsub.o multi.o debug.o sort.o intset.o syncio.o cluster.o crc16.o endianconv.o slowlog.o scripting.o bio.o rio.o rand.o memtest.o crc64.o bitops.o sentinel.o notify.o setproctitle.o blocked.o hyperloglog.o latency.o sparkline.o redis-check-rdb.o redis-check-aof.o geo.o lazyfree.o module.o evict.o expire.o geohash.o geohash_helper.o childinfo.o defrag.o siphash.o rax.o t_stream.o listpack.o localtime.o
+ REDIS_SERVER_OBJ=adlist.o quicklist.o ae.o anet.o dict.o server.o sds.o zmalloc.o lzf_c.o lzf_d.o pqsort.o zipmap.o sha1.o ziplist.o release.o networking.o util.o object.o db.o replication.o rdb.o t_string.o t_list.o t_set.o t_zset.o t_hash.o config.o aof.o pubsub.o multi.o debug.o sort.o intset.o syncio.o cluster.o crc16.o endianconv.o slowlog.o scripting.o bio.o rio.o rand.o memtest.o crc64.o bitops.o sentinel.o notify.o setproctitle.o blocked.o hyperloglog.o latency.o sparkline.o redis-check-rdb.o redis-check-aof.o geo.o lazyfree.o module.o evict.o expire.o geohash.o geohash_helper.o childinfo.o defrag.o siphash.o rax.o t_stream.o listpack.o localtime.o lolwut.o lolwut5.o
+REDIS_SERVER_OBJ+=fpconv.o strbuf.o lua_bit.o lua_cjson.o lua_cmsgpack.o lua_struct.o
REDIS_CLI_NAME=redis-cli
REDIS_CLI_OBJ=anet.o adlist.o dict.o redis-cli.o zmalloc.o release.o anet.o ae.o crc64.o siphash.o crc16.o
diff --git a/dev-db/redis/files/redis-sentinel-5.0-config.patch b/dev-db/redis/files/redis-sentinel-5.0-config.patch
index 53299f11840f..099b4eef818c 100644
--- a/dev-db/redis/files/redis-sentinel-5.0-config.patch
+++ b/dev-db/redis/files/redis-sentinel-5.0-config.patch
@@ -1,10 +1,19 @@
diff --git a/sentinel.conf b/sentinel.conf
-index 3703c73..964ffa3 100644
+index bc9a705..05e58d3 100644
--- a/sentinel.conf
+++ b/sentinel.conf
-@@ -222,3 +222,5 @@ sentinel deny-scripts-reconfig yes
- # case, so writing "config guessme" is the same in the example above.
- #
- # SENTINEL SET can also be used in order to perform this configuration at runtime.
-+
+@@ -28,12 +28,12 @@ daemonize no
+ # When running daemonized, Redis Sentinel writes a pid file in
+ # /var/run/redis-sentinel.pid by default. You can specify a custom pid file
+ # location here.
+-pidfile /var/run/redis-sentinel.pid
++pidfile /run/redis-sentinel.pid
+
+ # Specify the log file name. Also the empty string can be used to force
+ # Sentinel to log on the standard output. Note that if you use standard
+ # output for logging but daemonize, logs will be sent to /dev/null
+-logfile ""
+logfile "/var/log/redis/sentinel.log"
+
+ # sentinel announce-ip <ip>
+ # sentinel announce-port <port>