summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHorea Christian <horea.christ@yandex.com>2017-05-28 22:06:46 +0200
committerMichał Górny <mgorny@gentoo.org>2017-06-14 00:47:00 +0200
commit4c4b5008318aca6743877e82c024820e66cfd48b (patch)
tree59584794bf98e652119fd818dde629ab5673b36b /dev-db/sadisplay/sadisplay-0.4.8.ebuild
parentkde-plasma: Remove KDE Plasma 5.10.1 (diff)
downloadgentoo-4c4b5008318aca6743877e82c024820e66cfd48b.tar.gz
gentoo-4c4b5008318aca6743877e82c024820e66cfd48b.tar.bz2
gentoo-4c4b5008318aca6743877e82c024820e66cfd48b.zip
dev-db/sadisplay: new package
Closes: https://github.com/gentoo/gentoo/pull/4795 Package-Manager: Portage-2.3.5, Repoman-2.3.2
Diffstat (limited to 'dev-db/sadisplay/sadisplay-0.4.8.ebuild')
-rw-r--r--dev-db/sadisplay/sadisplay-0.4.8.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-db/sadisplay/sadisplay-0.4.8.ebuild b/dev-db/sadisplay/sadisplay-0.4.8.ebuild
new file mode 100644
index 000000000000..56d89724d9dc
--- /dev/null
+++ b/dev-db/sadisplay/sadisplay-0.4.8.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5} )
+
+inherit distutils-r1
+
+DESCRIPTION="SqlAlchemy schema display script"
+HOMEPAGE="https://bitbucket.org/estin/sadisplay/wiki/Home"
+COMMIT_ID="d67d12894ebd"
+SRC_URI="https://bitbucket.org/estin/sadisplay/get/${COMMIT_ID}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND="dev-python/sqlalchemy[${PYTHON_USEDEP}]"
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( ${RDEPEND} )
+ "
+S="${WORKDIR}/estin-${PN}-${COMMIT_ID}"
+
+python_test() {
+ nosetests -v || die
+}