summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHorea Christian <chr@chymera.eu>2020-04-20 02:04:40 -0400
committerJoonas Niilola <juippis@gentoo.org>2020-04-23 09:36:26 +0300
commit99cbd51f902a056a90dfc868d280f235e3bbc0f8 (patch)
treeb0a359ed33b8d57173dbb72a14fe7e848005615f /dev-db/sadisplay
parentapp-emulation/virtio-win: removed older version 0.1.160 (diff)
downloadgentoo-99cbd51f902a056a90dfc868d280f235e3bbc0f8.tar.gz
gentoo-99cbd51f902a056a90dfc868d280f235e3bbc0f8.tar.bz2
gentoo-99cbd51f902a056a90dfc868d280f235e3bbc0f8.zip
dev-db/sadisplay: version bump 0.4.9, bug #718272
and PYTHON_COMPAT update Closes: https://bugs.gentoo.org/718272 Package-Manager: Portage-2.3.99, Repoman-2.3.22 Signed-off-by: Horea Christian <chr@chymera.eu> Closes: https://github.com/gentoo/gentoo/pull/15437 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'dev-db/sadisplay')
-rw-r--r--dev-db/sadisplay/Manifest1
-rw-r--r--dev-db/sadisplay/sadisplay-0.4.9.ebuild24
2 files changed, 25 insertions, 0 deletions
diff --git a/dev-db/sadisplay/Manifest b/dev-db/sadisplay/Manifest
index 9c5c9390de75..4b5219100347 100644
--- a/dev-db/sadisplay/Manifest
+++ b/dev-db/sadisplay/Manifest
@@ -1 +1,2 @@
DIST sadisplay-0.4.8.tar.gz 9063 BLAKE2B a6b965d6703102000510ae6100a6bb4d0ad5b42543408aea520476128897bf8f38fda276ea39ac066e9b6621ecf2634d20e82ca21543b8c0bb472ac5d804b2a1 SHA512 c3707f90a20028fdb164caa3037f4ffff3da3f4bc763c400f8204dae4d7d71862e65902892d8ad0fe3bbe636cf87e4f96a475e01e8ce0ac55bed4e17073e3308
+DIST sadisplay-0.4.9.tar.gz 9536 BLAKE2B 0265eb470ab600b761cf6d0e1872c3225e863de8aa602fbcdb1839c33ced8825318d4e4f8ee24de420847c077d1830af069af37ea8d3e3e6c76f47dc2335e1b3 SHA512 30fe8dd2a6247328bc4d7640e5a34b15a062322729cb8a2ffb66c740145475a95ac924f752017fda8f347268ce598957cfe78e8fd6f80413267c72b143b3e8b8
diff --git a/dev-db/sadisplay/sadisplay-0.4.9.ebuild b/dev-db/sadisplay/sadisplay-0.4.9.ebuild
new file mode 100644
index 000000000000..fba6f55c38ae
--- /dev/null
+++ b/dev-db/sadisplay/sadisplay-0.4.9.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8} )
+
+DISTUTILS_USE_SETUPTOOLS=bdepend
+
+inherit distutils-r1
+
+DESCRIPTION="SqlAlchemy schema display script"
+HOMEPAGE="https://bitbucket.org/estin/sadisplay/wiki/Home"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="dev-python/sqlalchemy[${PYTHON_USEDEP}]"
+
+distutils_enable_tests pytest