summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-db/spatialite-tools
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-db/spatialite-tools')
-rw-r--r--dev-db/spatialite-tools/Manifest1
-rw-r--r--dev-db/spatialite-tools/metadata.xml5
-rw-r--r--dev-db/spatialite-tools/spatialite-tools-3.1.0.ebuild33
3 files changed, 39 insertions, 0 deletions
diff --git a/dev-db/spatialite-tools/Manifest b/dev-db/spatialite-tools/Manifest
new file mode 100644
index 000000000000..979dcc6266b8
--- /dev/null
+++ b/dev-db/spatialite-tools/Manifest
@@ -0,0 +1 @@
+DIST spatialite-tools-3.1.0.tar.gz 439019 SHA256 7e12a3b23ad5163257b7c8585091ead1046e8d5b56ac3130de42490693b5e160 SHA512 27f725fefcbc75894d6d14e81093deaa95b6a1cce7e15eb8fc3130ed7580f664bbb8ffd7e95f4de94b38cc8548cc82f2ed830fa8bcf3173e460a9b0666e9e0cc WHIRLPOOL 01a432a872c7ddb801edee969c3a6467cddacdb014690e669c75a1238c753f3f2d825a8e2f7370410431adc471ced0bb949291d868befa2d8d4947d08b39609e
diff --git a/dev-db/spatialite-tools/metadata.xml b/dev-db/spatialite-tools/metadata.xml
new file mode 100644
index 000000000000..3190fbf9c377
--- /dev/null
+++ b/dev-db/spatialite-tools/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>sci-geosciences</herd>
+</pkgmetadata>
diff --git a/dev-db/spatialite-tools/spatialite-tools-3.1.0.ebuild b/dev-db/spatialite-tools/spatialite-tools-3.1.0.ebuild
new file mode 100644
index 000000000000..b74ba99258d9
--- /dev/null
+++ b/dev-db/spatialite-tools/spatialite-tools-3.1.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit multilib
+
+DESCRIPTION="A complete Spatial DBMS in a nutshell built upon sqlite"
+HOMEPAGE="http://www.gaia-gis.it/spatialite"
+SRC_URI="http://www.gaia-gis.it/gaia-sins/${PN}-sources/${P}.tar.gz"
+
+LICENSE="MPL-1.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="readline"
+
+RDEPEND=">=dev-db/spatialite-3.0.1[geos,xls]
+ dev-libs/expat
+ >=sci-libs/geos-3.3
+ sci-libs/proj
+ sci-geosciences/readosm
+ readline? (
+ sys-libs/ncurses
+ sys-libs/readline
+ )
+"
+DEPEND="${RDEPEND}"
+
+src_configure() {
+ econf \
+ $(use_enable readline)
+}