summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergey Popov <pinkbyte@gentoo.org>2022-04-05 13:22:07 +0300
committerSergey Popov <pinkbyte@gentoo.org>2022-04-05 13:22:30 +0300
commit4b9315f7395f89508609befe55e5dcb7603dafa8 (patch)
treec0a36ee3efe593ed201994142a05e0eac71e4b86 /dev-db/sqlcipher
parentdev-db/sqlcipher: drop old (diff)
downloadgentoo-4b9315f7395f89508609befe55e5dcb7603dafa8.tar.gz
gentoo-4b9315f7395f89508609befe55e5dcb7603dafa8.tar.bz2
gentoo-4b9315f7395f89508609befe55e5dcb7603dafa8.zip
dev-db/sqlcipher: version bump
Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Sergey Popov <pinkbyte@gentoo.org>
Diffstat (limited to 'dev-db/sqlcipher')
-rw-r--r--dev-db/sqlcipher/Manifest1
-rw-r--r--dev-db/sqlcipher/sqlcipher-4.5.1.ebuild70
2 files changed, 71 insertions, 0 deletions
diff --git a/dev-db/sqlcipher/Manifest b/dev-db/sqlcipher/Manifest
index 727487be2c83..713b2b37b7c8 100644
--- a/dev-db/sqlcipher/Manifest
+++ b/dev-db/sqlcipher/Manifest
@@ -1 +1,2 @@
DIST sqlcipher-4.0.1.tar.gz 17006324 BLAKE2B 44e8eb4e1230c3625b4fe1b4af608cd8edc25f3c6adf7e11450c8f9ddb7970fea92ff0823f3a1e631d1b0acfbab6cf078c80e4645c535d66de57f1d73b55ff47 SHA512 0fb48326860a10e9849b2f56fae0c310deae124c7203b54d51f92d346782be795d505c29eafbdfb7206f5e7be54c0f7228fe50c45bd9d2b23cca976b263264fc
+DIST sqlcipher-4.5.1.tar.gz 18132121 BLAKE2B 233ffbd9636eae78533553325f08fa3ceb1e01ce0d809be44ca8ed64d46478d6a70dd40f81c38a1f0524986932ebe8614e52fda9dfc1c2f20134692cac7d4b16 SHA512 157ab90e1b80ae9ae85c68c6b77008fe8ab5b526cbb2604297a5ba54279286b4cac1fecd0db552e0113a75ff61a198f649611b8bde4dec5156c443e7b7fbe0c3
diff --git a/dev-db/sqlcipher/sqlcipher-4.5.1.ebuild b/dev-db/sqlcipher/sqlcipher-4.5.1.ebuild
new file mode 100644
index 000000000000..4d7ee1fefb7f
--- /dev/null
+++ b/dev-db/sqlcipher/sqlcipher-4.5.1.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools flag-o-matic multilib-minimal
+
+DESCRIPTION="Full Database Encryption for SQLite"
+HOMEPAGE="https://www.zetetic.net/sqlcipher/"
+SRC_URI="https://github.com/sqlcipher/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+IUSE="debug libedit readline static-libs tcl test"
+
+# Tcl is always needed by buildsystem
+RDEPEND="
+ libedit? ( dev-libs/libedit[${MULTILIB_USEDEP}] )
+ dev-libs/openssl:0=[${MULTILIB_USEDEP}]
+ readline? ( sys-libs/readline:0=[${MULTILIB_USEDEP}] )
+ tcl? ( dev-lang/tcl:=[${MULTILIB_USEDEP}] )
+"
+DEPEND="${RDEPEND}
+ dev-lang/tcl:*"
+
+# Libedit and readline support are mutually exclusive
+# Testsuite requires compilation with TCL, bug #582584
+REQUIRED_USE="
+ libedit? ( !readline )
+ test? ( tcl )
+"
+
+DOCS=( README.md )
+
+# Testsuite fails, bug #692310
+RESTRICT="test"
+
+src_prepare() {
+ # Column metadata added due to bug #670346
+ append-cflags -DSQLITE_HAS_CODEC -DSQLITE_ENABLE_COLUMN_METADATA
+
+ default
+ eautoreconf
+}
+
+multilib_src_configure() {
+ ECONF_SOURCE="${S}" \
+ econf \
+ --enable-fts3 \
+ --enable-fts4 \
+ --enable-fts5 \
+ --enable-geopoly \
+ --enable-json1 \
+ --enable-memsys5 \
+ --enable-rtree \
+ --enable-session \
+ --enable-tempstore \
+ $(use_enable debug) \
+ $(use_enable libedit editline) \
+ $(use_enable readline) \
+ $(use_enable static-libs static) \
+ $(use_enable tcl)
+}
+
+multilib_src_install_all() {
+ find "${D}" -name '*.la' -type f -delete || die
+ einstalldocs
+}