summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergey Popov <pinkbyte@gentoo.org>2019-02-26 12:55:30 +0300
committerSergey Popov <pinkbyte@gentoo.org>2019-02-26 12:55:30 +0300
commitfdaf8de795251ce4fad3e4c1d4f2928055f1f73e (patch)
tree8d2326fa6db4eec609e80f6bac31ba9bd88f9c8a /dev-db/sqlcipher
parentdev-db/sqlcipher: fix building with LibreSSL 2.8 (diff)
downloadgentoo-fdaf8de795251ce4fad3e4c1d4f2928055f1f73e.tar.gz
gentoo-fdaf8de795251ce4fad3e4c1d4f2928055f1f73e.tar.bz2
gentoo-fdaf8de795251ce4fad3e4c1d4f2928055f1f73e.zip
dev-db/sqlcipher: drop old version
Signed-off-by: Sergey Popov <pinkbyte@gentoo.org> Package-Manager: Portage-2.3.51, Repoman-2.3.10
Diffstat (limited to 'dev-db/sqlcipher')
-rw-r--r--dev-db/sqlcipher/Manifest1
-rw-r--r--dev-db/sqlcipher/files/sqlcipher-3.4.1-libressl.patch11
-rw-r--r--dev-db/sqlcipher/sqlcipher-3.4.1.ebuild59
3 files changed, 0 insertions, 71 deletions
diff --git a/dev-db/sqlcipher/Manifest b/dev-db/sqlcipher/Manifest
index 92c76c5bb127..300a2664c6a4 100644
--- a/dev-db/sqlcipher/Manifest
+++ b/dev-db/sqlcipher/Manifest
@@ -1,2 +1 @@
-DIST sqlcipher-3.4.1.tar.gz 13873645 BLAKE2B 8d910691fff6d31393a9e4adb549c084472b3f962f46a6ecd9f0860e5ad3c225d1e7bccd1fc4d87fb0641de0091408ef82521718c21e874a622f5304b6a7df08 SHA512 1c08ccdf438c0de23b1293192c687cb869db1ea904c47da5643c69f3a21f3f6a801fe8e87eb2e660acf0fe977b1f05bf8801b79162c609ffa3711706392c642b
DIST sqlcipher-3.4.2.tar.gz 14743960 BLAKE2B 88ee265b02bb9a42734c2ef93070c8fd8e13d546d7cc85e7fbfd6e6046ccbf2626d75e14b19cbba379c99784c7311d0100de06235b99b4908c60c99890d8d7a2 SHA512 c620bf2b175e404afd60ebe76b5476f5a447ff5fcdfa31bebc3f4bd7f1ebfcd507ee423cd582c9b3d6431d8b57320171492da2586e1a739adb4f440e7443dc03
diff --git a/dev-db/sqlcipher/files/sqlcipher-3.4.1-libressl.patch b/dev-db/sqlcipher/files/sqlcipher-3.4.1-libressl.patch
deleted file mode 100644
index f12f1284514d..000000000000
--- a/dev-db/sqlcipher/files/sqlcipher-3.4.1-libressl.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- a/src/crypto_openssl.c 2017-07-06 08:11:21.560000000 +0300
-+++ b/src/crypto_openssl.c 2017-07-06 08:11:32.180000000 +0300
-@@ -46,7 +46,7 @@
- static unsigned int openssl_init_count = 0;
- static sqlite3_mutex* openssl_rand_mutex = NULL;
-
--#if OPENSSL_VERSION_NUMBER < 0x10100000L
-+#if OPENSSL_VERSION_NUMBER < 0x10100000L || defined(LIBRESSL_VERSION_NUMBER)
- static HMAC_CTX *HMAC_CTX_new(void)
- {
- HMAC_CTX *ctx = OPENSSL_malloc(sizeof(*ctx));
diff --git a/dev-db/sqlcipher/sqlcipher-3.4.1.ebuild b/dev-db/sqlcipher/sqlcipher-3.4.1.ebuild
deleted file mode 100644
index d75de25de377..000000000000
--- a/dev-db/sqlcipher/sqlcipher-3.4.1.ebuild
+++ /dev/null
@@ -1,59 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-inherit autotools eutils flag-o-matic multilib-minimal
-
-DESCRIPTION="Full Database Encryption for SQLite"
-HOMEPAGE="https://www.zetetic.net/sqlcipher/"
-SRC_URI="https://github.com/sqlcipher/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="amd64 x86"
-
-IUSE="readline libressl static-libs tcl test"
-
-# Tcl is always needed by buildsystem
-RDEPEND="
- !libressl? ( dev-libs/openssl:0=[${MULTILIB_USEDEP}] )
- libressl? ( dev-libs/libressl:0=[${MULTILIB_USEDEP}] )
- readline? ( sys-libs/readline:0=[${MULTILIB_USEDEP}] )
- tcl? ( dev-lang/tcl:=[${MULTILIB_USEDEP}] )
-"
-DEPEND="${RDEPEND}
- dev-lang/tcl:*"
-
-# Testsuite requires compilation with TCL, bug #582584
-REQUIRED_USE="test? ( tcl )"
-
-DOCS=( README.md )
-
-src_prepare() {
- append-cflags -DSQLITE_HAS_CODEC
-
- # bug #622114
- epatch "${FILESDIR}/${P}-libressl.patch"
-
- eapply_user
- eautoreconf
-}
-
-multilib_src_configure() {
- ECONF_SOURCE=${S} \
- econf \
- --enable-fts3 \
- --enable-fts4 \
- --enable-fts5 \
- --enable-json1 \
- --enable-tempstore \
- $(use_enable readline) \
- $(use_enable static-libs static) \
- $(use_enable tcl)
-}
-
-multilib_src_install_all() {
- prune_libtool_files
- einstalldocs
-}