summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMario Haustein <mario.haustein@hrz.tu-chemnitz.de>2023-04-07 11:10:31 +0200
committerSam James <sam@gentoo.org>2023-04-09 19:31:16 +0100
commit5625fa5babc9a0eeb2993a9f427a2f8d925c12c8 (patch)
tree50c3e0715a00115759c6c23569be76c3a062ee9f /dev-db/sqlmap/sqlmap-1.7.4.ebuild
parentsys-apps/less: add 632_beta (unkeyworded) (diff)
downloadgentoo-5625fa5babc9a0eeb2993a9f427a2f8d925c12c8.tar.gz
gentoo-5625fa5babc9a0eeb2993a9f427a2f8d925c12c8.tar.bz2
gentoo-5625fa5babc9a0eeb2993a9f427a2f8d925c12c8.zip
dev-db/sqlmap: add 1.7.4
Signed-off-by: Mario Haustein <mario.haustein@hrz.tu-chemnitz.de> Closes: https://github.com/gentoo/gentoo/pull/30512 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-db/sqlmap/sqlmap-1.7.4.ebuild')
-rw-r--r--dev-db/sqlmap/sqlmap-1.7.4.ebuild60
1 files changed, 60 insertions, 0 deletions
diff --git a/dev-db/sqlmap/sqlmap-1.7.4.ebuild b/dev-db/sqlmap/sqlmap-1.7.4.ebuild
new file mode 100644
index 000000000000..550ec7d5d4b0
--- /dev/null
+++ b/dev-db/sqlmap/sqlmap-1.7.4.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{9..11} )
+PYTHON_REQ_USE="sqlite"
+
+inherit bash-completion-r1 python-single-r1 wrapper
+
+DESCRIPTION="An automatic SQL injection and database takeover tool"
+HOMEPAGE="https://sqlmap.org/"
+
+if [[ ${PV} == 9999 ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/sqlmapproject/sqlmap"
+else
+ SRC_URI="https://github.com/sqlmapproject/sqlmap/archive/refs/tags/${PV}.tar.gz -> ${P}.gh.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+# sqlmap (GPL-2+)
+# ansitrm (BSD)
+# beautifulsoup (BSD)
+# bottle (MIT)
+# chardet (LGPL-2.1+)
+# clientform (BSD)
+# colorama (BSD)
+# fcrypt (BSD-2)
+# identitywaf (MIT)
+# keepalive (LGPL-2.1+)
+# magic (MIT)
+# multipartpost (LGPL-2.1+)
+# ordereddict (MIT)
+# prettyprint (BSD-2)
+# pydes (public-domain)
+# six (MIT)
+# socks (BSD)
+# termcolor (BSD)
+# wininetpton (public-domain)
+LICENSE="BSD BSD-2 GPL-2+ LGPL-2.1+ MIT public-domain"
+SLOT="0"
+
+RDEPEND="${PYTHON_DEPS}"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+DOCS=( doc/ README.md )
+
+src_install () {
+ einstalldocs
+
+ insinto /usr/share/${PN}/
+ doins -r *
+ python_optimize "${ED}"/usr/share/${PN}
+
+ make_wrapper ${PN} \
+ "${EPYTHON} ${EPREFIX}/usr/share/${PN}/sqlmap.py"
+
+ newbashcomp "${FILESDIR}"/sqlmap.bash-completion sqlmap
+}