summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2022-05-04 07:29:51 +0000
committerPatrick Lauer <patrick@gentoo.org>2022-05-04 07:30:10 +0000
commit0a619394072bab04816592efd90a363314695717 (patch)
treedd45d17b6bfead57511df8e234f45a257de5c5e7 /dev-db/timescaledb
parentprofiles/arch/loong: mask USE=ldap (diff)
downloadgentoo-0a619394072bab04816592efd90a363314695717.tar.gz
gentoo-0a619394072bab04816592efd90a363314695717.tar.bz2
gentoo-0a619394072bab04816592efd90a363314695717.zip
dev-db/timescaledb: Bump to 2.6.1
Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Patrick Lauer <patrick@gentoo.org>
Diffstat (limited to 'dev-db/timescaledb')
-rw-r--r--dev-db/timescaledb/Manifest1
-rw-r--r--dev-db/timescaledb/timescaledb-2.6.1.ebuild67
2 files changed, 68 insertions, 0 deletions
diff --git a/dev-db/timescaledb/Manifest b/dev-db/timescaledb/Manifest
index 349090e9777b..6cde88ea9aba 100644
--- a/dev-db/timescaledb/Manifest
+++ b/dev-db/timescaledb/Manifest
@@ -1,2 +1,3 @@
DIST timescaledb-2.5.2.tar.gz 2773859 BLAKE2B 918768e21ea43de2678c2ce12c5ea9faa9794eb48d4f1003c898d5510330d25c319b30323692facff78f95ee417a4cd4ec0e78363de17c4746aeb3f42c0b5bba SHA512 28cc4b4a786c62651aa9e499bb82bbc079307ed237a8c2478d5fbd4d6aaa9bb43bf3c1df971f76921d25112761a79dc9dec31d663fa31caca38b0c822f2026b0
DIST timescaledb-2.6.0.tar.gz 2863860 BLAKE2B 14b7bbfcfe1ca874ef24a7d31f3855f78cde0be57022251e1b1eb141819e19af45a2269123583a2d97c08c778aed38d9662cd4a6ff9c44281a605b8c0faed1ec SHA512 b076a44e3b30e99986dba710079cdc1a38b59a9d65ecd9f78fa16f3b762f253d7a9236a34a4d7e7beb29c1051113ea8877973e07ed3116012c9d2175a77e2edc
+DIST timescaledb-2.6.1.tar.gz 2876847 BLAKE2B 6053e69fd6f7b86287c0ae54966a9e7528cf371d2952b6edfe80c0c616c4fcaccf04fa1f3af5f7ed787e85b7b12ac00e709664552c79561f7b4e503891cb5dd4 SHA512 edcc84c37af9670c1a7bf527f5c430405e9b04e9a35e676d04e7ac70b20184032f992d05545a180b50ac2346b076aac4fc98348c355006345394910978864a8f
diff --git a/dev-db/timescaledb/timescaledb-2.6.1.ebuild b/dev-db/timescaledb/timescaledb-2.6.1.ebuild
new file mode 100644
index 000000000000..b6b5d265256d
--- /dev/null
+++ b/dev-db/timescaledb/timescaledb-2.6.1.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+POSTGRES_COMPAT=( 12 13 14 )
+POSTGRES_USEDEP="ssl"
+
+inherit postgres-multi cmake
+
+DESCRIPTION="Open-source time-series SQL database"
+HOMEPAGE="https://www.timescale.com/"
+SRC_URI="https://github.com/timescale/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+IUSE="proprietary-extensions"
+LICENSE="POSTGRESQL Apache-2.0 proprietary-extensions? ( timescale )"
+
+KEYWORDS="~amd64"
+
+SLOT=0
+
+RESTRICT="test"
+
+DEPEND="${POSTGRES_DEP}"
+RDEPEND="${DEPEND}"
+
+CMAKE_IN_SOURCE_BUILD=yes
+CMAKE_BUILD_TYPE="RelWithDebInfo"
+BUILD_DIR=${WORKDIR}/${P}
+
+src_prepare() {
+ postgres-multi_src_prepare
+ postgres-multi_foreach cmake_src_prepare
+}
+
+timescale_configure() {
+ local CMAKE_USE_DIR=$BUILD_DIR
+ local mycmakeargs=( "-DPG_CONFIG=/usr/bin/pg_config${MULTIBUILD_VARIANT}" "-DREGRESS_CHECKS=OFF" )
+
+ # licensing is tied to features, this useflag disables the non-apache2 licensed bits
+ if ! use proprietary-extensions ; then
+ mycmakeargs+=("-DAPACHE_ONLY=ON")
+ fi
+ cmake_src_configure
+}
+
+src_configure() {
+ postgres-multi_foreach timescale_configure
+}
+
+timescale_src_compile() {
+ local CMAKE_USE_DIR=$BUILD_DIR
+ cmake_src_compile
+}
+
+src_compile() {
+ postgres-multi_foreach timescale_src_compile
+}
+
+timescale_src_install() {
+ local CMAKE_USE_DIR=$BUILD_DIR
+ cmake_src_install
+}
+
+src_install() {
+ postgres-multi_foreach timescale_src_install
+}