summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2015-10-25 15:55:42 +0100
committerJustin Lecher <jlec@gentoo.org>2015-10-25 16:03:16 +0100
commitaff9f5d5693c4c0ce39269a69c30322496a3b109 (patch)
tree268793a89bbfbea37eb4d9ad6b6ea349205f619c /dev-db/wxsqlite3/wxsqlite3-3.2.1-r1.ebuild
parentsys-libs/musl: version 1.1.12 stable on arm and ppc. (diff)
downloadgentoo-aff9f5d5693c4c0ce39269a69c30322496a3b109.tar.gz
gentoo-aff9f5d5693c4c0ce39269a69c30322496a3b109.tar.bz2
gentoo-aff9f5d5693c4c0ce39269a69c30322496a3b109.zip
dev-db/wxsqlite3: Fix typo in pc file
Package-Manager: portage-2.2.23 Signed-off-by: Justin Lecher <jlec@gentoo.org>
Diffstat (limited to 'dev-db/wxsqlite3/wxsqlite3-3.2.1-r1.ebuild')
-rw-r--r--dev-db/wxsqlite3/wxsqlite3-3.2.1-r1.ebuild60
1 files changed, 60 insertions, 0 deletions
diff --git a/dev-db/wxsqlite3/wxsqlite3-3.2.1-r1.ebuild b/dev-db/wxsqlite3/wxsqlite3-3.2.1-r1.ebuild
new file mode 100644
index 000000000000..590745629571
--- /dev/null
+++ b/dev-db/wxsqlite3/wxsqlite3-3.2.1-r1.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+WX_GTK_VER="3.0"
+
+inherit eutils multilib wxwidgets
+
+DESCRIPTION="C++ wrapper around the public domain SQLite 3.x database"
+HOMEPAGE="http://wxcode.sourceforge.net/components/wxsqlite3/"
+SRC_URI="mirror://sourceforge/wxcode/${P}.tar.gz"
+
+LICENSE="wxWinLL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug"
+
+DEPEND="
+ x11-libs/wxGTK:3.0[X,debug=]
+ dev-db/sqlite:3"
+RDEPEND="${DEPEND}"
+
+#S="${WORKDIR}/${P%.1}"
+
+src_prepare() {
+ local wxdebug
+
+ rm -rf sqlite3 || die
+ cp configure30 configure || die
+ use debug && wxdebug="d"
+ sed \
+ -e "s:@WXDEBUG@:${wxdebug}:g" \
+ -e "s:@WXVERSION@:${WX_GTK_VER}:g" \
+ -e "s:@LIBDIR@:$(get_libdir):g" \
+ -e "s:@VERSION@:${PV}:g" \
+ "${FILESDIR}"/${P}.pc.in > ${PN}.pc || die
+}
+
+src_configure() {
+ econf \
+ --enable-shared \
+ --enable-unicode \
+ --with-wx-config="${WX_CONFIG}" \
+ --with-wxshared \
+ --with-sqlite3-prefix="${PREFIX}/usr"
+}
+
+src_install() {
+ default
+
+ insinto /usr/$(get_libdir)/pkgconfig
+ doins ${PN}.pc
+
+ dodoc Readme.txt
+ dohtml -r docs/html/*
+ docinto samples
+ dodoc -r samples/*
+}