summaryrefslogtreecommitdiff
path: root/dev-db
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-08-04 23:34:20 +0100
committerSam James <sam@gentoo.org>2021-08-04 23:34:48 +0100
commit078826f79b8e1af7ddb40bc1e7d7ea7d71662608 (patch)
tree7338a7817bd7ef6018ecad294104d6de7cddfc2c /dev-db
parentprofiles: last-rite net-libs/openmq-cclient (diff)
downloadgentoo-078826f79b8e1af7ddb40bc1e7d7ea7d71662608.tar.gz
gentoo-078826f79b8e1af7ddb40bc1e7d7ea7d71662608.tar.bz2
gentoo-078826f79b8e1af7ddb40bc1e7d7ea7d71662608.zip
dev-db/opendbx: workaround build failure with GCC 11
Bug: https://bugs.gentoo.org/788304 Bug: https://bugs.gentoo.org/804993 See: 04dea1fbb62f503659bba7109f238b13da5dfd42 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-db')
-rw-r--r--dev-db/opendbx/opendbx-1.4.5-r1.ebuild5
-rw-r--r--dev-db/opendbx/opendbx-1.4.6-r2.ebuild5
2 files changed, 8 insertions, 2 deletions
diff --git a/dev-db/opendbx/opendbx-1.4.5-r1.ebuild b/dev-db/opendbx/opendbx-1.4.5-r1.ebuild
index 222716f22f73..d62eda3c5e8c 100644
--- a/dev-db/opendbx/opendbx-1.4.5-r1.ebuild
+++ b/dev-db/opendbx/opendbx-1.4.5-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI="6"
@@ -60,6 +60,9 @@ src_configure() {
append-ldflags -L"${ORACLE_HOME}"
fi
+ # bug #788304
+ append-cxxflags -std=c++14
+
econf --with-backends="${backends}"
}
diff --git a/dev-db/opendbx/opendbx-1.4.6-r2.ebuild b/dev-db/opendbx/opendbx-1.4.6-r2.ebuild
index 5c3009011be6..7ba0179bedaa 100644
--- a/dev-db/opendbx/opendbx-1.4.6-r2.ebuild
+++ b/dev-db/opendbx/opendbx-1.4.6-r2.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI="6"
@@ -60,6 +60,9 @@ src_configure() {
append-ldflags -L"${ORACLE_HOME}"
fi
+ # bug #788304
+ append-cxxflags -std=c++14
+
econf --with-backends="${backends}"
}