summaryrefslogtreecommitdiff
path: root/dev-db
diff options
context:
space:
mode:
authorEli Schwartz <eschwartz93@gmail.com>2024-03-10 19:41:32 -0400
committerSam James <sam@gentoo.org>2024-03-11 14:22:46 +0000
commit1a1fa73a130e911354c9578f4e5e905ef00281a1 (patch)
tree21ddfc5d259e4422deb836c3a7bd35ef7ab8876a /dev-db
parentdev-db/slony1: fix typo in ebuild variables (diff)
downloadgentoo-1a1fa73a130e911354c9578f4e5e905ef00281a1.tar.gz
gentoo-1a1fa73a130e911354c9578f4e5e905ef00281a1.tar.bz2
gentoo-1a1fa73a130e911354c9578f4e5e905ef00281a1.zip
dev-db/pgpool2: mark as LTO-unsafe
Closes: https://bugs.gentoo.org/855248 Signed-off-by: Eli Schwartz <eschwartz93@gmail.com> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-db')
-rw-r--r--dev-db/pgpool2/pgpool2-4.3.8.ebuild10
-rw-r--r--dev-db/pgpool2/pgpool2-4.4.4.ebuild10
-rw-r--r--dev-db/pgpool2/pgpool2-4.4.5.ebuild10
-rw-r--r--dev-db/pgpool2/pgpool2-9999.ebuild10
4 files changed, 32 insertions, 8 deletions
diff --git a/dev-db/pgpool2/pgpool2-4.3.8.ebuild b/dev-db/pgpool2/pgpool2-4.3.8.ebuild
index d46c7c75826a..b0b928ab667f 100644
--- a/dev-db/pgpool2/pgpool2-4.3.8.ebuild
+++ b/dev-db/pgpool2/pgpool2-4.3.8.ebuild
@@ -1,11 +1,11 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
POSTGRES_COMPAT=( 9.6 {10..15} )
-inherit autotools postgres-multi
+inherit autotools flag-o-matic postgres-multi
MY_P="${PN/2/-II}-${PV}"
@@ -48,6 +48,12 @@ src_prepare() {
}
src_configure() {
+ # -Werror=lto-type-mismatch
+ # https://bugs.gentoo.org/855248
+ # https://github.com/pgpool/pgpool2/issues/42
+ #
+ filter-lto
+
postgres-multi_foreach econf \
--disable-rpath \
--sysconfdir="${EPREFIX}/etc/${PN}" \
diff --git a/dev-db/pgpool2/pgpool2-4.4.4.ebuild b/dev-db/pgpool2/pgpool2-4.4.4.ebuild
index 7c58c30c4de0..f296ca0fb0a6 100644
--- a/dev-db/pgpool2/pgpool2-4.4.4.ebuild
+++ b/dev-db/pgpool2/pgpool2-4.4.4.ebuild
@@ -1,11 +1,11 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
POSTGRES_COMPAT=( {10..16} )
-inherit autotools postgres-multi
+inherit autotools flag-o-matic postgres-multi
MY_P="${PN/2/-II}-${PV}"
@@ -48,6 +48,12 @@ src_prepare() {
}
src_configure() {
+ # -Werror=lto-type-mismatch
+ # https://bugs.gentoo.org/855248
+ # https://github.com/pgpool/pgpool2/issues/42
+ #
+ filter-lto
+
postgres-multi_foreach econf \
--disable-rpath \
--sysconfdir="${EPREFIX}/etc/${PN}" \
diff --git a/dev-db/pgpool2/pgpool2-4.4.5.ebuild b/dev-db/pgpool2/pgpool2-4.4.5.ebuild
index 7c58c30c4de0..f296ca0fb0a6 100644
--- a/dev-db/pgpool2/pgpool2-4.4.5.ebuild
+++ b/dev-db/pgpool2/pgpool2-4.4.5.ebuild
@@ -1,11 +1,11 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
POSTGRES_COMPAT=( {10..16} )
-inherit autotools postgres-multi
+inherit autotools flag-o-matic postgres-multi
MY_P="${PN/2/-II}-${PV}"
@@ -48,6 +48,12 @@ src_prepare() {
}
src_configure() {
+ # -Werror=lto-type-mismatch
+ # https://bugs.gentoo.org/855248
+ # https://github.com/pgpool/pgpool2/issues/42
+ #
+ filter-lto
+
postgres-multi_foreach econf \
--disable-rpath \
--sysconfdir="${EPREFIX}/etc/${PN}" \
diff --git a/dev-db/pgpool2/pgpool2-9999.ebuild b/dev-db/pgpool2/pgpool2-9999.ebuild
index 0de82e93599a..aec380cbbd43 100644
--- a/dev-db/pgpool2/pgpool2-9999.ebuild
+++ b/dev-db/pgpool2/pgpool2-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -7,7 +7,7 @@ EGIT_REPO_URI="https://git.postgresql.org/git/pgpool2.git"
POSTGRES_COMPAT=( 9.6 {10..15} )
-inherit autotools git-r3 postgres-multi
+inherit autotools flag-o-matic git-r3 postgres-multi
DESCRIPTION="Connection pool server for PostgreSQL"
HOMEPAGE="https://www.pgpool.net/"
@@ -53,6 +53,12 @@ src_prepare() {
}
src_configure() {
+ # -Werror=lto-type-mismatch
+ # https://bugs.gentoo.org/855248
+ # https://github.com/pgpool/pgpool2/issues/42
+ #
+ filter-lto
+
postgres-multi_foreach econf \
--disable-rpath \
--sysconfdir="${EPREFIX}/etc/${PN}" \