summaryrefslogtreecommitdiff
path: root/dev-db
diff options
context:
space:
mode:
authorWilliam Hubbs <williamh@gentoo.org>2023-06-12 13:56:24 -0500
committerWilliam Hubbs <williamh@gentoo.org>2023-06-12 14:00:52 -0500
commit220a7926c6592d853c854e1e5709b7971d90a97e (patch)
tree4f0aeaa97105ab798a5cb7b129d4203328f2b854 /dev-db
parentdev-ruby/stringex: fix tests failing without activerecord (diff)
downloadgentoo-220a7926c6592d853c854e1e5709b7971d90a97e.tar.gz
gentoo-220a7926c6592d853c854e1e5709b7971d90a97e.tar.bz2
gentoo-220a7926c6592d853c854e1e5709b7971d90a97e.zip
dev-db/influx-cli: new package, add 2.7.3
This is the command line interface for influxdb-2.x. Bug: https://bugs.gentoo.org/907954 Signed-off-by: William Hubbs <williamh@gentoo.org>
Diffstat (limited to 'dev-db')
-rw-r--r--dev-db/influx-cli/Manifest2
-rw-r--r--dev-db/influx-cli/influx-cli-2.7.3.ebuild28
-rw-r--r--dev-db/influx-cli/metadata.xml10
3 files changed, 40 insertions, 0 deletions
diff --git a/dev-db/influx-cli/Manifest b/dev-db/influx-cli/Manifest
new file mode 100644
index 000000000000..e9e3b8e391b1
--- /dev/null
+++ b/dev-db/influx-cli/Manifest
@@ -0,0 +1,2 @@
+DIST influx-cli-2.7.3-deps.tar.xz 52915924 BLAKE2B 38ca630eb4445dfdd66ed47362cbad220e727c8ddab64eb262e4859577155038650e5d14fcdc6fd8f44c541db07d1b79503c7d9ec5fdd52595198293edf3850e SHA512 c2fa4b7d5d744a85de11f97e3172c9d51b2c1c7b2e31d35fbd15a6ba2b6c12cd4d265216ced0bd27d150d5d3ee619e7d972b67c63cfdbdfdfb69d84d966d881c
+DIST influx-cli-2.7.3.tar.gz 442354 BLAKE2B 3c69e6a2510a4b82830134b930ebc62446848f19cad302f35796853cebd53002963a2d9015512dbf60a4a24e86f237af1ce62c698231150a66331cd8718f2c69 SHA512 d2ffd56c7a1dee24e48afdf487e79b3f125f897fe1c642cccf64a9544134dd6692ebd40415624418597341c16c1afbd444b949c9e3d1bb825ebed5e3f8392dfa
diff --git a/dev-db/influx-cli/influx-cli-2.7.3.ebuild b/dev-db/influx-cli/influx-cli-2.7.3.ebuild
new file mode 100644
index 000000000000..deefe0de73ef
--- /dev/null
+++ b/dev-db/influx-cli/influx-cli-2.7.3.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+inherit go-module
+MY_PV="${PV/_rc/-rc.}"
+
+DESCRIPTION="The command line for influxdb"
+HOMEPAGE="https://github.com/influxdata/influx-cli"
+
+SRC_URI="https://github.com/influxdata/influx-cli/archive/v${MY_PV}.tar.gz -> ${P}.tar.gz"
+SRC_URI+=" https://dev.gentoo.org/~williamh/dist/${P}-deps.tar.xz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RESTRICT+=" test"
+
+
+src_compile() {
+ unset LDFLAGS
+ emake
+}
+
+src_install() {
+ dobin bin/$(go env GOOS)/$(go env GOARCH)/influx
+}
diff --git a/dev-db/influx-cli/metadata.xml b/dev-db/influx-cli/metadata.xml
new file mode 100644
index 000000000000..d529e99ced4c
--- /dev/null
+++ b/dev-db/influx-cli/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>williamh@gentoo.org</email>
+ <name>William Hubbs</name>
+ </maintainer>
+ <upstream>
+ </upstream>
+</pkgmetadata>