summaryrefslogtreecommitdiff
path: root/dev-db
diff options
context:
space:
mode:
authorMichael Vetter <jubalh@iodoru.org>2023-08-08 11:56:57 +0000
committerSam James <sam@gentoo.org>2023-08-09 05:48:41 +0100
commit27d68a4cc58c56f46ec3181c7a36c54fd267ca45 (patch)
tree1b87bc1fb5cf2866fccb4121777a39720af3f4d9 /dev-db
parentsys-fs/fuse: add 3.16.1 (diff)
downloadgentoo-27d68a4cc58c56f46ec3181c7a36c54fd267ca45.tar.gz
gentoo-27d68a4cc58c56f46ec3181c7a36c54fd267ca45.tar.bz2
gentoo-27d68a4cc58c56f46ec3181c7a36c54fd267ca45.zip
dev-db/unixODBC: Add 2.3.12
Signed-off-by: Michael Vetter <jubalh@iodoru.org> Closes: https://github.com/gentoo/gentoo/pull/32219 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-db')
-rw-r--r--dev-db/unixODBC/Manifest1
-rw-r--r--dev-db/unixODBC/unixODBC-2.3.12.ebuild74
2 files changed, 75 insertions, 0 deletions
diff --git a/dev-db/unixODBC/Manifest b/dev-db/unixODBC/Manifest
index 3162b4581286..1e34e2941e3d 100644
--- a/dev-db/unixODBC/Manifest
+++ b/dev-db/unixODBC/Manifest
@@ -1 +1,2 @@
DIST unixODBC-2.3.11.tar.gz 1752585 BLAKE2B fa1502d7b83c8c10ee9d54b23281096156a3e3ec893b81acf125cd95c1de0f4ae7657ab3b4c5214a5c6a0fc9209e53cd9acdf6f99e65840e0a05366182af5600 SHA512 dddc32f90a7962e6988e1130a8093c6fb8b9ff532cad270d572250324aecbc739f45f9d8021d217313910bab25b08e69009b4f87456575535e93be1f46f5f13d
+DIST unixODBC-2.3.12.tar.gz 1753915 BLAKE2B 9da9b0fb5ff962db8ec1483b700aca5d4adf88f3349b22010bd0b4b4ec1fe2e7a51d761527e3b9e49b08286a00e55aadc38c320a6db512ba52f491aecad7fd83 SHA512 ca9d8db943195679a44db1fc09391dc6662ab1721112c93d448f04011e98502462ffe14b8364eb03707d851db456eced20eb61a22370392ca88d917038d45b56
diff --git a/dev-db/unixODBC/unixODBC-2.3.12.ebuild b/dev-db/unixODBC/unixODBC-2.3.12.ebuild
new file mode 100644
index 000000000000..5adc1d911a52
--- /dev/null
+++ b/dev-db/unixODBC/unixODBC-2.3.12.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools multilib-minimal
+
+DESCRIPTION="Complete ODBC driver manager"
+HOMEPAGE="https://www.unixodbc.org/"
+SRC_URI="https://www.unixodbc.org/unixODBC-${PV}.tar.gz"
+
+LICENSE="GPL-2 LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x64-solaris"
+IUSE="+minimal odbcmanual static-libs unicode"
+
+RDEPEND="
+ dev-libs/libltdl:0[${MULTILIB_USEDEP}]
+ >=sys-libs/readline-6.2_p5-r1:=[${MULTILIB_USEDEP}]
+ >=sys-libs/ncurses-5.9-r3:=[${MULTILIB_USEDEP}]
+ >=virtual/libiconv-0-r1[${MULTILIB_USEDEP}]
+"
+DEPEND="
+ ${RDEPEND}
+ sys-devel/bison
+ sys-devel/flex
+"
+
+MULTILIB_CHOST_TOOLS=( /usr/bin/odbc_config )
+MULTILIB_WRAPPED_HEADERS=( /usr/include/unixODBC/unixodbc_conf.h /usr/include/unixodbc.h )
+
+src_prepare() {
+ default
+
+ # Only needed for config.h install patch
+ eautoreconf
+}
+
+multilib_src_configure() {
+ # Needs flex, bison
+ export LEX=flex
+ unset YACC
+
+ # --enable-driver-conf is --enable-driverc as per configure.in
+ local myeconfargs=(
+ --cache-file="${BUILD_DIR}"/config.cache
+ --sysconfdir="${EPREFIX}"/etc/${PN}
+ --disable-editline
+ --disable-static
+ --enable-iconv
+ --enable-shared
+ $(use_enable static-libs static)
+ $(use_enable !minimal drivers)
+ $(use_enable !minimal driverc)
+ $(use_with unicode iconv-char-enc UTF8)
+ $(use_with unicode iconv-ucode-enc UTF16LE)
+ )
+ ECONF_SOURCE="${S}" econf "${myeconfargs[@]}"
+}
+
+multilib_src_install_all() {
+ einstalldocs
+
+ if use odbcmanual ; then
+ # We could simply run "make install-html" if we'd not had
+ # out-of-source builds here.
+ docinto html
+ dodoc -r doc/.
+ find "${ED}/usr/share/doc/${PF}/html" -name "Makefile*" -delete || die
+ fi
+
+ use prefix && dodoc README*
+ find "${ED}" -type f -name '*.la' -delete || die
+}