summaryrefslogtreecommitdiff
path: root/dev-db
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2021-09-05 13:28:09 +0000
committerPatrick Lauer <patrick@gentoo.org>2021-09-05 13:28:17 +0000
commit78d64ffae470a2efd64402fb83c5f358813518e8 (patch)
tree6e1a7d118b6c36a9ee5af6ebcc8a690368fadab2 /dev-db
parentnet-news/newsboat: set CC when calling emake (diff)
downloadgentoo-78d64ffae470a2efd64402fb83c5f358813518e8.tar.gz
gentoo-78d64ffae470a2efd64402fb83c5f358813518e8.tar.bz2
gentoo-78d64ffae470a2efd64402fb83c5f358813518e8.zip
dev-db/postgis: Bump
Package-Manager: Portage-3.0.22, Repoman-3.0.3 Signed-off-by: Patrick Lauer <patrick@gentoo.org>
Diffstat (limited to 'dev-db')
-rw-r--r--dev-db/postgis/Manifest2
-rw-r--r--dev-db/postgis/postgis-3.0.4.ebuild144
-rw-r--r--dev-db/postgis/postgis-3.1.4.ebuild143
3 files changed, 289 insertions, 0 deletions
diff --git a/dev-db/postgis/Manifest b/dev-db/postgis/Manifest
index ed8966feab82..916ff85d03e2 100644
--- a/dev-db/postgis/Manifest
+++ b/dev-db/postgis/Manifest
@@ -1,5 +1,7 @@
DIST postgis-3.0.3.tar.gz 16871696 BLAKE2B 891f814271de9193cd17013d6d971a752d2e984cb0f68b05510450adef97fc96827e3d1a1c7e4fa4cf79a5d15eb3f74b32e6e9a8db1947f7bad7c2b23656bc8f SHA512 478f0971e18c2a1bd651c9bf7b995236aad32fda037762505cf8ac9e67a4e40917436248c1e62827a1a6da96c15c4ae8d0b606d548fa080cdff453642b897115
+DIST postgis-3.0.4.tar.gz 16871782 BLAKE2B 188e9b843526299bb112cb5f9437a9471a1b2cbf51cf85f68094172cfe98101f66cd2a72b2667161a0d40c4719ceed14299c04494e8165716b5dfd4aa84cd5c7 SHA512 0b01414433137af2708f5dee3cc054823dd788d311273f9055ab2d7bce5901e18206021381f3705408d6e263f7afc9cfcf6eaa5298b82690efaeac66486f8c0e
DIST postgis-3.1.0.tar.gz 17262134 BLAKE2B dbc6edde826328b84ca7d6cc9329d648c7874d51528252759499131d7ad5dbc1a7a4ef881054f2fa1fc255810157270dc1c0ae0e2ea24ec702f06b9fd5f6dfed SHA512 c5b063ff7cbe855ab6ce4104d170b27eea04ae632fd6fcb8de38b14699296a8e0c9ce06bfb48ab14cba51b7a1b3f7e0a3996d9377a954dfc39fd68fe3f839e8f
DIST postgis-3.1.1.tar.gz 17261826 BLAKE2B a14bdce3773f8cc50c72880d9b8158c32b546332884645e91cba539ab9238c3cbcbc9ee60292932c86de67a0134bdab6a2b4e6b1f3c55881afbb36a08d8f138a SHA512 b975d26c1ad01fa6b90b5b3b51fd2b4b33204a380af0f76b98d1bfd6bd95f527d4ac3548f1b822e114be17bb3a133bc88c3d33a17d4effdfa1f90ec0c683e5e5
DIST postgis-3.1.2.tar.gz 17266501 BLAKE2B acc65e3ab70667c57a71bcb9c7bbfc382f8a6038ceb0e91aac07e36fb6b4cb6365aa968b30af13eda8292410cc1b567d871970e6cb7dfaadb454147224f9b834 SHA512 df9d2fa118987e29acd635912a708e643770ad3df82c098f8129f11ab07a9eafde969302d2d2e59a68fea6fc7312fe768a231dd4cb5de7002c418725da75848a
DIST postgis-3.1.3.tar.gz 17273487 BLAKE2B 603be66476037fca5e75b00079a26b4beaa50f0af0626f89660f17da398576d929574cb363c4177877d9c8db5459f7eac964b85796cd93b0d0c6ff2462d7ad3f SHA512 525c982de6b5888d1f4a4f6d2cca5dfa945d8899d8038b1d62ce222e0149c4ab26a2a3602bb8c85e89ce22b3d5b20d278fc4f841144f4b0d19e6de4f48d819ad
+DIST postgis-3.1.4.tar.gz 17269391 BLAKE2B 6070fb72c777f8baf9c520ec51cf436837fffb54f21af5b4cf800940240f2fb9fcee162b2d3817cbfd4e60c2cef37eb4cf902d9e9f065e537d8d9b8ec965bef3 SHA512 afd84b45b146bdae310580fc9f8a878dd658f9e74f99c41f5d143f32974d5f5017ab4190855dcaea915a31ac2a78d34bf5561f206965264de3252f2c2ac57683
diff --git a/dev-db/postgis/postgis-3.0.4.ebuild b/dev-db/postgis/postgis-3.0.4.ebuild
new file mode 100644
index 000000000000..ec0647eb354f
--- /dev/null
+++ b/dev-db/postgis/postgis-3.0.4.ebuild
@@ -0,0 +1,144 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+POSTGRES_COMPAT=( 9.6 {10..13} )
+POSTGRES_USEDEP="server"
+inherit autotools postgres-multi
+
+MY_P="${PN}-$(ver_rs 3 '')"
+
+if [[ ${PV} = *9999* ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://git.osgeo.org/gitea/postgis/postgis.git"
+else
+ PGIS="$(ver_cut 1-2)"
+ SRC_URI="https://download.osgeo.org/postgis/source/${MY_P}.tar.gz"
+ KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+fi
+
+DESCRIPTION="Geographic Objects for PostgreSQL"
+HOMEPAGE="https://postgis.net"
+
+S="${WORKDIR}/${MY_P}"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="address-standardizer doc gtk static-libs test topology"
+
+REQUIRED_USE="test? ( doc ) ${POSTGRES_REQ_USE}"
+
+# Needs a running psql instance, doesn't work out of the box
+RESTRICT="test"
+
+RDEPEND="${POSTGRES_DEP}
+ dev-libs/json-c:=
+ dev-libs/libxml2:2
+ dev-libs/protobuf-c:=
+ >=sci-libs/geos-3.6.0
+ >=sci-libs/proj-4.9.0:=
+ >=sci-libs/gdal-1.10.0:=
+ address-standardizer? ( dev-libs/libpcre )
+ gtk? ( x11-libs/gtk+:2 )
+"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ doc? (
+ app-text/docbook-xsl-stylesheets
+ app-text/docbook-xml-dtd:4.5
+ dev-libs/libxslt
+ virtual/imagemagick-tools[png]
+ )
+ test? ( dev-util/cunit )
+"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-2.2.0-arflags.patch"
+ "${FILESDIR}/${PN}-3.0.3-avoid-calling-ar-directly.patch"
+ "${FILESDIR}/${PN}-3.0.3-detect-only-stdc.patch"
+ "${FILESDIR}/${PN}-3.0.3-try-other-cpp-names.patch"
+)
+
+src_prepare() {
+ default
+
+ if [[ ${PV} = *9999* ]] ; then
+ source "${S}"/Version.config
+ PGIS="${POSTGIS_MAJOR_VERSION}.${POSTGIS_MINOR_VERSION}"
+ fi
+
+ # These modules are built using the same *FLAGS that were used to build
+ # dev-db/postgresql. The right thing to do is to ignore the current
+ # *FLAGS settings.
+ QA_FLAGS_IGNORED="usr/lib(64)?/(rt)?postgis-${PGIS}\.so"
+
+ # bug #775968
+ touch build-aux/ar-lib || die
+ # bug #775968
+ config_rpath_update build-aux/config.rpath
+
+ local AT_M4DIR="macros"
+ eautoreconf
+
+ postgres-multi_src_prepare
+}
+
+src_configure() {
+ local myeconfargs=(
+ $(use_with address-standardizer)
+ $(use_with gtk gui)
+ $(use_with topology)
+ )
+ postgres-multi_foreach econf "${myeconfargs[@]}"
+}
+
+src_compile() {
+ postgres-multi_foreach emake
+ postgres-multi_foreach emake -C topology
+
+ if use doc ; then
+ postgres-multi_foreach emake comments
+ postgres-multi_foreach emake cheatsheets
+ postgres-multi_forbest emake -C doc html
+ fi
+}
+
+src_install() {
+ postgres-multi_foreach emake DESTDIR="${D}" install
+ postgres-multi_foreach emake -C topology DESTDIR="${D}" install
+ postgres-multi_forbest dobin ./utils/postgis_restore.pl
+
+ dodoc CREDITS TODO loader/README.* doc/*txt
+
+ docinto topology
+ dodoc topology/{TODO,README}
+
+ if use doc ; then
+ postgres-multi_foreach emake DESTDIR="${D}" comments-install
+
+ docinto html
+ postgres-multi_forbest dodoc doc/html/{postgis.html,style.css}
+
+ docinto html/images
+ postgres-multi_forbest dodoc doc/html/images/*
+ fi
+
+ use static-libs || find "${ED}" -name '*.a' -delete
+}
+
+pkg_postinst() {
+ ebegin "Refreshing PostgreSQL symlinks"
+ postgresql-config update
+ eend $?
+
+ local base_uri="https://postgis.net/docs/manual-"
+ if [[ ${PV} = *9999* ]] ; then
+ base_uri+="dev"
+ else
+ base_uri+="${PGIS}"
+ fi
+
+ elog "To finish installing PostGIS, follow the directions detailed at:"
+ elog "${base_uri}/postgis_installation.html#create_new_db_extensions"
+}
diff --git a/dev-db/postgis/postgis-3.1.4.ebuild b/dev-db/postgis/postgis-3.1.4.ebuild
new file mode 100644
index 000000000000..a81f3e9072c3
--- /dev/null
+++ b/dev-db/postgis/postgis-3.1.4.ebuild
@@ -0,0 +1,143 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+POSTGRES_COMPAT=( 9.6 {10..13} )
+POSTGRES_USEDEP="server"
+inherit autotools postgres-multi toolchain-funcs
+
+MY_P="${PN}-$(ver_rs 3 '')"
+
+if [[ ${PV} = *9999* ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://git.osgeo.org/gitea/postgis/postgis.git"
+else
+ PGIS="$(ver_cut 1-2)"
+ SRC_URI="https://download.osgeo.org/postgis/source/${MY_P}.tar.gz"
+ KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+fi
+
+DESCRIPTION="Geographic Objects for PostgreSQL"
+HOMEPAGE="https://postgis.net"
+
+S="${WORKDIR}/${MY_P}"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="address-standardizer doc gtk static-libs topology"
+
+REQUIRED_USE="${POSTGRES_REQ_USE}"
+
+# Needs a running psql instance, doesn't work out of the box
+RESTRICT="test"
+
+RDEPEND="${POSTGRES_DEP}
+ dev-libs/json-c:=
+ dev-libs/libxml2:2
+ dev-libs/protobuf-c:=
+ >=sci-libs/geos-3.9.0
+ >=sci-libs/proj-4.9.0:=
+ >=sci-libs/gdal-1.10.0:=
+ address-standardizer? ( dev-libs/libpcre )
+ gtk? ( x11-libs/gtk+:2 )
+"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ doc? (
+ app-text/docbook-xsl-stylesheets
+ app-text/docbook-xml-dtd:4.5
+ dev-libs/libxslt
+ virtual/imagemagick-tools[png]
+ )
+"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-2.2.0-arflags.patch"
+ "${FILESDIR}/${PN}-3.0.3-avoid-calling-ar-directly.patch"
+ "${FILESDIR}/${PN}-3.0.3-detect-only-stdc.patch"
+ "${FILESDIR}/${PN}-3.0.3-try-other-cpp-names.patch"
+)
+
+src_prepare() {
+ default
+
+ if [[ ${PV} = *9999* ]] ; then
+ source "${S}"/Version.config
+ PGIS="${POSTGIS_MAJOR_VERSION}.${POSTGIS_MINOR_VERSION}"
+ fi
+
+ # These modules are built using the same *FLAGS that were used to build
+ # dev-db/postgresql. The right thing to do is to ignore the current
+ # *FLAGS settings.
+ QA_FLAGS_IGNORED="usr/lib(64)?/(rt)?postgis-${PGIS}\.so"
+
+ # bug #775968
+ touch build-aux/ar-lib || die
+
+ local AT_M4DIR="macros"
+ eautoreconf
+
+ postgres-multi_src_prepare
+}
+
+src_configure() {
+ export CPP=$(tc-getCPP)
+
+ local myeconfargs=(
+ $(use_with address-standardizer)
+ $(use_with gtk gui)
+ $(use_with topology)
+ )
+ postgres-multi_foreach econf "${myeconfargs[@]}"
+}
+
+src_compile() {
+ postgres-multi_foreach emake
+ postgres-multi_foreach emake -C topology
+
+ if use doc ; then
+ postgres-multi_foreach emake comments
+ postgres-multi_foreach emake cheatsheets
+ postgres-multi_forbest emake -C doc html
+ fi
+}
+
+src_install() {
+ postgres-multi_foreach emake DESTDIR="${D}" install
+ postgres-multi_foreach emake -C topology DESTDIR="${D}" install
+ postgres-multi_forbest dobin ./utils/postgis_restore.pl
+
+ dodoc CREDITS TODO loader/README.* doc/*txt
+
+ docinto topology
+ dodoc topology/{TODO,README}
+
+ if use doc ; then
+ postgres-multi_foreach emake DESTDIR="${D}" comments-install
+
+ docinto html
+ postgres-multi_forbest dodoc doc/html/{postgis.html,style.css}
+
+ docinto html/images
+ postgres-multi_forbest dodoc doc/html/images/*
+ fi
+
+ use static-libs || find "${ED}" -name '*.a' -delete
+}
+
+pkg_postinst() {
+ ebegin "Refreshing PostgreSQL symlinks"
+ postgresql-config update
+ eend $?
+
+ local base_uri="https://postgis.net/docs/manual-"
+ if [[ ${PV} = *9999* ]] ; then
+ base_uri+="dev"
+ else
+ base_uri+="${PGIS}"
+ fi
+
+ elog "To finish installing PostGIS, follow the directions detailed at:"
+ elog "${base_uri}/postgis_installation.html#create_new_db_extensions"
+}