summaryrefslogtreecommitdiff
path: root/dev-db
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2019-10-20 17:17:04 +0000
committerPatrick Lauer <patrick@gentoo.org>2019-10-20 17:17:16 +0000
commit90fae2db1a43c1fc0530b97e82f927bae68645e5 (patch)
tree1eab799265a45c613ff69c10eb1cf55abbcc26ba /dev-db
parentsys-cluster/slurm: respect CFLAGS (diff)
downloadgentoo-90fae2db1a43c1fc0530b97e82f927bae68645e5.tar.gz
gentoo-90fae2db1a43c1fc0530b97e82f927bae68645e5.tar.bz2
gentoo-90fae2db1a43c1fc0530b97e82f927bae68645e5.zip
dev-db/pgbouncer: Bump
Package-Manager: Portage-2.3.77, Repoman-2.3.17 Signed-off-by: Patrick Lauer <patrick@gentoo.org>
Diffstat (limited to 'dev-db')
-rw-r--r--dev-db/pgbouncer/Manifest1
-rw-r--r--dev-db/pgbouncer/files/pgbouncer-1.11-dirs.patch18
-rw-r--r--dev-db/pgbouncer/pgbouncer-1.11.0.ebuild86
3 files changed, 105 insertions, 0 deletions
diff --git a/dev-db/pgbouncer/Manifest b/dev-db/pgbouncer/Manifest
index 8336f7b13204..3b82c47d9395 100644
--- a/dev-db/pgbouncer/Manifest
+++ b/dev-db/pgbouncer/Manifest
@@ -1,2 +1,3 @@
DIST pgbouncer-1.10.0.tar.gz 480571 BLAKE2B a0c1dadc48f38cfe0ba2641791b4734da84cfe6674198bb2a8014bc92543850e909d7b4649b99e78d58febaa0f89f62b6694f6333b1111cbd62ff2f22741984d SHA512 8ec9f102b57ca5f92fb689588ec090056ac29f21825400ec67bca413fe076ad50e0b491e65c4cfebc488cc245eb3c88c36db2ee0ba1cb737f35404be0983dd1d
+DIST pgbouncer-1.11.0.tar.gz 571414 BLAKE2B 044d7cdf57b352b5b87547a8b96af1eca87e46b1f761bbd31d28a0d5158b52e438325db051ab51849f4e683f6211d0156a5081cc99a1109846085c84be7f72a6 SHA512 2373157f952a39dbb5d9afad7db2eba7459c28bcc302487c3bf15b64dca98940f65c9f7a1d142237f7053b6d2b290eaec15f930a341025f1665b501a26919115
DIST pgbouncer-1.9.0.tar.gz 469300 BLAKE2B 466f171a49ec9ce9be9a9d3208780cfbff956da7c74ec4332c7104ea537cb47a5cfdc0d80bbd96d233769b6f430f1ad99b623caefa2dc93af7ba336dd0f49514 SHA512 b127f4cb60ca5cdf339da76727918f0a3797a3e0a89f8ed6fdcaa80f3391d2c5bb51e19731915775210c0e5070dd611ee2e410c9a947624e45b5cf11aecdacf9
diff --git a/dev-db/pgbouncer/files/pgbouncer-1.11-dirs.patch b/dev-db/pgbouncer/files/pgbouncer-1.11-dirs.patch
new file mode 100644
index 000000000000..3dd405372525
--- /dev/null
+++ b/dev-db/pgbouncer/files/pgbouncer-1.11-dirs.patch
@@ -0,0 +1,18 @@
+diff --git a/etc/pgbouncer.ini b/etc/pgbouncer.ini
+index fed4a9f..5f2ed8e 100644
+--- a/etc/pgbouncer.ini
++++ b/etc/pgbouncer.ini
+@@ -55,9 +55,9 @@ listen_port = 6432
+
+ ;; Unix socket is also used for -R.
+ ;; On Debian it should be /var/run/postgresql
+-;unix_socket_dir = /tmp
+-;unix_socket_mode = 0777
+-;unix_socket_group =
++unix_socket_dir = /run/postgresql
++unix_socket_mode = 0777
++unix_socket_group = postgres
+
+ ;;;
+ ;;; TLS settings for accepting clients
+
diff --git a/dev-db/pgbouncer/pgbouncer-1.11.0.ebuild b/dev-db/pgbouncer/pgbouncer-1.11.0.ebuild
new file mode 100644
index 000000000000..1492a74c6e8f
--- /dev/null
+++ b/dev-db/pgbouncer/pgbouncer-1.11.0.ebuild
@@ -0,0 +1,86 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit user
+
+DESCRIPTION="Lightweight connection pooler for PostgreSQL"
+HOMEPAGE="https://pgbouncer.github.io"
+SRC_URI="https://pgbouncer.github.io/downloads/files/${PV}/${P}.tar.gz"
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+c-ares debug doc pam ssl -udns"
+
+# At-most-one-of, one can be enabled but not both
+REQUIRED_USE="?? ( c-ares udns )"
+
+RDEPEND="
+ >=dev-libs/libevent-2.0
+ >=sys-libs/glibc-2.10
+ c-ares? ( >=net-dns/c-ares-1.10 )
+ ssl? ( >=dev-libs/openssl-1.0.1:=[-bindist] )
+ udns? ( >=net-libs/udns-0.1 )
+"
+
+DEPEND="${RDEPEND}"
+
+pkg_setup() {
+ enewgroup postgres 70
+ enewuser postgres 70 /bin/bash /var/lib/postgresql postgres
+
+ enewuser pgbouncer -1 -1 -1 postgres
+}
+
+src_prepare() {
+ eapply "${FILESDIR}/pgbouncer-1.11-dirs.patch"
+
+ default
+}
+
+src_configure() {
+ # --enable-debug is only used to disable stripping
+ econf \
+ --docdir=/usr/share/doc/${PF} \
+ --enable-debug \
+ $(use_with c-ares cares) \
+ $(use_enable debug cassert) \
+ $(use_with pam) \
+ $(use_with ssl openssl) \
+ $(use_with udns)
+}
+
+src_test() {
+ cd "${S}/test"
+ emake
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+
+ dodoc AUTHORS
+ use doc && dodoc doc/*.rst
+
+ newconfd "${FILESDIR}/${PN}.confd-r1" "${PN}"
+ newinitd "${FILESDIR}/${PN}.initd-r2" "${PN}"
+
+ insinto /etc
+ doins etc/pgbouncer.ini
+
+ insinto /etc/logrotate.d
+ newins "${FILESDIR}/logrotate" pgbouncer
+}
+
+pkg_postinst() {
+ if [[ -z ${REPLACING_VERSIONS} ]] ; then
+ einfo "Please read the config.txt for Configuration Directives"
+ einfo
+ einfo "For Administration Commands, see:"
+ einfo " man pgbouncer"
+ einfo
+ einfo "By default, PgBouncer does not have access to any database."
+ einfo "GRANT the permissions needed for your application and make sure that it"
+ einfo "exists in PgBouncer's auth_file."
+ fi
+}