summaryrefslogtreecommitdiff
path: root/dev-db
diff options
context:
space:
mode:
authorAaron W. Swenson <titanofold@gentoo.org>2019-06-22 06:32:54 -0400
committerAaron W. Swenson <titanofold@gentoo.org>2019-06-22 06:33:01 -0400
commita83d846503fa6f3043e6406dc1ae50e792e3a1e4 (patch)
tree0dae3e39702d4b932d3b4523a79a2d09d80a79cc /dev-db
parentpackage.mask: Last rite sci-biology/vaal (diff)
downloadgentoo-a83d846503fa6f3043e6406dc1ae50e792e3a1e4.tar.gz
gentoo-a83d846503fa6f3043e6406dc1ae50e792e3a1e4.tar.bz2
gentoo-a83d846503fa6f3043e6406dc1ae50e792e3a1e4.zip
dev-db/pgagent: Bump to 4.0.0
Package-Manager: Portage-2.3.62, Repoman-2.3.11 Signed-off-by: Aaron W. Swenson <titanofold@gentoo.org>
Diffstat (limited to 'dev-db')
-rw-r--r--dev-db/pgagent/Manifest1
-rw-r--r--dev-db/pgagent/pgagent-4.0.0.ebuild53
2 files changed, 54 insertions, 0 deletions
diff --git a/dev-db/pgagent/Manifest b/dev-db/pgagent/Manifest
index b4f6ba3e7fbb..a8365d4f8d37 100644
--- a/dev-db/pgagent/Manifest
+++ b/dev-db/pgagent/Manifest
@@ -1 +1,2 @@
DIST pgAgent-3.4.0-Source.tar.gz 45081 BLAKE2B 81f074213285253743127188d9e203cb01d8492ce502dc5215279c7c557fdd7f532fa383a4578a8d9cc8ea46668ea971015e4cc5989d1b8022ed8924a92b988b SHA512 3b068fc6f5e51ff20604f8cec3e067d04b5b1537229da15ee442000f5fe834697a4eae86be0e9a58b8ee5da24cc985c8c9804d71cb2a50e93ec4cf9a424a4ff0
+DIST pgAgent-4.0.0-Source.tar.gz 63561 BLAKE2B 1731e748a6a5e76cd8b177162eb5b82ae633d1b507739e3193a8857a0eee0fe775fdaadb871eb5d708c0f7e80558680b5d7d246f4cb5d2bc1c10955bdf9cc09e SHA512 df2d6f5817d83d4cf60f0f1106718225870bcfd2f5b882765e5fd459e1614208225f90b29de492bec5284f3727f3d4be9f724b92ef503fea08029fab22a8fbb4
diff --git a/dev-db/pgagent/pgagent-4.0.0.ebuild b/dev-db/pgagent/pgagent-4.0.0.ebuild
new file mode 100644
index 000000000000..19115c249627
--- /dev/null
+++ b/dev-db/pgagent/pgagent-4.0.0.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+CMAKE_IN_SOURCE_BUILD=1
+
+inherit cmake-utils user
+
+MY_PN=${PN/a/A}
+
+KEYWORDS="~amd64 ~x86"
+
+DESCRIPTION="${MY_PN} is a job scheduler for PostgreSQL"
+HOMEPAGE="https://www.pgadmin.org/download/pgagent-source-code/"
+SRC_URI="mirror://postgresql/pgadmin/${PN}/${MY_PN}-${PV}-Source.tar.gz"
+
+LICENSE="POSTGRESQL GPL-2"
+SLOT="0"
+
+RDEPEND="dev-db/postgresql:*
+ dev-libs/boost
+"
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}/${MY_PN}-${PV}-Source"
+
+src_prepare() {
+ cmake-utils_src_prepare
+
+ sed -e "s:share):share/${P}):" \
+ -i CMakeLists.txt || die "failed to patch CMakeLists.txt"
+}
+
+src_configure() {
+ mycmakeargs=( "-DSTATIC_BUILD:BOOLEAN=FALSE"
+ )
+ cmake-utils_src_configure
+}
+
+src_install() {
+ cmake-utils_src_install
+
+ newinitd "${FILESDIR}/pgagent.initd-r1" "${PN}"
+ newconfd "${FILESDIR}/pgagent.confd" "${PN}"
+
+ rm "${ED}"/usr/{LICENSE,README} || die "failed to remove useless docs"
+}
+
+pkg_preinst() {
+ # This user needs a real shell, and the daemon will use the
+ # ~/.pgpass file from its home directory.
+ enewuser pgagent -1 /bin/bash /home/pgagent
+}