summaryrefslogtreecommitdiff
path: root/dev-db
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2019-07-29 18:19:14 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2019-07-29 19:30:43 +0200
commitba4527020543e5ddba7d9cd30894ee68c2aaca1e (patch)
treef01bc7f4fe23a85e83c28a96a70dd1d9fc51c199 /dev-db
parentdev-db/freetds: Drop 1.00.341-r1 (diff)
downloadgentoo-ba4527020543e5ddba7d9cd30894ee68c2aaca1e.tar.gz
gentoo-ba4527020543e5ddba7d9cd30894ee68c2aaca1e.tar.bz2
gentoo-ba4527020543e5ddba7d9cd30894ee68c2aaca1e.zip
dev-db/freetds: Drop unmaintained live ebuild
Package-Manager: Portage-2.3.69, Repoman-2.3.16 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'dev-db')
-rw-r--r--dev-db/freetds/freetds-9999.ebuild62
1 files changed, 0 insertions, 62 deletions
diff --git a/dev-db/freetds/freetds-9999.ebuild b/dev-db/freetds/freetds-9999.ebuild
deleted file mode 100644
index a18ef188436e..000000000000
--- a/dev-db/freetds/freetds-9999.ebuild
+++ /dev/null
@@ -1,62 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-inherit autotools git-r3
-
-DESCRIPTION="Tabular Datastream Library"
-HOMEPAGE="https://www.freetds.org/"
-EGIT_REPO_URI="https://github.com/FreeTDS/${PN}.git"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS=""
-IUSE="gnutls iconv kerberos libressl mssql iodbc odbc ssl"
-RESTRICT="test"
-
-# sed, grep, and awk are used by the build system and the osql script.
-COMMON_DEPEND="sys-apps/sed
- sys-apps/grep
- virtual/awk
- gnutls? ( net-libs/gnutls )
- iconv? ( virtual/libiconv )
- iodbc? ( dev-db/libiodbc )
- kerberos? ( virtual/krb5 )
- odbc? ( dev-db/unixODBC )
- ssl? (
- !libressl? ( dev-libs/openssl:0 )
- libressl? ( dev-libs/libressl )
- )"
-
-DEPEND="${COMMON_DEPEND}"
-
-# bind-tools is needed because the osql script calls "host".
-# binutils is for "strings".
-RDEPEND="${COMMON_DEPEND}
- sys-devel/binutils
- net-dns/bind-tools"
-
-# iODBC and unixODBC are mutually-exclusive choices for
-# the ODBC driver manager. Future versions of FreeTDS
-# will throw an error if you specify both.
-REQUIRED_USE="?? ( iodbc odbc )"
-
-src_prepare() {
- default
- eautoreconf
-}
-
-src_configure() {
- local myconf=( $(use_with iodbc) )
- myconf+=( $(use_with odbc unixodbc "${EPREFIX}/usr") )
- myconf+=( $(use_enable iconv libiconv) )
- myconf+=( $(use_with iconv libiconv-prefix "${EPREFIX}/usr") )
- myconf+=( $(use_enable kerberos krb5) )
- myconf+=( $(use_enable mssql msdblib) )
- myconf+=( $(use_with gnutls) )
- myconf+=( $(use_with ssl openssl "${EPREFIX}/usr") )
- myconf+=( --docdir="/usr/share/doc/${PF}" )
-
- econf "${myconf[@]}"
-}