summaryrefslogtreecommitdiff
path: root/dev-db
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2017-06-03 21:57:22 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2017-06-03 23:26:22 +0200
commitd51654ee0326c1d4057800b37712a84ddd26878e (patch)
tree7836c812879d4ac9238e1931ef1729cef84ff742 /dev-db
parentdev-libs/tvision: Bump to EAPI=6 (diff)
downloadgentoo-d51654ee0326c1d4057800b37712a84ddd26878e.tar.gz
gentoo-d51654ee0326c1d4057800b37712a84ddd26878e.tar.bz2
gentoo-d51654ee0326c1d4057800b37712a84ddd26878e.zip
dev-db/xbase: Update HOMEPAGE, dohtml -> HTML_DOCS, drop ltprune.eclass
Merging remaining changes taken from PR#4182 with partially overlapping existing work from tree and adding changes of my own. Gentoo-bug: 594174 Thanks-to: Kacper KoƂodziej <kacper@kolodziej.in> Package-Manager: Portage-2.3.4, Repoman-2.3.2 Closes: https://github.com/gentoo/gentoo/pull/4182
Diffstat (limited to 'dev-db')
-rw-r--r--dev-db/xbase/xbase-3.1.2.ebuild28
1 files changed, 18 insertions, 10 deletions
diff --git a/dev-db/xbase/xbase-3.1.2.ebuild b/dev-db/xbase/xbase-3.1.2.ebuild
index eba9889c70a0..c38abe5a5f24 100644
--- a/dev-db/xbase/xbase-3.1.2.ebuild
+++ b/dev-db/xbase/xbase-3.1.2.ebuild
@@ -2,14 +2,15 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=6
-inherit autotools ltprune
+
+inherit autotools
DESCRIPTION="xbase (i.e. dBase, FoxPro, etc.) compatible C++ class library"
-HOMEPAGE="http://linux.techass.com/projects/xdb/"
+HOMEPAGE="https://sourceforge.net/projects/xdb/ http://linux.techass.com/projects/xdb/"
SRC_URI="mirror://sourceforge/xdb/${PN}64-${PV}.tar.gz"
-SLOT="0"
LICENSE="GPL-2"
+SLOT="0"
KEYWORDS="amd64 ~arm hppa ppc ppc64 x86 ~x86-fbsd"
IUSE="doc static-libs"
@@ -39,15 +40,22 @@ src_configure() {
}
src_install() {
- default
- prune_libtool_files
+ if use doc; then
+ HTML_DOCS+=( html/. )
+ if [[ -e examples/.libs ]] ; then
+ rm -r examples/.libs || die
+ fi
+ dodoc -r examples
+ fi
- # media-tv/linuxtv-dvb-apps collision, bug #208596
- mv "${ED}/usr/bin/zap" "${ED}/usr/bin/${PN}-zap" || die
+ default
+ find "${D}" -name '*.la' -delete || die
if use doc; then
- dohtml html/*
- insinto /usr/share/doc/${PF}/examples
- doins examples/*
+ rm "${ED%/}"/usr/share/doc/${PF}/html/copying.lib || die
+ rm "${ED%/}"/usr/share/doc/${PF}/html/Makefile{,.in,.am} || die
fi
+
+ # media-tv/linuxtv-dvb-apps collision, bug #208596
+ mv "${ED%/}"/usr/bin/{,${PN}-}zap || die
}