summaryrefslogtreecommitdiff
path: root/dev-db
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-07-30 23:55:02 +0100
committerSam James <sam@gentoo.org>2021-07-31 00:29:50 +0100
commite5396d9459edc837e9072b6ac471d2eddcb20d93 (patch)
tree2687deab381cbc0a5d9bc51f407d6a68b7afc4e7 /dev-db
parentapp-mobilephone/smstools: [QA] call tmpfiles_process in pkg_postinst (diff)
downloadgentoo-e5396d9459edc837e9072b6ac471d2eddcb20d93.tar.gz
gentoo-e5396d9459edc837e9072b6ac471d2eddcb20d93.tar.bz2
gentoo-e5396d9459edc837e9072b6ac471d2eddcb20d93.zip
dev-db/etcd: [QA] call tmpfiles_process in pkg_postinst
This is needed to actually apply the tmpfiles configuration we've installed in the ebuild. See tmpfiles.eclass documentation. Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-db')
-rw-r--r--dev-db/etcd/etcd-3.3.23.ebuild10
-rw-r--r--dev-db/etcd/etcd-3.3.24.ebuild10
-rw-r--r--dev-db/etcd/etcd-3.4.10.ebuild10
-rw-r--r--dev-db/etcd/etcd-3.4.11.ebuild10
-rw-r--r--dev-db/etcd/etcd-3.4.14.ebuild10
5 files changed, 40 insertions, 10 deletions
diff --git a/dev-db/etcd/etcd-3.3.23.ebuild b/dev-db/etcd/etcd-3.3.23.ebuild
index 8381d1a4fae4..cf8a5c817d79 100644
--- a/dev-db/etcd/etcd-3.3.23.ebuild
+++ b/dev-db/etcd/etcd-3.3.23.ebuild
@@ -59,6 +59,10 @@ src_compile() {
./build || die
}
+src_test() {
+ ./test || die
+}
+
src_install() {
dobin bin/etcdctl
use doc && dodoc -r Documentation
@@ -82,6 +86,8 @@ src_install() {
fi
}
-src_test() {
- ./test || die
+pkg_postinst() {
+ if use server; then
+ tmpfiles_process ${PN}.conf
+ fi
}
diff --git a/dev-db/etcd/etcd-3.3.24.ebuild b/dev-db/etcd/etcd-3.3.24.ebuild
index d42802d3d244..cfe02273d71b 100644
--- a/dev-db/etcd/etcd-3.3.24.ebuild
+++ b/dev-db/etcd/etcd-3.3.24.ebuild
@@ -52,6 +52,10 @@ src_compile() {
./build || die
}
+src_test() {
+ ./test || die
+}
+
src_install() {
dobin bin/etcdctl
use doc && dodoc -r Documentation
@@ -75,6 +79,8 @@ src_install() {
fi
}
-src_test() {
- ./test || die
+pkg_postinst() {
+ if use server; then
+ tmpfiles_process ${PN}.conf
+ fi
}
diff --git a/dev-db/etcd/etcd-3.4.10.ebuild b/dev-db/etcd/etcd-3.4.10.ebuild
index 4cc5cd41c5e2..052158ea52e9 100644
--- a/dev-db/etcd/etcd-3.4.10.ebuild
+++ b/dev-db/etcd/etcd-3.4.10.ebuild
@@ -52,6 +52,10 @@ src_compile() {
./build || die
}
+src_test() {
+ ./test || die
+}
+
src_install() {
dobin bin/etcdctl
use doc && dodoc -r Documentation
@@ -75,6 +79,8 @@ src_install() {
fi
}
-src_test() {
- ./test || die
+pkg_postinst() {
+ if use server; then
+ tmpfiles_process ${PN}.conf
+ fi
}
diff --git a/dev-db/etcd/etcd-3.4.11.ebuild b/dev-db/etcd/etcd-3.4.11.ebuild
index bb9e9a16f55c..572b8ec43e15 100644
--- a/dev-db/etcd/etcd-3.4.11.ebuild
+++ b/dev-db/etcd/etcd-3.4.11.ebuild
@@ -52,6 +52,10 @@ src_compile() {
./build || die
}
+src_test() {
+ ./test || die
+}
+
src_install() {
dobin bin/etcdctl
use doc && dodoc -r Documentation
@@ -75,6 +79,8 @@ src_install() {
fi
}
-src_test() {
- ./test || die
+pkg_postinst() {
+ if use server; then
+ tmpfiles_process ${PN}.conf
+ fi
}
diff --git a/dev-db/etcd/etcd-3.4.14.ebuild b/dev-db/etcd/etcd-3.4.14.ebuild
index 63f03f9e8d4f..b21d65258252 100644
--- a/dev-db/etcd/etcd-3.4.14.ebuild
+++ b/dev-db/etcd/etcd-3.4.14.ebuild
@@ -281,6 +281,10 @@ src_compile() {
./build || die
}
+src_test() {
+ ./test || die
+}
+
src_install() {
dobin bin/etcdctl
use doc && dodoc -r Documentation
@@ -304,6 +308,8 @@ src_install() {
fi
}
-src_test() {
- ./test || die
+pkg_postinst() {
+ if use server; then
+ tmpfiles_process ${PN}.conf
+ fi
}