summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2024-03-07 18:54:09 +0000
committerSam James <sam@gentoo.org>2024-03-07 18:54:09 +0000
commit127dc03a3c8fa58347375f41795635594a47b2c6 (patch)
treeabf4a35a25ef1a78315433e73814d64a9a21b35a /dev-debug
parentdev-python/evdev: Stabilize 1.7.0 amd64, #926400 (diff)
downloadgentoo-127dc03a3c8fa58347375f41795635594a47b2c6.tar.gz
gentoo-127dc03a3c8fa58347375f41795635594a47b2c6.tar.bz2
gentoo-127dc03a3c8fa58347375f41795635594a47b2c6.zip
dev-debug/lldb: filter LTO (ODR violations)
Bug: https://github.com/llvm/llvm-project/issues/83636 Bug: https://bugs.gentoo.org/914354 Closes: https://bugs.gentoo.org/858389 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-debug')
-rw-r--r--dev-debug/lldb/lldb-15.0.7.ebuild5
-rw-r--r--dev-debug/lldb/lldb-16.0.6-r1.ebuild5
-rw-r--r--dev-debug/lldb/lldb-16.0.6.ebuild5
-rw-r--r--dev-debug/lldb/lldb-17.0.6.ebuild5
-rw-r--r--dev-debug/lldb/lldb-18.1.0.ebuild5
-rw-r--r--dev-debug/lldb/lldb-19.0.0.9999.ebuild5
-rw-r--r--dev-debug/lldb/lldb-19.0.0_pre20240302.ebuild5
7 files changed, 28 insertions, 7 deletions
diff --git a/dev-debug/lldb/lldb-15.0.7.ebuild b/dev-debug/lldb/lldb-15.0.7.ebuild
index 3eff62955fde..70c8d4f38dd7 100644
--- a/dev-debug/lldb/lldb-15.0.7.ebuild
+++ b/dev-debug/lldb/lldb-15.0.7.ebuild
@@ -4,7 +4,7 @@
EAPI=8
PYTHON_COMPAT=( python3_{10..11} )
-inherit cmake llvm llvm.org python-single-r1
+inherit cmake flag-o-matic llvm llvm.org python-single-r1
DESCRIPTION="The LLVM debugger"
HOMEPAGE="https://llvm.org/"
@@ -60,6 +60,9 @@ pkg_setup() {
}
src_configure() {
+ # bug #858389 (https://github.com/llvm/llvm-project/issues/83636)
+ filter-lto
+
# LLVM_ENABLE_ASSERTIONS=NO does not guarantee this for us, #614844
use debug || local -x CPPFLAGS="${CPPFLAGS} -DNDEBUG"
diff --git a/dev-debug/lldb/lldb-16.0.6-r1.ebuild b/dev-debug/lldb/lldb-16.0.6-r1.ebuild
index df16f4ee368c..ba5732325fa4 100644
--- a/dev-debug/lldb/lldb-16.0.6-r1.ebuild
+++ b/dev-debug/lldb/lldb-16.0.6-r1.ebuild
@@ -4,7 +4,7 @@
EAPI=8
PYTHON_COMPAT=( python3_{10..12} )
-inherit cmake llvm llvm.org python-single-r1
+inherit cmake flag-o-matic llvm llvm.org python-single-r1
DESCRIPTION="The LLVM debugger"
HOMEPAGE="https://llvm.org/"
@@ -54,6 +54,9 @@ pkg_setup() {
}
src_configure() {
+ # bug #858389 (https://github.com/llvm/llvm-project/issues/83636)
+ filter-lto
+
# LLVM_ENABLE_ASSERTIONS=NO does not guarantee this for us, #614844
use debug || local -x CPPFLAGS="${CPPFLAGS} -DNDEBUG"
diff --git a/dev-debug/lldb/lldb-16.0.6.ebuild b/dev-debug/lldb/lldb-16.0.6.ebuild
index 3ba34e51a3a7..aab1e8475662 100644
--- a/dev-debug/lldb/lldb-16.0.6.ebuild
+++ b/dev-debug/lldb/lldb-16.0.6.ebuild
@@ -4,7 +4,7 @@
EAPI=8
PYTHON_COMPAT=( python3_{10..12} )
-inherit cmake llvm llvm.org python-single-r1
+inherit cmake flag-o-matic llvm llvm.org python-single-r1
DESCRIPTION="The LLVM debugger"
HOMEPAGE="https://llvm.org/"
@@ -60,6 +60,9 @@ pkg_setup() {
}
src_configure() {
+ # bug #858389 (https://github.com/llvm/llvm-project/issues/83636)
+ filter-lto
+
# LLVM_ENABLE_ASSERTIONS=NO does not guarantee this for us, #614844
use debug || local -x CPPFLAGS="${CPPFLAGS} -DNDEBUG"
diff --git a/dev-debug/lldb/lldb-17.0.6.ebuild b/dev-debug/lldb/lldb-17.0.6.ebuild
index da6233562fa0..2e5e3c8947e8 100644
--- a/dev-debug/lldb/lldb-17.0.6.ebuild
+++ b/dev-debug/lldb/lldb-17.0.6.ebuild
@@ -4,7 +4,7 @@
EAPI=8
PYTHON_COMPAT=( python3_{10..12} )
-inherit cmake llvm llvm.org python-single-r1
+inherit cmake flag-o-matic llvm llvm.org python-single-r1
DESCRIPTION="The LLVM debugger"
HOMEPAGE="https://llvm.org/"
@@ -60,6 +60,9 @@ pkg_setup() {
}
src_configure() {
+ # bug #858389 (https://github.com/llvm/llvm-project/issues/83636)
+ filter-lto
+
# LLVM_ENABLE_ASSERTIONS=NO does not guarantee this for us, #614844
use debug || local -x CPPFLAGS="${CPPFLAGS} -DNDEBUG"
diff --git a/dev-debug/lldb/lldb-18.1.0.ebuild b/dev-debug/lldb/lldb-18.1.0.ebuild
index 421afb18bc7e..7734bd04d4e9 100644
--- a/dev-debug/lldb/lldb-18.1.0.ebuild
+++ b/dev-debug/lldb/lldb-18.1.0.ebuild
@@ -4,7 +4,7 @@
EAPI=8
PYTHON_COMPAT=( python3_{10..12} )
-inherit cmake llvm.org llvm-utils python-single-r1
+inherit cmake flag-o-matic llvm.org llvm-utils python-single-r1
DESCRIPTION="The LLVM debugger"
HOMEPAGE="https://llvm.org/"
@@ -55,6 +55,9 @@ llvm.org_set_globals
src_configure() {
llvm_prepend_path "${LLVM_MAJOR}"
+ # bug #858389 (https://github.com/llvm/llvm-project/issues/83636)
+ filter-lto
+
# LLVM_ENABLE_ASSERTIONS=NO does not guarantee this for us, #614844
use debug || local -x CPPFLAGS="${CPPFLAGS} -DNDEBUG"
diff --git a/dev-debug/lldb/lldb-19.0.0.9999.ebuild b/dev-debug/lldb/lldb-19.0.0.9999.ebuild
index 6d10771e220b..c79bdcdf6f3d 100644
--- a/dev-debug/lldb/lldb-19.0.0.9999.ebuild
+++ b/dev-debug/lldb/lldb-19.0.0.9999.ebuild
@@ -4,7 +4,7 @@
EAPI=8
PYTHON_COMPAT=( python3_{10..12} )
-inherit cmake llvm.org llvm-utils python-single-r1
+inherit cmake flag-o-matic llvm.org llvm-utils python-single-r1
DESCRIPTION="The LLVM debugger"
HOMEPAGE="https://llvm.org/"
@@ -54,6 +54,9 @@ llvm.org_set_globals
src_configure() {
llvm_prepend_path "${LLVM_MAJOR}"
+ # bug #858389 (https://github.com/llvm/llvm-project/issues/83636)
+ filter-lto
+
# LLVM_ENABLE_ASSERTIONS=NO does not guarantee this for us, #614844
use debug || local -x CPPFLAGS="${CPPFLAGS} -DNDEBUG"
diff --git a/dev-debug/lldb/lldb-19.0.0_pre20240302.ebuild b/dev-debug/lldb/lldb-19.0.0_pre20240302.ebuild
index 6d10771e220b..c79bdcdf6f3d 100644
--- a/dev-debug/lldb/lldb-19.0.0_pre20240302.ebuild
+++ b/dev-debug/lldb/lldb-19.0.0_pre20240302.ebuild
@@ -4,7 +4,7 @@
EAPI=8
PYTHON_COMPAT=( python3_{10..12} )
-inherit cmake llvm.org llvm-utils python-single-r1
+inherit cmake flag-o-matic llvm.org llvm-utils python-single-r1
DESCRIPTION="The LLVM debugger"
HOMEPAGE="https://llvm.org/"
@@ -54,6 +54,9 @@ llvm.org_set_globals
src_configure() {
llvm_prepend_path "${LLVM_MAJOR}"
+ # bug #858389 (https://github.com/llvm/llvm-project/issues/83636)
+ filter-lto
+
# LLVM_ENABLE_ASSERTIONS=NO does not guarantee this for us, #614844
use debug || local -x CPPFLAGS="${CPPFLAGS} -DNDEBUG"