summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-01-18 15:38:03 +0100
committerMichał Górny <mgorny@gentoo.org>2024-01-19 15:44:09 +0100
commitad5b82e3a1dd57f354e4ab8c64bd46aad178ef6b (patch)
tree0cfef65d5988e9fbbf17cab3682a5c97761a5e71 /dev-debug
parentMove {dev-util → dev-debug}/d-feet (diff)
downloadgentoo-ad5b82e3a1dd57f354e4ab8c64bd46aad178ef6b.tar.gz
gentoo-ad5b82e3a1dd57f354e4ab8c64bd46aad178ef6b.tar.bz2
gentoo-ad5b82e3a1dd57f354e4ab8c64bd46aad178ef6b.zip
Move {dev-util → dev-debug}/d-spy
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-debug')
-rw-r--r--dev-debug/d-spy/Manifest2
-rw-r--r--dev-debug/d-spy/d-spy-1.6.0.ebuild43
-rw-r--r--dev-debug/d-spy/d-spy-1.8.0.ebuild43
-rw-r--r--dev-debug/d-spy/metadata.xml11
4 files changed, 99 insertions, 0 deletions
diff --git a/dev-debug/d-spy/Manifest b/dev-debug/d-spy/Manifest
new file mode 100644
index 000000000000..511442806a43
--- /dev/null
+++ b/dev-debug/d-spy/Manifest
@@ -0,0 +1,2 @@
+DIST d-spy-1.6.0.tar.xz 215844 BLAKE2B 4811591024d3b599e5e10354db8aa14d5b80bf6fb3c8bfbeadcf5d9c14501af0d00368643cb58eac5ad9452b541743ce3ff9f8376202270f635078876a1012b3 SHA512 7a65bd64320a69eb54077a359381bda35f285b42f4181bf972bc790a8002a773b66c23303e5e94c3dec8c7b9bfc7b8aa60a5ce60f2eb47459ce3dfd634a05703
+DIST d-spy-1.8.0.tar.xz 232944 BLAKE2B cb6f90e9b3d779aa5a76bc93f16e9ae677af029b72451bbb983ffeb06b99a92aa2402ef8b6f6a6c6b4ad4f6ba49a924db37d7e9fc9cb98157a6475a0ec234267 SHA512 49c0ff250a91110014f98453ed6958cf4b5191cc0c8d31c5e63b1408864eaf0906ab3860b0479400a04a8614ee36fe5b9527b179e6346bdb5616cb188d2648f0
diff --git a/dev-debug/d-spy/d-spy-1.6.0.ebuild b/dev-debug/d-spy/d-spy-1.6.0.ebuild
new file mode 100644
index 000000000000..a3ef33127ea0
--- /dev/null
+++ b/dev-debug/d-spy/d-spy-1.6.0.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit gnome.org meson xdg
+
+DESCRIPTION="D-spy is a blisteringly fast D-Bus debugger"
+HOMEPAGE="https://gitlab.gnome.org/GNOME/d-spy"
+
+LICENSE="GPL-3+ LGPL-3+"
+SLOT="1"
+KEYWORDS="amd64"
+
+DEPEND="
+ >=dev-libs/glib-2.68:2
+ >=gui-libs/gtk-4.6:4
+ >=gui-libs/libadwaita-1.0:1
+"
+RDEPEND="
+ ${DEPEND}
+ >=sys-apps/dbus-1
+"
+BDEPEND="
+ dev-libs/appstream-glib
+ dev-util/desktop-file-utils
+ sys-devel/gettext
+ virtual/pkgconfig
+"
+
+src_install() {
+ meson_src_install
+}
+
+pkg_postinst() {
+ xdg_icon_cache_update
+ xdg_desktop_database_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+ xdg_desktop_database_update
+}
diff --git a/dev-debug/d-spy/d-spy-1.8.0.ebuild b/dev-debug/d-spy/d-spy-1.8.0.ebuild
new file mode 100644
index 000000000000..75eed80ac1d1
--- /dev/null
+++ b/dev-debug/d-spy/d-spy-1.8.0.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit gnome.org meson xdg
+
+DESCRIPTION="D-spy is a blisteringly fast D-Bus debugger"
+HOMEPAGE="https://gitlab.gnome.org/GNOME/d-spy"
+
+LICENSE="GPL-3+ LGPL-3+"
+SLOT="1"
+KEYWORDS="~amd64 ~arm64"
+
+DEPEND="
+ >=dev-libs/glib-2.68:2
+ >=gui-libs/gtk-4.6:4
+ >=gui-libs/libadwaita-1.0:1
+"
+RDEPEND="
+ ${DEPEND}
+ >=sys-apps/dbus-1
+"
+BDEPEND="
+ dev-libs/appstream-glib
+ dev-util/desktop-file-utils
+ sys-devel/gettext
+ virtual/pkgconfig
+"
+
+src_install() {
+ meson_src_install
+}
+
+pkg_postinst() {
+ xdg_icon_cache_update
+ xdg_desktop_database_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+ xdg_desktop_database_update
+}
diff --git a/dev-debug/d-spy/metadata.xml b/dev-debug/d-spy/metadata.xml
new file mode 100644
index 000000000000..5da3a9ec9abb
--- /dev/null
+++ b/dev-debug/d-spy/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>gnome@gentoo.org</email>
+ <name>Gentoo GNOME Desktop</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="gnome-gitlab">GNOME/d-spy</remote-id>
+ </upstream>
+</pkgmetadata>