summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2023-09-22 14:05:55 +0200
committerMaciej Barć <xgqt@gentoo.org>2023-09-22 16:09:42 +0200
commite4fd77672aacd2bf86234958f7154741e9b4ea3a (patch)
treeb4429883bb381e668e4ef046ac7c2c23b9d94b64 /dev-dotnet/coco/coco-2014.12.24-r1.ebuild
parentRevert "net-firewall/ipset: add 7.19" (diff)
downloadgentoo-e4fd77672aacd2bf86234958f7154741e9b4ea3a.tar.gz
gentoo-e4fd77672aacd2bf86234958f7154741e9b4ea3a.tar.bz2
gentoo-e4fd77672aacd2bf86234958f7154741e9b4ea3a.zip
dev-dotnet/coco: use default dotnet-pkg_src_install
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'dev-dotnet/coco/coco-2014.12.24-r1.ebuild')
-rw-r--r--dev-dotnet/coco/coco-2014.12.24-r1.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/dev-dotnet/coco/coco-2014.12.24-r1.ebuild b/dev-dotnet/coco/coco-2014.12.24-r1.ebuild
new file mode 100644
index 000000000000..11dab3e015e6
--- /dev/null
+++ b/dev-dotnet/coco/coco-2014.12.24-r1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DOTNET_PKG_COMPAT=6.0
+unset NUGET_PACKAGES
+
+inherit dotnet-pkg
+
+DESCRIPTION="The compiler generator Coco/R for C#"
+HOMEPAGE="https://github.com/boogie-org/coco/"
+
+if [[ "${PV}" == *9999* ]] ; then
+ inherit git-r3
+
+ EGIT_REPO_URI="https://github.com/boogie-org/${PN}.git"
+else
+ SRC_URI="https://github.com/boogie-org/${PN}/archive/${PV}.tar.gz
+ -> ${P}.tar.gz"
+ KEYWORDS="~amd64"
+fi
+
+LICENSE="GPL-2+"
+SLOT="0"
+
+DOTNET_PKG_PROJECTS=( "${S}/Coco.csproj" )
+PATCHES=( "${FILESDIR}/${P}-Coco-csproj.patch" )
+
+src_unpack() {
+ dotnet-pkg_src_unpack
+
+ if [[ -n ${EGIT_REPO_URI} ]] ; then
+ git-r3_src_unpack
+ fi
+}